wayland (probably) crashing on N3150

Bug #1726842 reported by Hadmut Danisch on 2017-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Hi,

I just installed 17.10 (64) from the regular 17.10 ubuntu desktop image onto a ASRock Beebox N3150 with N3150 CPU and

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 21)

After Installation the system booted (but required the nodmodeset flag, otherwise the screen remains black and shows just the mouse pointer or nothing) and showed the regular graphical login (gdm I guess), but immediately after entering the password the system reproducably froze with a black screen. Even the mouse pointer. (Since I had no second computer at the moment, I cannot tell whether the kernel was dead or still working to allow network login.)

There's web pages like https://itsfoss.com/switch-xorg-wayland/ telling how to start the session with X11 instead of Wayland, but in contrast to this description the session selection button was absent. I then brought the machine into recovery mode and tried to install more sessions, but did not find the suitable package which brings the "Ubuntu on Xorg" session.

I then gave up and reinstalled the system from scratch with Lubuntu 17.10, which worked well, and to take this as a starting point to install other desktops like ubuntu and xubuntu. They all are installed and work, but they do run Xorg/X11. I don't see how to make the system start Wayland now.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1726842/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
gorgooger (gorgooger) wrote :

Well,
How should we do this?
We cannot pinpoint this to a single package, the screen stays black, as soon as the graphics is switched.
When you upgrade from 17.04 to 17.10 on an Acer R11 you will not be able to access the device locally.

gorgooger (gorgooger) wrote :

booting Ubuntu-17.10.1 or Ubuntu-18.04 Aspire R3-131T results in a black screen right from the beginning.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers