Video watch USB disconnects abruptly with "Unsafe device removal" message

Bug #172642 reported by Amaroq on 2007-11-28
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have a video watch I bought from thinkgeek.com. When I hook it up via USB, it will stay connected for a while. But if I try to do something that makes the OS read or modify it too much, it will disconnect with the unsafe USB device removal message.

I was hoping I could get by without this happening long enough to move my music off of it onto my computer. But I wasn't so lucky. The disconnection happened during the move, and when I got it plugged back in there were random, gibberish file names and directory names strewn all across the device's root directory as well as its music subdirectory and most of my music was corrupted.

I followed the instructions for debugging removable devices.

Below is the included information suggested by the instructions.

amaroq@Amaroq:~/Desktop/devtest$ id
uid=1000(amaroq) gid=1000(amaroq) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),104(scanner),112(netdev),113(lpadmin),115(powerdev),117(admin),1000(amaroq)
amaroq@Amaroq:~/Desktop/devtest$ id hal
id: hal: No such user
amaroq@Amaroq:~/Desktop/devtest$ id haldaemon
uid=107(haldaemon) gid=114(haldaemon) groups=114(haldaemon),24(cdrom),25(floppy),46(plugdev),115(powerdev)
amaroq@Amaroq:~/Desktop/devtest$ uname -a
Linux Amaroq 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

I am using Ubuntu 7.10, upgraded from a fresh and updated install of 7.04.

Amaroq (coolsteve64) wrote :
Amaroq (coolsteve64) wrote :
Amaroq (coolsteve64) wrote :
Amaroq (coolsteve64) wrote :
Amaroq (coolsteve64) wrote :

The instructions said only to do this with Dapper, but I figured I'd include it anyway just to be on the safe side.

Amaroq (coolsteve64) wrote :

Oddly enough, windows didn't seem to notice the strewn file/dir names. I ran an error detection/fix from windows' properties > tools tab of the device. I'm not sure whether it was windows itself, or the error detection run, but the filenames were cleaned up. The strewn stuff was gone, though the only stuff left was the uncorrupted files. The device also did not disconnect at all when plugged into the windows box, which relieves me of my suspicion that it may have been the device itself.

Amaroq (coolsteve64) wrote :

Another just in case sorta thing. Just in case you guys need this.

It went on for quite some time (a couple of minutes), but it did indeed stop with a little somethin' at the end.

Adam Niedling (krychek) wrote :

Has this issue been solved already?

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers