Black Screen after Upgrade from Kubuntu 17.04 to 17.10

Bug #1725169 reported by Woko on 2017-10-20
This bug affects 4 people
Affects Status Importance Assigned to Milestone

Bug Description

I just upgraded Kubuntu from 17.04 to 17.10 on two machines with the same Result:

After reboot, the first kernel in grub was 'linux-image-4.13.0-16-lowlatency'.
This kernel does not work with the nvidia-grafic-card and lead to a black screen.

After purging this kernel in a tty-session it booted up smothely.

I think this can help many others.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xorg 1:7.7+19ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 384.90 Tue Sep 19 19:17:35 PDT 2017
 GCC version: gcc version 7.2.0 (Ubuntu 7.2.0-8ubuntu3)
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: KDE
Date: Fri Oct 20 09:57:26 2017
DistUpgraded: 2017-10-20 08:57:01,633 DEBUG Running PostInstallScript: './'
DistroCodename: artful
DistroVariant: kubuntu
 bbswitch, 0.8, 4.13.0-16-generic, x86_64: installed
 nvidia-384, 384.90, 4.13.0-16-generic, x86_64: installed
ExtraDebuggingInterest: No
 NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd GM107 [GeForce GTX 750 Ti] [1458:362d]
InstallationDate: Installed on 2016-12-23 (300 days ago)
InstallationMedia: Kubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.1)
 Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 062a:4102 Creative Labs
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Gigabyte Technology Co., Ltd. Z170X-Gaming 3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic root=UUID=99e6e2ce-07c5-4553-be22-2ccd3c3a73cc ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to artful on 2017-10-20 (0 days ago) 06/30/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F22d
dmi.board.asset.tag: Default string Z170X-Gaming 3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF22d:bd06/30/2017:svnGigabyteTechnologyCo.,Ltd.:pnZ170X-Gaming3:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnZ170X-Gaming3:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring: Default string Z170X-Gaming 3
dmi.product.version: Default string
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Woko (wolfram-koehn) wrote :
Tom Kidman (tom-kidman) wrote :

Same problem here - booting kubuntu 17.10 using the new, default 'lowlatency' kernel led to a black screen. Manually selecting the 'generic' kernel via the advanced options in grub worked fine. I've got an nvidia 780 card.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Woko (wolfram-koehn) wrote :

The 'lowlatency' kernel was installed during the upgrade. I never used it before. As I know it's a realtime-kernel and there is no need for it on a desktop pc.

Tim O'Callaghan (timo-linux) wrote :

Currently using the graphics team ppa:

This is an issue with the nvidia driver (in my case 387.12) not supporting the low latency kernel. during nvidia DKMS compilation an error is generated making the module compile fail.

root# cat /var/crash/nvidia-378.0.crash
ProblemType: Package
DKMSKernelVersion: 4.13.0-16-lowlatency
Date: Sun Nov 19 22:49:50 2017
Package: nvidia-378 378.13-0ubuntu0~gpu17.04.3
PackageVersion: 378.13-0ubuntu0~gpu17.04.3
SourcePackage: nvidia-graphics-drivers-378
Title: nvidia-378 378.13-0ubuntu0~gpu17.04.3: nvidia-378 kernel module failed to build

CC [M] /var/lib/dkms/nvidia-378/378.13/build/nvidia/nv-cray.o
In file included from /var/lib/dkms/nvidia-378/378.13/build/nvidia/nv-dma.c:15:0:
/var/lib/dkms/nvidia-378/378.13/build/common/inc/nv-linux.h:227:2: error: #error "This driver requires the ability to change memory types!"
 #error "This driver requires the ability to change memory types!"

I suspect we need the newer dkms driver 387.22? according to arch linux:

Tim O'Callaghan (timo-linux) wrote :

ignore the 387.12 i meant 378

Tim O'Callaghan (timo-linux) wrote :

related to #1733227 ?

Tim O'Callaghan (timo-linux) wrote :

Try this:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt-get install nvidia-387 nvidia-387-dev nvidia-modprobe nvidia-opencl-icd-387 nvidia-settings

cd /var/lib/dpkg/info/
nano nvidia-387.postinst
# go to line ~208 in file 'nvidia-387.postinst' and change $KERNELS to $CURRENT_KERNEL and save
dpkg-reconfigure nvidia-387

NVIDIA dkms kernel modules re-compiled without a problem. not sure if optimus working for me yet though

Segher (zeuger) wrote :

I did what Tim suggested on a fresh install of Ubuntu 17.10 nut it doesn’t work on my laptop with GeForce GTX 1060. Still boots to a black screen. Booting with HDMI cable connected however, does work fine. Optimus is not available in NVIDIA settings. Is this a different bug?

Woko (wolfram-koehn) wrote :

In my humble opinion we have two problems here:
1. The unasked installation of the lowlatency-kernel during upgrade from 17.04 to 17.10.
2. Some nvidia driver don't work with that kernel.

As far as I know there is no need for a lowlatency-kernel, except of some audio-applications and one-core systems.

Correct me, if I'm wrong.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 17.10 (artful) reached end-of-life on July 19, 2018.

See this document for currently supported Ubuntu releases:

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

affects: xorg (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers