17.04 doesn't install properly on SD card slot

Bug #1710307 reported by foobar on 2017-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Used standard ISO; standard install procedure; SD card in /dev/mmcblk0

Installed just fine, but won't boot.

It turns out that this HP Envy refuses to boot from SD card slot, so I put SD card in card reader on /dev/sdb.

Problem is: Ubuntu boot process is still looking for /dev/mmcblk0p1 !!

Why in the world is Ubuntu looking for /dev/mmcblk0 when the SD card is being booted from /dev/sdb ?

Soooo, I re-installed Ubuntu ISO onto SD card while in /dev/sdc.

That worked fine, even though it booted on /dev/sdb.

But it *should* have worked when Ubuntu was installed onto this same card when it was plugged into the /dev/mmcblk0 slot.

For the record, the /dev/mmcblk0 slot is much faster than the USB SD card reader, so installing Ubuntu onto this SD card while plugged into this SD card slot is much faster, and should be preferred.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1710307/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
foobar (hbaker1) wrote :

I'd love to know which package this is; it's part of the boot process, but (to my knowledge) there aren't any packages associated with the boot process.

[This is not an automated message. Yes, bot, your message reached me inappropriately.]

Gustavo Silva (gsilvapt) on 2017-08-27
tags: added: kernel-media
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers