[needs-packaging] gtk 4.0

Bug #1656635 reported by Jeremy Bicha on 2017-01-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned

Bug Description

gtk3 is stable now with the 3.22 series.

The next version of gtk, gtk4, is now in development with the first major release 3.90 expected in March 2017. A stable 4.0 is expected about 2 years later.

https://wiki.gnome.org/Projects/GTK+/Roadmap

Like GTK3, this package will be maintained by the Debian GNOME team although several patches will be maintained by the Ubuntu Desktop Team with help from Ubuntu GNOME developers.

Currently, it's not expected for anything in the Ubuntu Desktop to depend on gtk4 for Ubuntu 17.04.

It might not even be needed by GNOME 3.24, but future GNOME versions will begin using gtk4. Note that GNOME does not intend to bump GNOME's major version number to 4 to match GTK.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers