[Xubuntu 7.10] keyboard delay when typing text. Result: missing letters.

Bug #164346 reported by Pjotr12345 on 2007-11-21
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The keyboard of my laptop doesn't function properly in Xubuntu 7.10. When I type for example my password, I need to wait one second between each letter, otherwise the letter is skipped. This happens also when I type text in Firefox and in other applications.

It's a multi-boot laptop, a Sony Vaio VGN-BX296VP. Pentium M 1,7 Ghz processor, 1 GB DDR2 RAM, Intel video card, Intel Centrino wireless. Both Ubuntu 7.10 (Gnome) and Fluxbuntu 7.10 (Fluxbox) don't have this problem on my laptop. Fedora 7 (Gnome) and Mandriva 2008 (Gnome) don't have this problem either.

Something to do with Xfce?

adamis (adamis) wrote :

Not sure if my problem is the same or not here but I'm having a similar issue. When I type I'm able to out type the keyboard. That is to say that the computer is lagging about two or three words behind me as I type. I haven't tried all of the applications to see if this happens but this is happening for sure with Firefox and with Openoffice so I think it is system wide.

The laptop is an Althlon 64 X2 (running the 32bit version of Xubuntu 7.10) with 2gb of RAM. It has NVIDIA graphics (using the proprietary driver) and is currently running compiz. I have tried disabling Compiz and it didn't seem to make any difference but I noticed that if I drop out of X and into a console the typing returns to normal with no delay at all so this definitly appears to be an issue with X.

Another thing I have noticed is that the delay seems to exasperate with the more characters used. For example, If I just alternate quickly between the letter "a" and "z" really quickly the computer is able to keep up. However, If I use a wide variety of letters like typing this setence it starts to get farther and farther behind. I probably type in the 50-70wpm so I'm not exactly a fast typer by any means.

Gauvain Pocentek (gpocentek) wrote :

If the problem occurs during the gdm login, this is probably not related to Xfce.

Pjotr12345 (computertip) wrote :

The problem is no longer there in Xubuntu 8.04 Hardy Heron. Happy now. :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments