dhcp3-client fails on pcmcia wireless

Bug #16390 reported by Lance Lassetter on 2005-04-23
6
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned

Bug Description

Please see above url as posted by the admin of the dhcp server.

dhcp3-client establishes connect, gets an ip address, then does not send the
proper ACK packet back to the dhcp server so the connection is lost.

there error in syslog is:

network is unreachable, there are no persisten dhcp leases in database.

this is with SSID hidden and Mac address filtering.

afaik the dhcp server is open source dhcp server. i have not the specifics on
the server software, only that it runs on an open source system.

the admin and i have concluded that dhcp3-client or some other network package
in ubuntu is not sendng the proper ACK response to the dhcp server. the above
url has all of that information.

afaik the same thing happens with dhcpcd client which was made with alien from
the dhcpcd homepage AFTER none of the above worked.

I'm marking this package as UNKNOWN as it doesn't seem specific to the dhcp
client used.

Could it possibly be dhcp-common affecting this?

http://uclinux.info/lance/ubuntu/bugs/dhcp-client_ubuntu: http://uclinux.info/lance/ubuntu/bugs/dhcp-client_ubuntu

Lance Lassetter (lance-uclinux) wrote :

I tested this in Fedora Core 3 and it works fine with their dhcp client software.

Matt Zimmerman (mdz) wrote :

It works fine for me with dhcp3-client and a PCMCIA wireless card.

Please send the output from dhclient3, and tcpdump output as well, showing the
problem.

Lance Lassetter (lance-uclinux) wrote :

going to do a fresh install of ubuntu hoary and see if there is still a problem.

will submit tcpdump output and dhclient3 output.

lance(stuNNed)

Lance Lassetter (lance-uclinux) wrote :

The issue seems to be with certain firewalling software on the local computer.
ipkungfu iptables setup as well as firehol both affect outgoing ACK packets.
Tested with firestarter, left the laptop connected to the same wireless network
for over 24 hours and worked like a charm.

mdz, do you still need tcpdump output and dhclient syslog entries with those
firewalling systems enabled?

Lance(stuNNed)

Lance Lassetter (lance-uclinux) wrote :

Created an attachment (id=2442)
tcpdump of failing wireless in ubuntu

Lance Lassetter (lance-uclinux) wrote :

Created an attachment (id=2443)
wireless fails syslog output dhclient3

Lance Lassetter (lance-uclinux) wrote :

requested text output submitted.

Lance Lassetter (lance-uclinux) wrote :

I'll further test. I think it's universe firewall related. Would there be a
reason for that that is specific to ubuntu?

Matt Zimmerman (mdz) wrote :

Closing, since this is apparently a problem with the firewall configuration, and
not with Ubuntu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.