USB drive has not automounted since Feisty upgrade

Bug #163386 reported by Endolith on 2007-11-17
2
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

and still doesn't work in Gutsy. I will post files from https://wiki.ubuntu.com/DebuggingRemovableDevices

$id
uid=1001(endolith) gid=1001(endolith) groups=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),30(dip),46(plugdev),104(scanner),119(fuse),1001(endolith)

$id hal
id: hal: No such user

$ id haldaemon
uid=107(haldaemon) gid=114(haldaemon) groups=114(haldaemon),24(cdrom),25(floppy),46(plugdev),115(powerdev)

$ uname -a
Linux optiplex 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Endolith (endolith) wrote :

when I typed "sudo udevmonitor -e | tee udev.log", nothing happened, so udev.log is empty.

Endolith (endolith) wrote :
Endolith (endolith) wrote :
Endolith (endolith) wrote :
Endolith (endolith) wrote :

ls -l /dev/sd*

brw-rw---- 1 root disk 8, 0 2007-11-17 08:00 /dev/sda
brw-rw---- 1 root disk 8, 1 2007-11-17 08:00 /dev/sda1
brw-rw---- 1 root disk 8, 2 2007-11-17 13:00 /dev/sda2
brw-rw---- 1 root disk 8, 3 2007-11-17 08:00 /dev/sda3
brw-rw---- 1 root disk 8, 5 2007-11-17 08:00 /dev/sda5
brw-rw---- 1 root plugdev 8, 16 2007-11-17 13:30 /dev/sdb
brw-rw---- 1 root plugdev 8, 17 2007-11-17 13:30 /dev/sdb1

Endolith (endolith) wrote :

More background information is available at http://ubuntuforums.org/showthread.php?t=608210 and linked question https://answers.launchpad.net/ubuntu/+question/11000

No one can help me with this?

Endolith (endolith) wrote :

Can anyone help me with this? I've asked in at least 4 different places that I'm supposed to be able to get answers. It's been 8 months now since it stopped working.

Endolith (endolith) wrote :

Still doesn't work. I ran fsck and it modified the FAT partition a little, which caused it to show up in Computer as a "black drive" but it sill won't mount if I click on it. It gives me error message "Invalid mount option when attempting to mount the volume" and "DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

Every partition mounts just fine if I do it manually. Why won't the computer recognize them automatically?

http://ubuntuforums.org/showthread.php?t=608210

Endolith (endolith) wrote :

It seems that this was a combination of the "usefree" option and the FSINFO sector. It appears to be fixed now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers