USB DVB-T tuner MSI Mega Sky 580 not working

Bug #163336 reported by Mr.Dan on 2007-11-17
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Hello,
I have a MSI Mega Sky 580 DVB-T USB tuner, which worked for me perfectly in Ubuntu 6.06 and 6.10
I use always the same method to get it to work:

hg clone http://linuxtv.org/hg/v4l-dvb
make, sudo make install
install dvb-utils
firmware wget http://blog.openheads.org/wp-content/work/dvb-usb-megasky-02.fw to /lib/firmware/$(uname -r)

and then I was usually able to open my channels.conf with VLC and watch the TV

now in 7.10 i'm experiencing problems...

lsusb
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 004: ID 0db0:5581 Micro Star International <---THIS IS IT!
Bus 001 Device 003: ID 0458:002e KYE Systems Corp. (Mouse Systems)
Bus 001 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 003: ID 5986:0100
Bus 002 Device 001: ID 0000:0000

 dmesg | grep dvb
[ 16.024000] dvb-usb: found a 'MSI Mega Sky 55801 DVB-T USB2.0' in warm state.
[ 16.024000] dvb-usb: This USB2.0 device cannot be run on a USB1.1 port. (it lacks a hardware PID filter)
[ 16.024000] dvb-usb: MSI Mega Sky 55801 DVB-T USB2.0 error while loading driver (-19)
[ 16.024000] usbcore: registered new interface driver dvb_usb_gl861

(i see the problem in the USB1.1 vs USB2.0 mismatch, i have no USB1.1 in my laptop (Acer Aspire 5104 WLMi))

scan cz-praha
scanning cz-praha
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:2247: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 2 No such file or directory

I tried to modprobe ehci_hcd but it didn't help
I thought this DVB tuner should work out of the box in Gutsy
thanks

Hello

I this still a problem under Hardy and a current version of dvb-utils?

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers