1.79gb ram detected, 8gb ram installed

Bug #1633161 reported by Federico Cavallo on 2016-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have installed elementary OS Loki. I have noticed that using the command htop my computer is finding only 1.79gb available for use. Using dmidecode I find the memory bank here:

Handle 0x0008, DMI type 17, 40 bytes
Memory Device
 Array Handle: 0x0007
 Error Information Handle: Not Provided
 Total Width: 64 bits
 Data Width: 64 bits
 Size: 8192 MB
 Form Factor: SODIMM
 Set: None
 Locator: ChannelA-DIMM0
 Bank Locator: BANK 0
 Type: DDR3
 Type Detail: Synchronous
 Speed: 1600 MHz
 Manufacturer: SK Hynix
 Serial Number: 20111867
 Asset Tag: 9876543210
 Part Number: HMT41GS6BFR8A-PB
 Rank: 2
 Configured Clock Speed: 1600 MHz
 Minimum Voltage: Unknown
 Maximum Voltage: Unknown
 Configured Voltage: 1.35 V

My computer is a lenovo yoga 700isk14 with a core i7 and a nvidia geforce 940m. I am using it with dual boot. It has windows 10 and elementary OS Loki.

Thank you very much.

Matt Spaulding (madsa) wrote :

What is the output of "cat /proc/meminfo"? Also, do you experience this same problem when installing Ubuntu 16.04 or only under elementary?

Federico Cavallo (fcavallo) wrote :

I have only tried with installing elementary OS. I have not tried ubuntu to see if it works there.

Here the result of "cat /proc/meminfo"

MemTotal: 1876364 kB
MemFree: 193728 kB
MemAvailable: 546208 kB
Buffers: 9256 kB
Cached: 625412 kB
SwapCached: 0 kB
Active: 1216268 kB
Inactive: 324272 kB
Active(anon): 908096 kB
Inactive(anon): 166756 kB
Active(file): 308172 kB
Inactive(file): 157516 kB
Unevictable: 112 kB
Mlocked: 112 kB
SwapTotal: 0 kB
SwapFree: 0 kB
Dirty: 184 kB
Writeback: 0 kB
AnonPages: 906108 kB
Mapped: 236320 kB
Shmem: 168860 kB
Slab: 67860 kB
SReclaimable: 35576 kB
SUnreclaim: 32284 kB
KernelStack: 6944 kB
PageTables: 29252 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 938180 kB
Committed_AS: 3856564 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 0 kB
VmallocChunk: 0 kB
HardwareCorrupted: 0 kB
AnonHugePages: 75776 kB
CmaTotal: 0 kB
CmaFree: 0 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 2048 kB
DirectMap4k: 95060 kB
DirectMap2M: 1828864 kB
DirectMap1G: 0 kB

Paul White (paulw2u) wrote :

Marking the Ubuntu content of this bug report as being "Invalid" due to comments made in https://bugs.launchpad.net/ubuntu/+bug/1633161/comments/2.

Please change status of Ubuntu content to "New" if the issue is seen in an Ubuntu (flavour) installation and if possible assign to an appropriate Ubuntu package.

Changed in ubuntu:
status: New → Invalid
Daniel Fore (danrabbit) on 2016-10-18
affects: elementaryos → switchboard-plug-about
Federico Cavallo (fcavallo) wrote :

I have tried the ubuntu live usb and found the same ram problem in my notebook.

Changed in ubuntu:
status: Invalid → New
Zisu Andrei (matzipan) wrote :

I am afraid this sounds more like a kernel issue. Please try and updated kernel and see if it fixes it. Similarly, some motherboards try all sorts of tricks to make ram sticks which are different work at the same frequency, but then they give up.

Can you confirm there exists at least a kernel version or distribution of linux where all your 8 gigs are recognized?

Similarly, you can try memtest86.

Otherwise, there isn't much we can do.

Changed in switchboard-plug-about:
status: New → Invalid
no longer affects: switchboard-plug-about
Zisu Andrei (matzipan) wrote :

Hey Paul,

OP Seems to have seen this issue on a Ubuntu live disk as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers