[needs packaging] koha - library software

Bug #163248 reported by Caroline Ford on 2007-11-17
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Edubuntu
New
Undecided
Unassigned
Debian
New
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Koha needs packaging.

It's open source software to run a library. http://www.koha.org/about-koha/

http://www.koha.org/download/

It's under the GPL

Caroline Ford (secretlondon) wrote :

I've found the perl modules it needs as dependencies:

Zoom - libnet-z3950-perl
HTML::template - libhtml-template-perl
MARC::Record - libmarc-record-perl
MARC::Charset - libmarc-charset-perl
XML::Simple - libxml-simple-perl
Date::Calc - libdate-calc-perl
MARC::File::XML - libmarc-xml-perl
Mail::Sendmail - libmail-sendmail-perl
PDF::API2 - libpdf-api2-perl
GD::Barcode - libgd-barcode-perl
Data::Random - libdata-random-perl
PDF::Reuse::Barcode libpdf-reuse-barcode-perl
Net::LDAP - libnet-ldap-perl

It doesn't seem to recognise libnet-z3950-perl as giving it ZOOM though.

Caroline Ford (secretlondon) wrote :

Net-Z3950-ZOOM-1.21 from cpan needs Yaz 2.1.50+, gutsy ships with libyaz 2.1.18.

Caroline Ford (secretlondon) wrote :

Debian-unstable has libyaz 2.1.18, Debian experimental has 2.1.48+debian.1-0.2

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=438844 is a debian bug about it.

Caroline Ford (secretlondon) wrote :

This is blocked by #163459 (missing libnet-z3950-zoom-perl) which in turn is blocked by #163459 out of date yaz2-dev

This could possibly be solved by syncing libyaz 2.1.48 and libnet-z3950-zoom-perl from Debian experimental. The current libnet-z3950-zoom-perl module needs yaz 2.1.50. I have not tried to compile koha against unstable's version of libnet-z3950-zoom-perl.

Caroline Ford (secretlondon) wrote :

Debian has ITP 389876 for Koha.

Ruben Romero (huayra) wrote :

Since the latest activity in this bug a lot has happened in the koha landscape:

They have actually released a new stable version (3.0.x) and a lot of work has been going around the social, community building part of the project.

As I believe we should get this into Ubuntu, I would like to follow up this wishlist request and point at you the following wiki page created about the debian packaging issue:

http://wiki.koha.org/doku.php?id=debian_packaging_work

Koha is the first and best ILS out there, there is no competitor and thus the debian world (that includes Ubuntu, yes) should take this in their hands and see what can be done.

Maybe the MOTU team could ask the debian team how things are doing regarding this package? I will try to get people interested in this to collaborate, but first we must know where and how this collabporation should happen.

Ruben Romero (huayra) wrote :

There is some activity in the Debian side of things. Maybe we should step up and start the addition of koha to universe?

http://debian.koha-community.org/koha/README

Changed in debian:
status: New → Fix Released
Changed in debian:
status: Fix Released → Unknown

I filed Debian Bug 702134 to spark a new look at getting this into the mix. The folks at Koha are maintaining their own repository to release the software as seen here: http://debian.koha-community.org/koha/

The "Request For Packaging" bugs have previously expired out at Debian but, with the Koha team already maintaining their own pool, we need to assess how hard it would be to run compliance checks to get them into the pools of either Debian or Ubuntu as soon as possible. Koha is a major suite used for integrated operation of libraries and this would allow for increased use of these distros in those situations if we had the software directly available.

Edubuntu has been added though that project may need to be more directly pinged at this point.

Changed in debian:
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.