USB Hard disk data not saved

Bug #162616 reported by Chris Fletcher on 2007-11-14
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Declined for Intrepid by Brian Murray

Bug Description

The following affects Feisty. I haven't been able to check Gutsy yet.

I'm not sure if this is a bug in Gnome or a subsystem like UDEV. But whenever I save a SMALL amount of data to my USB Hard Disk (Which is a 250GB Western Digital Passport - with a 2MB buffer) and then select "Unmount Volume" in Gnome, it unmounts ok, but when I unplug the drive a plug it in again the data isn't there. (Modified files revert to their old version, deleted files reappear and newly created files disappear).

I am assuming that the data is being buffered somewhere but not being saved. Perhaps the changes get saved to the onboard 2MB buffer, but are lost when the power is disconnected (and the Unmounting of the volume doesn't flush this cache - this would explain why big files aren't affected).

Using the same computer, I booted an old live CD version of Ubuntu Dapper and the problem went away, which suggests the problem has emerged between Dapper and Feisty (I haven't been able to check Edgy as I don't have a copy of it). Interestingly, with Dapper, when you unmount it says it is saving data to the disk and not to unplug it. With Feisty, it doesn't.

Next I tested on a different computer (with live CDs). First using Dapper (which worked) and then with Feisty (which wouldn't even let me unmount the volume!!)

Please let me know if I can assist further with any log information or further details.

(Interestingly enough, I also tried this on various propriatary OS's from Redmond. With XP there was no problem but the same problem as described above appeared in Vista!)

One final thing: This didn't happen with a USB memory stick only the HD.

System information:

1st Computer: HP Pavillion dv2000 (1.7Ghz Core 2 Duo)
2nd Computer: Intel Desktop board (2.4Ghz P4)
Portable Drive: Western Digital Passport WDXMS2500TN (250GB)

Adam Niedling (krychek) wrote :

Please test Hardy.

I tested with Hardy and there was no difference (the last version I used
that this wasn't a problem was Dapper, I haven't tested Edgy).

Any small file (I'm presuming any file less than the memory buffer size on
the disk) is still getting lost. I just tried the following on Hardy:

 - I created a file on my Gnome desktop called foo.txt.
 - I opened the file and typed: "test" and saved the file.
 - I plugged my WD drive into the machine and copied the file to the drive.
 - I right clicked the drive icon and selected "Unmount Drive".
 - Unlike the older Gnome desktops, there was no message about writing to
the drive, nor was there any message about being able to safely unplug.
 - After 30 seconds (just to be sure!), I disconnected the drive.
 - I then plugged the drive back in and sure enough, the file was gone!

I'm a little concerned at the low response to this, as it is a serious
isssue that involves DATA LOSS! I am available at ANY time to assist with
this.

Best Regards,

Chris Fletcher.

BrightSparks Internet for Schools
A Division of Split Pea Technologies P/L
Phone: 1300 650 630
Fax: 1300 650 060
Email: <email address hidden>

On Sat, 16 Aug 2008, Adam Niedling wrote:

> Please test Hardy.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> --
> USB Hard disk data not saved
> https://bugs.launchpad.net/bugs/162616
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Adam Niedling (krychek) wrote :

If the same thing happened in vista too then this might be hardware error. My Ubuntu installation is on a WD Passport too and I don't have any problems with it. You don't have another USB HDD to test, do you?

Duane Hinnen (duanedesign) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Duane Hinnen (duanedesign) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We are closing this bug because it lacks the information needed to investigate the problem. If this you are still experiencing this bug with the latest release of Ubuntu please feel free to reopen this bug report. You can click on the current status, under the Status column, and change the Status back to "New". Thanks again and don't hesitate to submit bug reports in the future.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers