system sounds not working

Bug #162336 reported by clutchmm on 2007-11-13
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I did a clean install from feisty to gutsy. After the install I started to apply the custom sounds I was using on feisty but after selecting them in System > Preferences > Sound > Sounds Tab I tried to test the sound by pressing the Play button and nothing happened. I rebooted my system and the only sound that worked was the sound that plays when the GDM first loads. I managed to make some changes in /etc/gdm/gdm.conf to get the login sounds working but the others don't. When I double click the sound file it loads into Totem and plays just fine. My movies and music play fine in mplayer and audacious but I get device errors when I try to record sound with audacity. I have spent several hours trying to fix this issue with workarounds and fixes I have found online. I have installed every package that Pulse Audio, OSS, ALSA, and ,ESD have to offer. I have tried switching between all of them and each one the Test button plays the testing tone but my system sounds still won't play. The only error I get in changing the sound mixers is when I test the sound capture, on every option I get "Failed to construct test pipeline for 'gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat'".
I am running an MSI laptop with an AMD 64 3400+, 2 gigs of ram, and an SIS chipset. I was running Feisty amd64 but my clean install is Gutsy i386 since it has more compatible applications.

Olindo Pindaro (o-pindaro) wrote :

me too no system sound...

Stanley Sokolow (overbyte) wrote :

[Hardy 8.04 alpha-1 sound] No system sounds here either, but sound output tests okay on System>Preferences>Sound>Devices. On the Sounds tab, none of the system sounds play their test, using the default sound files or by making other selections. "Play System Sounds" is enabled, but I don't get the login or logout sounds. But I do get sound from Totem playing the Example file "Experience ubuntu.ogg" and from Adobe FlashPlayer 9 embedded in Firefox playing a flash video from a web site. Just no system sounds. My system sounds worked fine on Ubuntu 7.10, but not on the Hardy alpha 1, neither before nor after the major alpha upgrade. My test computer is an i386 system (Celeron 2.6 GHz) with C-Media CMI 8736 sound chip using ALSA mixer. It works fine in Windows and Ubuntu 7.10.

Stanley Sokolow (overbyte) wrote :

[Hardy 8.04 alpha-1 sound] I just compared my sound settings between my 7.04 and 7.10 installations (where system sounds work) and my 8.04alpha-1 installation (where system sounds don't work). On 7.10, the sound events playback device that works is called "C-Media PCI IEC958". This device "test" works and the system sounds play (both in the test play and in the real system events such as login). On 7.04, the system sounds also work.

On 8.04alpha-1, that same sound events device only produces white noise when I do the test and nothing when I try to play a system sound. The sound events device that produces a tone when I test is called "C-Media PCI DAC/ADC" but it does not play system event sounds when I test them. None of the sound events devices play sound events on my 8.04alpha-1 installation. These installations are all on exactly the same machine, just using different hard drives that I can swap out using removable drive trays or different partitions on the same drive, so there is absolutely the same hardware in all instances. This is a new bug introduced into 8.04 alpha-1.

Stanley Sokolow (overbyte) wrote :

[Hardy 8.04 alpha-2 sound] No system sounds on alpha-2 and on today's daily build of the i386 iso file (22 Dec 2007 07:40).

Stanley Sokolow (overbyte) wrote :

[Hardy 8.04 alpha-2 pulseaudio] I looked at /var/log/syslog. Pulse audio wrote some error messages, which may be related to the system sound problem. I don't know enough about Pulse Audio to interpret these messages, but it seems that pulseaudio is not configured properly:
Dec 28 03:04:12 Northgate-U804a2 pulseaudio[5304]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
Dec 28 03:04:12 Northgate-U804a2 pulseaudio[5304]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Dec 28 03:04:12 Northgate-U804a2 pulseaudio[5304]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Dec 28 03:04:12 Northgate-U804a2 pulseaudio[5304]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Dec 28 03:04:12 Northgate-U804a2 pulseaudio[5304]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

Stanley Sokolow (overbyte) wrote :

No midi sound, either.

Stanley Sokolow (overbyte) wrote :

I'm running Hardy alpha-3 with current updates, and the sound works fine for me. Since there have been no further reports on this bug and recent releases seem to have fixed it, I'm changing status.

stz_comp (stz-comp) wrote :

I had exactly the same problems in Interpid (both i386 and AMD64) an now I have these problems in Jaunty (both i386 and AMD64).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers