Fails to unlock/ resumes to black screen

Bug #1622303 reported by Kev Bowring on 2016-09-11
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned
xfce4-session (Ubuntu)
Undecided
Sean Davis
xubuntu-default-settings (Ubuntu)
Undecided
Sean Davis

Bug Description

Lock screen (or suspend)

System allows for password to unlock

No desktop shown after unlocking

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: xfce4-power-manager 1.4.4-4ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Uname: Linux 4.4.0-9136-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Sep 11 10:04:39 2016
InstallationDate: Installed on 2016-06-11 (91 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160611)
SourcePackage: xfce4-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
DistroRelease: Ubuntu 16.10
InstallationDate: Installed on 2016-06-11 (95 days ago)
InstallationMedia: Xubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160611)
Package: light-locker 1.7.0-2ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Tags: yakkety
Uname: Linux 4.4.0-9136-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo
_MarkForUpload: True

Kev Bowring (flocculant) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) on 2016-09-13
affects: xfce4-power-manager (Ubuntu) → light-locker (Ubuntu)

apport information

tags: added: apport-collected
description: updated

apport information

apport information

@robert-ancell, We're seeing this breakage starting in Yakkety. Since there have been no changes to light-locker or lightdm-gtk-greeter between Xenial and Yakkety, I was wondering if you knew of any potentially breaking changes in LightDM?

Kev Bowring (flocculant) wrote :

lightdm log from fail to return from lock session

Kev Bowring (flocculant) wrote :

more notes - while it appears that the system is still locked - media playing prior to locking can be heard implies to me at least it has unlocked we're just not getting a desktop back

summary: - Fails to unlock/ resume to black screen
+ Fails to unlock/ resumes to black screen
Jack Fromm (jjfrv8) wrote :

I don't know if my symptoms are different or not. After I resume, I am able to enter my password to unlock but instead of going to a completely black screen, I get a "This session is locked. You'll be redirected to the unlock dialog automatically in a few seconds" screen.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1622303

tags: added: iso-testing
Sean Davis (bluesabre) wrote :

Marking this bug as critical as it is a release blocker for 16.10.

Changed in light-locker (Ubuntu):
importance: Undecided → Critical
Sean Davis (bluesabre) wrote :

I tagged LightDM and LightDM GTK+ Greeter since they may be directly related.

tags: added: rls-y-incoming
Sean Davis (bluesabre) wrote :

I tried downgrading lightdm (and related packages) to their xenial versions (1.18.x) and the bug persists, so it seems less likely to be directly related to lightdm.

Robert Ancell (robert-ancell) wrote :

Sorry, didn't notice this bug go past. I can't think of anything that would have changed in LightDM and the log isn't showing anything going wrong. I was going to suggest you try downgrading LightDM but you've done that. My best guess is the session / light-locker haven't realised they've been unlocked for some reason? Either that or something to do with VT switching (driver issues?).

Kev Bowring (flocculant) wrote :

Reverted to older xubuntu-default-settings - undid https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1627304/comments/18

Reverted to light-locker.

Everything now works as expected.

Sean Davis (bluesabre) wrote :

@flocculant Thanks for looking into this. I spoke with pitti about this and we correctly identified the issue being related to the session switch to system user units. For now, we'll roll back the session changes.

Affected packages: xfce4-session, xubuntu-default-settings

Changed in xfce4-session (Ubuntu):
assignee: nobody → Sean Davis (bluesabre)
status: New → In Progress
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Sean Davis (bluesabre)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 16.10.2

---------------
xubuntu-default-settings (16.10.2) yakkety; urgency=medium

  * Revert systemd user unit changes (LP: #1622303)
  * usr/share/xsessions/xubuntu.desktop: Switch Exec= line back to
    direct startxfce4 execution.

 -- Sean Davis <email address hidden> Wed, 28 Sep 2016 06:02:49 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
Kev Bowring (flocculant) on 2016-09-28
no longer affects: light-locker (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Kev Bowring (flocculant) on 2016-09-28
affects: lightdm (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Confirmed
Kev Bowring (flocculant) on 2016-10-01
Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Invalid
Changed in ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints