Support for the scanner with the Brother DCP 7025 multifunction printer

Bug #161855 reported by Ludovic Claude on 2007-11-10
2
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Please add the following lines to /etc/udev/rules.d/45-libsane.rules

# Brother DCP 7025
SYSFS{idVendor}=="04f9", SYSFS{idProduct}=="0184", MODE="666", GROUP="scanner"

This will make the installation of the Brother driver much easier on Ubuntu.

I managed to get the scanner to work on my Ubuntu (Gutsy 64bits) only after doing the following:
1) download & install the driver brscan2 0.2.4 from the Brother website
2) see a cryptic error message "Failed to open Device: brother2:bus1:dev1' Error during I/0" when I opened xsane
3) search frantically in the forums, and finally finding this nice tip about libsane.rules which worked perfectly for me.

See also bug #72321 which was closed a bit too fast.

I'm perfectly ok to install the driver manually, if you have license issues which prevent you from including it in your repository, but can you make our live easier and add those 2 lines in the 45-libsane.rules file?

BTW, the printer worked like a charm, I had only to configure it from system-config-printer and select the correct model, great job!

Thanks, Ludovic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers