Widescreen monitor (Acer AL1702W) is not using proper resolution

Bug #161816 reported by Chandru on 2007-11-10
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When I run Kubuntu 7.10, using the live install CD, my monitor model (Acer AL1702W) and its max resolution (1440x900) are detected correctly. However only three-fourth of the screen was used and the display was badly skewed. I'm using an nVIDIA GeForce4 MX 4000.

When I checked the System Settings, I found that while the resolution is detected properly, the "Image Format" for the monitor was set to "Standard 4:3". When I changed it to "Widescreen 16:9" and restarted X, everything was fine.

This can affect the user experience of new users trying Kubuntu for the first time on a widescreen monitor.

RobinSteven (vortune) wrote :

Congratulation for your fixing the problem in Ubuntu, I ran into same trouble in Gentoo.
please tell where is you find the "Image format" of system, because I can't found this option on Ubuntu 7.10 Install CD.

Please post you /etc/X11/xorg.conf here or mail me as attachment "<email address hidden>", let me search useful info for my distro.

Chandru (chandru-in) wrote :

I have changed my graphics card now and I have run into this new bug now.

https://bugs.launchpad.net/ubuntu/+source/kde-systemsettings/+bug/163642

Kubuntu seems to be too weak at automatically handling widescreen monitors correctly. If someone can confirm the above bug, it will be good.

My current xorg.conf may not be useful to you as it has changed to a great extent now.

RobinSteven (vortune) wrote :

It is defect of xorg that couldn't support perfectly widescreen monitor, in my remember it have very dirty bug in LCD monitor when that was being popular.
good luck.

trident_2008 (noir) wrote :

Same problem with Samsung 206BW / Intel builtin card/64 bit (EM64T) LiveDVD. Fix proposed in original description worked for LiveDVD, but problem appeared again after install, although monitor was already set to widescreen.

Monitor's auto-adjustment didn't do any good (it displayed correct image briefly, then it was reset back to wrong size.) Manuasl adjustment had insufficient range to fix that.

It disappeared after I selected Generic LCD 1600x1050 but with aspect set back to 4:3 (Tried "PnP monitor" and "Samsung 206BW" from the list both with and without forced widescreen - no effect.), then using monitor's auto-adjust button. Aspect is a bit off, but at least desktop is not off-screen now. I suspect that it is not important what exactly you select in hardware tab, - its a change itself that somehow triggers correct behavior. Will post more information later.

trident_2008 (noir) wrote :

uname -a
Linux noir-desktop 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

trident_2008 (noir) wrote :

More tests, - After I selected different monitor, restarted X Server and put all the settings that worked back ( Generic LCD 1600x1050 , 4:3, same resolution), it stopped to work again.

Deleting xorg.conf completely seemingly resolved the "off-screen desktop" problem, but aspect ratio of everything became absolutely wrong, to a point of non-legibility (for me).

Manually edited modelines (see below) allowed me to get almost normal 1280x768@60 mode, and all the other ones now behave predictably, - 4:3 ones have aspect ratio problem, and 16:x have "off-screen" problem.

I'm yet to download Hardy CD.

Section "Monitor"
 Identifier "SyncMaster"
 Vendorname "Samsung"
 Modelname "Samsung SyncMaster 206BW (Analog)"
 DisplaySize 433.44 270.9
 Horizsync 30-81
 Vertrefresh 56-75
  modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
  modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
  modeline "1280x800@75" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
  modeline "1280x768@75" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
  modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
  modeline "1280x960@60" 108.00 1280 1344 1480 1680 800 961 964 968 +hsync +vsync
  modeline "1600x1050@60" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
 Gamma 1.0
EndSection

trident_2008 (noir) wrote :

Works fine in Hardy alpha 4

Michael Nagel (nailor) wrote :

closing this bug report, then

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers