Brightness Control doesn't work on Dell Vostro 1000

Bug #159255 reported by Rodrigo Saraiva on 2007-11-01
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

FN Keys doens't work on Dell Vostro 1000 to control brightness, and isn't possible to control by slider on GPM, because it not exists.
I search foruns, Internet, but i didn't found the solution.
This problem is older, since another versions.
When the users will have a solution?

Luka Renko (lure) wrote :

Is this Kubuntu or Ubuntu? Which version?
Can you provide data as requested in https://wiki.ubuntu.com/KubuntuLaptopKeycodes ?

zanonmark (info-marcozanon) wrote :

same here, using Ubuntu Gutsy,

but doing an "echo -n VALUE > /proc/acpi/video/VGA/LCD/brightness" works,

thanks, MZ

Maybe this could work;

Install Kpowersave, it's an application that lets you manager power settings, i had the same problem, my fn keys still don't work (using vostro 1500)

i'm using Kubuntu Gutsy 7.10 btw

Ubuntu 7.10 Gutsy Gibbon.
<h1>Please, it has somebody working in this case?</h1>

Ahmet (portakalio) wrote :

I'm using Ubuntu 7.10 Gutsy Gibbon 64-Bit version on the Dell Vostro 1000 laptop.
I can also confirm that "echo -n VALUE > /proc/acpi/video/VGA/LCD/brightness" works likes a charm.

The "echo -n VALUE > /proc/acpi/video/VGA/LCD/brightness" does not work on my Vostro 1000 on Ubuntu 7.10 64bit. It gives "bash: /proc/.../brightness: Permission denied". If I do "cat /proc/.../brightness" it gives:

levels: 100 37 12 25 37 50 62 75 87 100
current: 0

Also, the brightness keys are working in the GRUB menu.

Ahmet (portakalio) wrote :

to Андон Сикавица :
try this in a terminal window:

sudo su -

This will give you root clearance on the shell .
then :

echo -n VALUE > /proc/acpi/video/VGA/LCD/brightness

where argument VALUE represents any these: 12, 25, 37, 50, 62, 75, 87, or 100

for example a brightness level of 37 goes like this:
echo -n 37 > /proc/acpi/video/VGA/LCD/brightness

To quit the root terminal, type exit

Thanks, that is working. I actually tried running the echo command prefixing it with sudo and it gave the same permission denied result. That why I didn't try it with the su prompt.

James (jfinstrom) wrote :

ok so there are two scripts called by the brightness keys which hit acpi_fakekey (doesnt work)
Below are a couple quick and dirty replacements that work on dell vostro 1000

these replace :
/etc/acpi/video_brightnessup.sh
http://www.pastebin.ca/834518
/etc/acpi/video_brightnessdown.sh
http://www.pastebin.ca/834514

Backup any originals

James (jfinstrom) wrote :
lostangel78 (lostangel78) wrote :

Try typing the following command in a terminal:

xgamma -gamma 0.75

If that doesn't work you need to install xgamma from the repos.

I have posted my own solution here on setting it up:

http://ubuntuforums.org/showthread.php?p=4168042#post4168042

alexrussell (alexrussell101) wrote :

James, you're a genius! Those scripts did the trick for me.

Borahshadow (codyregister) wrote :

Thanks worked for me. Also Hardy alpha 6 the brightness works out of the box. FYI But that could change by the final release.

Alikus (metalikus) wrote :

Here's solution for Dell Vostro 1400 with Intel® GMA X3100
http://www.pastebin.ca/943749

P.S.
Thanks for James :)

zanonmark (info-marcozanon) wrote :

Hi, using Hardy 8.04 here,

now the brightness keys show the brightness progress indicator at 100%, but when I press the "brightness up" or "brightness down" keys the progress bar is still at 100% (i.e: no way to lower that using the keyboard),

thanks, MZ

Ahmet (portakalio) wrote :

Just try the solution I posted here:

https://bugs.launchpad.net/ubuntu/+bug/159255/comments/7

Remember to make the scripts executable (+x)

It works on Hardy 8.04, 64bit, on my Vostro 1000.
You'll see the onscreen brightness indicator level up or level down when you increase or decrease your brightness level through fn+up / fn+down.

If you add the Brightness Applet to the upper panel, the slider won't influence the brightness level, as this also still doesn't seem to be working.

Try it, it'll work.

BTW: I've got magnificent battery life on Hardy 8.04!

Ahmet (portakalio) wrote :

What I forgot to mention in my previous post were James' scripts, which you can get here:

https://bugs.launchpad.net/ubuntu/+bug/159255/comments/9

zanonmark (info-marcozanon) wrote :

Thanks Ahmet and James, the scripts did work,

still reporting the bug, though, since it should work "out-of-the-box": but thanks for the temporary solution,

MZ

Ahmet (portakalio) wrote :

I can confirm that the stock kernel on Ubuntu 8.10 32bit DOES NOT CONTAIN this problem anymore!
Brightness controls are fully functional, also 'dim when idle' seems to work outstanding.

Seems like that also A LOT of other things seem to be fixed in Ibex Intrepid...

Luka Renko (lure) on 2009-05-01
Changed in ubuntu:
assignee: Luka Renko (lure) → nobody
Changed in ubuntu:
status: Incomplete → Fix Released
Syarif (psychicmind9) wrote :

hai..im using acer aspire 4736 laptop.
im also having the same problem as you guys.
My diplay brightness is not functioning.
i hve a simple solution but working. It works like charm for Ubuntu 9.04 Jaunty.

Here my solution and tutorial.

My solution is:
---------------

1. Install COmpiz (Advanced Desktop Effect Settings (ccsm) from Add/Remove..

2. After finished, go to System > Preferences > CompizConfig Settings Manager.

3. At Accessibility Column, tick the Opacity, Brightness And Saturation and click at the word.

4. There are Opacity| Brightness | Saturation tab. Choose the brightness tab.

5. You will see keyboard(increase),mouse(increase),keyboard(decrease),mouse(decrease) icon at the left. At the right of it, you will see Disable button.

---------------------
-Brightness Increase-
---------------------

6. Click at the disable button of keyboard(increase) and tick the enable box.

7. Now, put your own combination. Lets say we want to make it as CTRL + right button. There are a choice:

      Shift Super
      Ctrl Alt

8. Click at the Grab key combination.

9. ccsm windows will pop up. Press ctrl + right button on your keyboard and press ok..

10. Now you have done for the Brightness increase button.

----------------------
-Brightness Decrease-
----------------------

11. Click at the disable button of keyboard(decrease) and tick the enable box.

12. Now, put your own combination. Lets say we want to make it as CTRL + left button. There are a choice:

      Shift Super
      Ctrl Alt

13. Click at the Grab key combination.

14. ccsm windows will pop up. Press ctrl + left button on your keyboard and press ok..

15. Now you have done for the Brightness decrease button.

------------
-Try it OUT-
------------

Now, go to the desktop and press CTRL + left button on your keyboard repeatedly and CTRL + right repeatedly.

It is working??

Note: this brightness working at all active windows.

try open up mozilla and press the CTRL + left button. Mozilla will get dimmer.
Try open up terminal and do the same things. The terminal will get dimmer to.
press CTRL + right to get it brighter.

Hope you will understand my simple tutorial. Please drop your comment and suggestion.

Happy playing!!!

ochach (ochach) wrote :

I have dell vostro 3500 and added this line to my /etc/Xorg/xorg.conf

    Option "RegistryDwords" "EnableBrightnessControl=1"

in Section "device"

this solved the issue for me. Theyve changed sth in drivers so this is now needed to control brightness which is pretty stupid but its good to know this :]
Hope it helps,
cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers