Comment 2 for bug 157648

Yep that looks like it.

It seems to be a bug but I found this in the bugs and it looks like so
solution https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/120375 . I
seem to remember being dumped at some thing like ram file system scree,

However, I gave up and use Opensuse, which, I can't say I like as much
as Ubuntu particularly on the Desktop (but this is a server), every
thing worked (including the RAID) without too much struggle and I am not
an ubergeek.

Any way good luck

rihad wrote:
> Does my case look similar?
>
> I've installed 7.10 amd64 on a Intel Server System 1500 with 2 SAS
> drives, which unfortunately has a SW raid system incompatible with open
> OS', so I'm trying to use Linux mdadm. The first partition on both
> drives was created and marked as bootable, and raid autodetect. The
> installation goes well and the system boots ok on /dev/md0, and
> /proc/mdstat and mdadm -D show everything's in sync. After shutting down
> the system and unplugging one of the drives -- it doesn't matter which
> -- the systems waits for 2-3 minutes at the "loading, please wait'
> prompt, then spits out some errors like "stdin: error 0" and then the
> output similar to what happens when you run modprobe with no arguments,
> and some more "no such file or directory" regarding parts under the root
> fs (like /dev/ /sys/ /proc etc.), eventually dropping into a busybox
> shell.
>
> I also tried running this on both drives, with no effect whatsoever.
> Quote:
> grub-install /dev/sda
> grub
> grub: device (hd0) /dev/sdb
> grub: root (hd0,0)
> grub: setup (hd0)
> grub: quit
>
>