No Sound from Speakers, but Headphones work

Bug #156013 reported by Lonnie Lee Best on 2007-10-22
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned
linux-backports-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alsa-driver (Ubuntu)

Sound works fine in 7.04, but not in Ubuntu 7.10 on my Compaq Presario 2700 Laptop.

Specifically, no sound will come from my laptop's internal speakers, but if I plug in headphones I hear sound.

I've checked all the volume controls on all devices to make sure nothing is muted or turned down. Again, this wasn't an issue in Ubuntu 7.04.

Ubuntu 7.10's Device Manager says that my Audio Controller is:

 Vendor: Intel Corporation
 Device: 82801CA/CAM AC'97 Audio Controller
 Status: Status
 Bus Type: PCI

Most of the Audio Controller's sub component's names start off:
Intel 82801CA-ICH3

Here's a screen shot:
http://www.lonniebest.com/Image/ScreenShot/AudioController.png

Interesting. When I plug my headphones in, I can hear sound.

I've fooled with every lever in Volume control to make sure that it was not muted and had volume, but the only way I've been able to hear sound is with head phones.

I didn't experience this behavior in 7.04, but do now in 7.10.

description: updated
luke (hupann) wrote :

This is exactly what I am experiencing also.
How do I go about fixing the bug?
How do i upload my screen shot for my audiocontroller.png here?

Suger (suger) wrote :

Well, same problem here on a VAIO VGN TZ11MN

lspci -nn | grep Audio
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)

What's funny is that with 7.04, plugin in the headphones did not mute the speakers, and now, speakers are always muted, whatever you tweak in alsamixer.

I'd rather see this as a bug with alsa than with gnome-session, but who am I to tell ?

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-session:
status: New → Invalid

Please be more specific regarding the information that is missing. What exactly do you need us to provide?

This is a backwards compatibility issue it seems. Something was changed in 7.10 that causes my laptop's internal speakers not to play sound while headphones continue to play sound; the 7.04 live CD will play sounds fine, however, the 7.10 live CD does not.

So the question is, "what changed?"

Someone forgot to include something in 7.10 that was included in 7.04 OR someone changed something for 7.10 that caused this unintended ramification.

Who is best qualified to handle this issue? I suspect the right person will know exactly what caused this and know an easy fix too.

-Respectfully

luke (hupann) wrote :

How and where can we find the right person to look into this issue?
I am making a complete switch from Windows to Linux as I think Linux is a great OS compared to Windows.
Alas! I am so sad, but I am not giving up till I can find a remedy for this sound issue.
In fact, I have another issue with my flash card reader built-in also.
However, I look to resolve one thing at a time.
Can the respective developer for Linux Ubuntu 7.10 look into the issue a.s.a.p?
Thanks.

Suger (suger) wrote :

OK. So it's definitely an alsa bug. I recompiled the latest alsa (1.0.15) following https://help.ubuntu.com/community/HdaIntelSoundHowto (just substitute 15 to 14 in the version number used there), and sound works perfetly : from speakers when no headphone plugged, from headphones when plugged.

Is this kind of bug which make sound unusable on a full range of laptops enough to warrant an upgrade to latest alsa ?

luke (hupann) wrote :

I give up!
I followed the instructions given in https://help.ubuntu.com/community/HdaIntelSoundHowto, but when I come to the command, sudo ./configure --with-cards=hda-intel, it returned checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
I tried it so many times and it just gave the same reply.
Is there something wrong?

Le mardi 23 octobre 2007 à 19:22 +0000, luke a écrit :
> I give up!
> I followed the instructions given in https://help.ubuntu.com/community/HdaIntelSoundHowto, but when I come to the command, sudo ./configure --with-cards=hda-intel, it returned checking for gcc... gcc
> checking for C compiler default output file name... configure: error: C compiler cannot create executables
> See `config.log' for more details.
> I tried it so many times and it just gave the same reply.
> Is there something wrong?

Did you install build-essential and linux-headers ?

If so, please send me your config.log. I remember having a similar
problem once, for some stupid reason I forgot all about

Changed in alsa-driver:
status: New → Confirmed
description: updated

Suger,

I'm not sure what you mean when you say:

"just substitute 15 to 14 in the version number used there"

Do you mean "change 15 to 14"? So what you did is you recompiled alsa so that Ubuntu is effectively using the previous version of alsa while tricking the update manager into thinking Ubuntu is using 15? Is that what you did?

If, so, I suppose the new updates won't over write your compiled version of 14 (which externally seems to be 15) until 16 comes out. Am I way off here?

Suger (suger) wrote :

Le mardi 23 octobre 2007 à 23:49 +0000, Lonnie a écrit :
> Suger,
>
> I'm not sure what you mean when you say:
>
> "just substitute 15 to 14 in the version number used there"
>
> Do you mean "change 15 to 14"? So what you did is you recompiled alsa so
> that Ubuntu is effectively using the previous version of alsa while
> tricking the update manager into thinking Ubuntu is using 15? Is that
> what you did?
>
> If, so, I suppose the new updates won't over write your compiled version
> of 14 (which externally seems to be 15) until 16 comes out. Am I way off
> here?

No, I mean exactly the opposite : Ubuntu is using version 1.0.14 and you
have to compile 1.0.15, which works, at least here. But the wiki article
speaks of version 1.0.14, which is the reason of my quite unclear
previous assertion. Download and compile 1.0.15. And yes, unless they
bump the alsa version or someone patches 1.0.14 to work around the bug,
you'll have to recompile at least alsa driver for every kernel update...

Tim Gardner (timg-tpi) wrote :

Install Gutsy linux-backports-modules to get ALSA 1.0.15 driver support.

Changed in alsa-driver:
status: Confirmed → Fix Released
mune (mune) wrote :

Same happened to me!

Everything was perfect on feisty nut when upgrading to gutsy the video resolution was 1024x768, so I activeted the restricted dricer for my radeon.

In xorg.conf, the driver become "fglarx" and adding the modeline
Modeline "1360x765" 84.14 1360 1392 1704 1736 765 780 788 804
and happily I had nack the full 16:9 screen.

I was happy :)

Immediately I discover the bad side: the speakers do not sound anymore but the headphones still work.

I have also downloaded the alsa source and installed its modules. But it doesn't workked!

Some output is attached.

Mark (mge7272-ubuntu) wrote :

I also have a Presario 2700 Laptop and have been trying to get the sound to output from my laptop speakers for weeks. I've tried everything I could find in the forums, the help guides, etc. I've even recompiled with ALSA Driver 1.0.16 using Module-intel8x0 from the alsa project and still no sound. I've tried muting and unmuting all possible things in the alsamixer. I've tried booting other linux live cd's and none of them output sound from the speakers. What else can be done to fix this bug. I'd be happy to try anything anyone has a suggestion to try. Thanks.

p.s. I posted a question about this problem previously but never found a solution that worked. Here's a link to that post:

https://answers.edge.launchpad.net/ubuntu/+question/19793

This bug persists in Ubuntu 8.04. The last version my speakers successfully worked on was Ubuntu 7.04.

With Ubunty 7.10, the speakers worked while running the Live CD, but after installation, the speakers no longer work (but if I plugged in the head phone I can hear sound). It's interesting that the same sound card that feeds my head phone jack, can't feed my speakers anymore in these last two releases of Ubuntu.

In 8.04, the speakers won't work while running the Live CD. I haven't actually done a full installation, but due to my previous experience (with everything working fine in 7.04, but not working in 7.10 and not working 8.04 Live, I feel like I'd be wasting my time to do a full install of 8.04.

Who in the Linux community is familiar enough with this type of problem to fix it for all us Compaq Presario 2700 users who have tasted ubuntu working fine with our speakers to have it taken away from us in later releases?

I'm still running 7.04, due to this bug, but would love to upgrade when someone discovers a fix.

Changed in alsa-driver:
status: New → Confirmed
Changed in linux-backports-modules-2.6.22:
status: Fix Released → Confirmed
Mackenzie Morgan (maco.m) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information. Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

mune (mune) wrote :

Il giorno dom, 21/09/2008 alle 21.19 +0000, Mackenzie Morgan ha scritto:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Unfortunately we can't fix it without more information.
> Please include the information requested from the "Reporting Sound Bugs"
> section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate
> attachments.
>
> ** Changed in: ubuntu
> Status: Confirmed => Incomplete

Well, in the meantime I installed the version 8.04, and that time I
solved the problem reinstalling the package alsa.

Thanks
--
Fede
________________________________________________________________________
       mune (at) fsfe.org Ing. Federico Munerotto
   home http://www.mune-web.eu
Public key http://www.mune-web.eu/personal/misc/pk/pk.html
Signoraggio http://www.mune-web.eu/personal/misc/signoraggio/
________________________________________________________________________
      posta firmata digitalmente | digitally signed message
________________________________________________________________________
You are sick, twisted and perverted. I like that in a person.

Changed in linux-backports-modules-2.6.22:
status: Confirmed → Fix Released
Changed in alsa-driver:
status: Confirmed → Invalid
Nextnx (nextnx) wrote :

Hi

Got same problem on my Thinkpad A31 [Intel 82801CA-ICH3 with AD1881A] running Ubuntu 8.10

Playback fine in jack but speaker no dice.

Checked alsamixer
Checked all Audio Controls like vol,switches,options
Installed linux-backports-modules
Complete reinstall of alsa via Synaptic
Complete compile/install with "ALSA Upgrade Script" - http://ubuntuforums.org/showthread.php?p=6589810#post6589810
And did a whole lot surfing and what not.
Still no luck

Please advise and please reopen.

Do check attachment

Best regards
Nextnx

Mark (mge7272-ubuntu) wrote :

Hi Newtnx,

I gave up on anyone fixing this problem with the ALSA in Ubuntu and all other linux distributions I've tried (10+).

The fix is to replace ALSA with hat using the Open Sound System (OSS). See the link below.

https://help.ubuntu.com/community/OpenSound

After following these instructions my laptop speakers finally produced sound! And I'd been trying to figure out how to do this for countless hours over the last year.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers