[needs-packaging] PeaZip

Bug #153386 reported by Felipe Monteiro de Carvalho on 2007-10-16
110
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
Debian
New
Unknown
Ubuntu
Wishlist
Unassigned
Declined for Hardy by Brian Murray
Declined for Intrepid by Brian Murray

Bug Description

PeaZip is a cross platform, desktop neutral archiver tool for many compressed or not formats.

Full support: 7Z, 7Z-sfx, BZip2, GZip/TGZ, LPAQ, PAQ8, PEA, QUAD, split (.001), TAR, ZIP;

Browse/extract support: ACE, ARJ, CAB, CHM, COMPOUND (MSI, DOC, XLS, PPT), CPIO, ISO, Java (JAR, EAR, WAR), various Linux packages (DEB, PET/PUP, RPM, SLP), LHA/LZH, NSIS, OOo, PAK/PK3/PK4, RAR, WIM, XPI, Z/TZ.

It would be great to have this tool on Ubuntu!

URL: http://peazip.sourceforge.net/

License: LGPL v3

Notes:
Written in FreePascal, built-in Localizations, Very Active Development,
Can be installed on 32 and 64 bit systems,
please note that ia32-libs are required to run any 32 bit binary on 64 bit systems.
QT GUI Requires Qt 4.3.4 or more recent, and needs libqt4intf.so installed in /usr/local/lib
GTK GUI Requires GTK2 or higher

Actual Version Sources:
http://downloads.sourceforge.net/peazip/peazip-4.1.src.zip

SOURCES:
http://downloads.sourceforge.net/peazip/

Miroslav Sabljić (civija) wrote :

Is anybody working on this? I would like to package this for Ubuntu.

Giorgio tani (giorgiotani) wrote :

Package request for PeaZip

PeaZip is a cross platform, desktop neutral archiver tool for many compressed or not formats.
Full support: 7Z, 7Z-sfx, BZip2, GZip/TGZ, LPAQ, PAQ8, PEA, QUAD, split (.001), TAR, ZIP;
Browse/extract support: ACE, ARJ, CAB, CHM, COMPOUND (MSI, DOC, XLS, PPT), CPIO, ISO, Java (JAR, EAR, WAR), various Linux packages (DEB, PET/PUP, RPM, SLP), LHA/LZH, NSIS, OOo, PAK/PK3/PK4, RAR, WIM, XPI, Z/TZ.

URL: http://peazip.sourceforge.net/
License: LGPLv3
Notes: Latest stable version is 2.0; DEB package is available: http://downloads.sourceforge.net/peazip/peazip_2.0.bin.LINUX.GTK2.i586-1.deb

Xavier Guillot (valeryan-24) wrote :

Yes it would be nice to have PeaZip in the packages.

It allows also to join 001 files like 7-zip.

Version 2.1 is available :

http://downloads.sourceforge.net/peazip/peazip_2.1.bin.LINUX.GTK2.i586-1.deb

The file-roller suffers from various issues. zip archiving does not work when it comes to large files. .tar.gz is rather old-fashioned and not quite so safe (AFAIR). -> AFAIK, Ubuntu presently does not have any fully working safe built-in archiving tool.

All programs currently available in Ubuntu's repositories seem to rely on the same packaging libaries, so if there is an error in the one concerned, you cannot package with this format. Therefore, it seems to me that it would be very important to have an alternative available which is independent from the usual libraries.

Will PeaZip ship with Ubuntu 8.10?

PS Also, my question would be whether this can be changed from "Whishlist" to "High". I think it is really important for an operating system that aims to be professional to have a fully working package program available. Or are there any reasons why PeaZip cannot be in Ubuntu 8.10?

Giorgio tani (giorgiotani) wrote :

Hi, DEB packages fit for Ubuntu distribution can be found on project's website on SourceForge:
http://sourceforge.net/project/showfiles.php?group_id=178996&package_id=255049
I'll be glad to see it in repositories too.

Anyway PeaZip exists also as portable application (well, indeed it started as portable application), just dowload and extract the Linux GTK2 package from http://sourceforge.net/project/showfiles.php?group_id=178996&package_id=234632

<3 i love PeaZip and is better than file-roller.

please, add to the next ubuntu version :(

Is this going to be part of Ubuntu 9.04?

Xavier Guillot (valeryan-24) wrote :

Hello,

Any news about including Peazip on the Ubuntu packages ?

A new version (2.5.1) with some improvements just came out.

Best regards.

nh2 (nh2) wrote :

Having read http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499376 it seems the problem is that PeaZip cannot be compiled without the Lazarus IDE running. AFAIK this has to be fixed before PeaZip can be included into Debian or Ubuntu.

Any Lazarus software can be compiled without the IDE running. The IDE
just calls Free Pascal, which is the command line compiler. You can
check which options the IDE uses in the Compiler Options dialog. Here
is an example of a makefile for Lazarus software:

http://wiki.lazarus.freepascal.org/Deploying_Your_Application#Creating_a_Makefile_for_your_Lazarus_software

--
Felipe Monteiro de Carvalho

pinzia (pinzia) on 2009-09-16
description: updated
Giorgio tani (giorgiotani) wrote :

Sources for the new stable release are available here:
http://downloads.sourceforge.net/peazip/peazip-2.7.src.zip

Savvas Radevic (medigeek) wrote :

Here's an example lazarus / freepascal ppa if anyone is interested: https://launchpad.net/~paul-climbing/+archive/ppa/+packages

Changed in debian:
status: Fix Released → New
joopbraak (joopbraak) wrote :

The main reason it's not packaged yet is that no-one succeeded in compiling it successfully in 64 bit environment.

A shame, although the code and the interface is a bit messy. These are all the error messages I get when running peazip on 64 bit (although it still runs) :

http://pastebin.com/uS9AWYh0

I can't believe Gnome's standard archive manager (file roller, the name sucks as well) doesn't even have such basic features as showing the CRC32. Peazip is the only *nix GUI archive manager I found that does this.

Changed in debian:
status: New → Unknown
joopbraak (joopbraak) on 2011-10-23
description: updated
Giorgio tani (giorgiotani) wrote :

Hi, topics about compiling and packing the application can be found in the readme in sources' package.
About compiling onb 64 bit issue, PeaZip uses this library http://home.netsurf.de/wolfgang.ehrhardt/index.html
which provides cryptographic, hash and crc functions: some parts are written in ASM for performance reasons, and only in some cases are available pure high level language counterparts.
I did not succeeded in compiling those ASM functions on 64 bit Lazarus/FreePascal compiler, they should either been rewritten to be fully compatible with x86-64 ASM or either rewritten in Object Pascal to ensure portability.
Otherwise, PeaZip needs ia32-libs as requirement to run on 64 bit systems, but of course I could not package such a big and complex library in the generic packages (not targeting a specific distribution/version) I provide in DEB, RPM and TGZ formats.

About PeaZip code being a bit messy, I know, one of the reason is that Lazarus/FPC is a relatively recent project and is being actively developed. When I started writing PeaZip 6 years ago the IDE was a lot different and PeaZip grew up finding its way in what that wonderful IDE was able to offer as it improved by Lazarus/FPC staff version after version.
They did a great work in developing a really astounding IDE as Lazarus is today, but of course working on what is itself a work in progress requires some workarounds, and version after version part of the development is finding non optimal code and find what Lazarus offers to make things better / simpler today.

Changed in debian:
status: Unknown → New
G4JC (gaming4jc2) wrote :

+1 for Natty & Oneiric
Thankfully they do offer packages from their site now... e.g.:
https://peazip.googlecode.com/files/peazip_4.5.LINUX.GTK2-2_all.deb
Works fine on AMD64, but like they say if it's not in apt it can't be good - so make sure it's in there. ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.