Upgrade to Gutsy fails with configuring debconf

Bug #152133 reported by Luke Plant
2
Affects Status Importance Assigned to Milestone
Ubuntu
New
Undecided
Unassigned

Bug Description

Using Kubuntu feisty, I tried to upgrade to Gutsy following https://help.ubuntu.com/community/GutsyUpgrades#head-03dfe71741407e245a9fcd75bded428572061f53

After everything downloaded, I received a number of popups - contents equivalents the following messages from main.log:

2007-10-12 19:22:02,498 ERROR got an error from dpkg for pkg: 'debconf': 'subprocess post-installation script killed by signal (Segmentation fault), core dumped

2007-10-12 22:22:39,893 ERROR got an error from dpkg for pkg: '/var/cache/apt/archives/x11-common_1%3a7.2-5ubuntu13_i386.deb': 'subprocess pre-installation script killed by signal (Segmentation fault), core dumped

2007-10-12 22:24:04,503 ERROR got an error from dpkg for pkg: 'x11-common': 'dependency problems - leaving unconfigured

Then, while displaying the message 'Preparing to configure libidl0', it just hung -- stopped forever with no CPU or disk activity. So I abandoned. Tried the process again (which unfortunately means I don't have a proper apt.log, though I have salvaged the others). The upgrader didn't work -- I had to 'sudo dpkg --configure -a' to get things in a working state. After this used "aptitude dist-upgrade" to continue upgrade, which appears to be working, with some problems (due to failed downloads, perhaps?) which may be fixed by trying again.

Revision history for this message
Luke Plant (spookylukey) wrote :
Revision history for this message
Luke Plant (spookylukey) wrote :
Revision history for this message
James (james-ellis-gmail) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers