glchess fails to draw 3D field

Bug #146777 reported by Wolf Rogner on 2007-09-29
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

This is what is produced starting /usr/games/glchess

This is glChess 2.20.0.1
Loading AI configuration from /usr/share/glchess/ai.xml
Detected AI: GNU Chess at /usr/games/gnome-gnuchess
Using OpenGL:
VENDOR=DRI R300 Project
RENDERER=Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
VERSION=1.3 Mesa 7.0.1
EXTENSIONS=GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
/bin/sh: /usr/bin/esd: not found
*********************************WARN_ONCE*********************************
File r300_mem.c function r300_mem_alloc line 225
Ran out of GART memory (for 1048576)!
Please consider adjusting GARTSize option.
***************************************************************************
Error: Could not get dma buffer... exiting

Wolf Rogner (war-rsb) wrote :

This happens only when compiz is active

Wolf Rogner (war-rsb) wrote :

In 7.10 (release) it does not work even without compiz.

When switching to 3D a dialog appears:

"Unable to enable 3D mode

Your system does not have the required software to enable 3D mode. Please contact your system administrator and ask them to install the OpenGL Python bindings and the GtkGLExt Python bindings.

You are still able to play chess in 2D without these packages."
[Close]

Installed python-gtkglext1, libgtkglext1, python-opengl, python-setuptools.

Still no progress

wolfger (wolfger) wrote :

where are you getting the 2.20.0.1 package from? I have installed from the Gutsy repo, and it is version 1.0 which I have no problems with, but I also see no way to "switch to 3D".

Wolf Rogner (war-rsb) wrote :

From the gutsy repository.

There is no problem with it now:

compiz 1.0.6.0+git20071119+0ubuntu1 (gutsy backport)
gnome-games 1.2.20.3-0ubuntu1
glChess 2.20.3

Problem solved (however, we don't know why and how)

Congratulations, Wolf

wolfger (wolfger) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers