ssh-based X11 forwarding not working in 15.04 following upgrade from 14.10

Bug #1463263 reported by Surfrock66 on 2015-06-09
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Undecided
Unassigned
Ubuntu
Undecided
Chris Halse Rogers

Bug Description

More detail posted here: http://ubuntuforums.org/showthread.php?t=2281659&p=13300597

    surfrock66@sr66-blade:~$ lsb_release -rd
        Description: Ubuntu 15.04
        Release: 15.04

I performed an in-place upgrade from 14.10 -> 15.04. Now, GTK apps will not X11 forward. I was under the impression that Mir would not be in place until 15.10 which was when I would have probably held back on upgrading; I believe that other gtk packages have been modified with hooks in preparation to support Mir, and that these updates have broken X11 forwarding

Some sample command output from the client I am using to connect from:

    surfrock66@sr66-blade:/$ easytag
        gdk_mir_display_open
        Failed to connect to Mir: Failed to connect to server socket: No such file or directory
        Unable to init server: Could not connect: Connection refused
        (easytag:13278): Gtk-WARNING **: cannot open display:
    surfrock66@sr66-blade:/$ baobab
        gdk_mir_display_open
        Failed to connect to Mir: Failed to connect to server socket: No such file or directory
        Unable to init server: Could not connect: Connection refused
    surfrock66@sr66-blade:/$ gedit
        gdk_mir_display_open
        Failed to connect to Mir: Failed to connect to server socket: No such file or directory
        Unable to init server: Could not connect: Connection refused
        (gedit:13348): Gtk-WARNING **: cannot open display:

The server does have an X session running, and I can X11 forward from other devices so I know my client (X11 server) works.

I've done some research:
http://ubuntuforums.org/showthread.php?t=2266456
http://ubuntuforums.org/showthread.php?t=2256737

x2go still works, but X11 forwarding was a huge part of my workflow and I'm extremely ticked off, I've been trying to troubleshoot it since the day 15.04 came out.

Host server is my home server; a Dell poweredge SC 1425 in my server closet.

I ran tried from 3 clients, got the same results on each:
    Debian Sid laptop over the LAN, ssh session using a shortcut created when it was working on 14.10
    Windows work laptop using Cygwin over the WAN, ssh session using a shortcut created when it was working on 14.10
    Windows work laptop using MobaXterm over the WAN, fresh ssh session.

All 3 clients can successfully run an X11 forwarded client from another computer (all 3 were my System76 desktop running from my house)

I have an alias to connect to my server; the command is "ssh -p #### -X IP" and in that, "echo $DISPLAY" returns a blank line. If I get into the server over x2go or VNC, "echo $DISPLAY" returns :0.

On my laptop (the client machine, with the X11 Server):

    surfrock66@sr66-darter:~$ egrep -i forward /etc/ssh/sshd_config
        X11Forwarding yes

On the server (the X11 client):

    surfrock66@sr66-blade:~$ egrep -i forward /etc/ssh/sshd_config
        X11Forwarding yes

From this client laptop, I invoke X-11 forwarded apps in 2 ways; the aliased ssh connection string, and from a shortcut in my awesomeWM menu. Here's the strings for both (I blocked the port numbers):

    # SSH Shortcuts
    alias hda='ssh -p #### -X hda.surfrock66.com'
    alias mc='ssh -p #### <email address hidden>'
    alias sr66-darter='ssh -p #### -X 192.168.1.65'
    alias sr66-dell='ssh -p #### -X 192.168.1.47'
    #alias sr66-hp='ssh -p #### 192.168.1.10'
    alias sr66-hp='ssh -p #### -X sr66-hp.hda.surfrock66.com'
    alias sr66-nas='ssh -p #### surfrock66@192.168.1.36'
    alias sr76='ssh -p #### -X sr76.hda.surfrock66.com'

All of them are initiating client sessions that should permit X11 forwarding. Now for the AwesomeWM shortcuts:

myhdaforwardedapps = {
 { "Baobab", "xterm -e 'ssh -X -p ### surfrock66@192.168.1.22 -t baobab'" },
 { "EasyTag", "xterm -e 'ssh -X -p ### surfrock66@192.168.1.22 -t easytag'" },
 { "File Manager", "xterm -e 'ssh -X -p ### surfrock66@192.168.1.22 -t pcmanfm'" },
 { "Terminator", "xterm -e 'ssh -X -p ### surfrock66@192.168.1.22 -t terminator'" },
}

All of these shortcuts worked before the upgrade.

I am happy to provide any additional information.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1463263/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Surfrock66 (surfrock66) wrote :

The following mir-related packages are installed:

surfrock66@sr66-blade:~/.scripts$ dpkg --get-selections | grep -v deinstall | grep -i mir
libmirclient8:amd64 install
libmircommon3:amd64 install
libmirprotobuf0:amd64 install
mir-client-platform-mesa2:amd64 install

affects: ubuntu → mir (Ubuntu)
Changed in mir (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Daniel van Vugt (vanvugt) wrote :

The "gdk_mir_display_open" error is just GDK/GTK trying to use Mir because it found no X11 server ($DISPLAY is blank). That's not a Mir bug.

 You are not trying to use Mir, and Mir does not seem to be responsible for the breakage either. If the system was not broken then $DISPLAY would be set to something correct (like ":0") and GDK would not be trying to fall back to Mir.

Changed in mir (Ubuntu):
status: New → Invalid
affects: mir (Ubuntu) → ubuntu
Changed in ubuntu:
status: Invalid → New
Changed in mir:
status: New → Invalid
Surfrock66 (surfrock66) wrote :

I kind of suspected Mir was the wrong package, but I had to choose something and it was the closest I could come up with. What package could it be then? This is a change with the upgrade, and it's something trying to hook to mir.

It's still broken. X11 forwarding is broken in Ubuntu Server 15.04.

Surfrock66 (surfrock66) on 2015-06-10
summary: - X11 Forwarding is broken following upgrade to Ubuntu Server 15.04 from
+ ssh-based X11 forwarding" not working in 15.04 following upgrade from
14.10
summary: - ssh-based X11 forwarding" not working in 15.04 following upgrade from
+ ssh-based X11 forwarding not working in 15.04 following upgrade from
14.10
Surfrock66 (surfrock66) wrote :

Following some feedback here: http://ubuntuforums.org/showthread.php?t=2281659&p=13301326#post13301326

Setup:
  * remote surfrock66@192.168.1.22 (x-client)
  * local 192.168.1.65 with X-server running
Steps:
1) ssh into a remote system - ssh -p 669 surfrock66@192.168.1.22
2) xhost + 192.168.1.22 # from local machine .65
3) export DISPLAY=192.168.1.65; xterm -sb &

Output:

surfrock66@sr66-blade:~$ export DISPLAY=192.168.1.65
surfrock66@sr66-blade:~$ xterm -sb &
[1] 7050
surfrock66@sr66-blade:~$ xterm: Xt error: Can't open display: 192.168.1.65

These systems are on the same subnet connected to the SAME, unmanaged, switch. No firewalls enabled on either the client or server.

Seems, according to the suggestion in that thread, that it's an X11 bug. I will mark it as such.

Surfrock66 (surfrock66) on 2015-06-11
affects: mir → xorg-server
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Tad (tad-rave) wrote :

Hi, I was unable to connect a remote display as well.

(process:3077): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
X11 connection rejected because of wrong authentication.

** (evince:3077): WARNING **: Could not open X display
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
gdk_mir_display_open
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Cannot parse arguments: Cannot open display:
logout
[1]+ Exit 1 evince book.pdf
Connection to 192.168.0.43 closed.

JuriM (coil93) wrote :

Same issue for Ubuntu 16.10

Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

Ken D'Ambrosio (ken-jots) wrote :

Did a '-vv' on the ssh session, and got this:
X11 forwarding request failed on channel 0
Which I googled, and got this page:
http://ask.xmodulo.com/fix-broken-x11-forwarding-ssh.html
It appears to be an IPv6 issue -- i.e., I'm not using it -- so this fixed the problem:
Add
AddressFamily inet
to /etc/sshd/sshd_config and restart service. (That's assuming the AddressFamily line didn't already exist, which it didn't for my 16.04 host). Done!

Ken D'Ambrosio (ken-jots) wrote :

Oh -- so the OP should probably associate this bug report with the openssh-server package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers