lvm device mapper devs are symlinks to themselves

Bug #144595 reported by Markus Kienast on 2007-09-24
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

elias@doroga:~$ ls -l /dev/mapper/
total 0
lrwxrwxrwx 1 root root 13 2007-09-24 23:46 belly-bigfish -> belly-bigfish
lrwxrwxrwx 1 root root 15 2007-09-24 23:46 belly-edgy_root -> belly-edgy_root
lrwxrwxrwx 1 root root 15 2007-09-24 23:46 belly-edgy_swap -> belly-edgy_swap
lrwxrwxrwx 1 root root 17 2007-09-24 23:46 belly-feisty_root -> belly-feisty_root
lrwxrwxrwx 1 root root 17 2007-09-24 23:46 belly-feisty_swap -> belly-feisty_swap
crw-rw---- 1 root root 10, 63 2007-09-25 01:45 control

Don't think this needs any additional explanantion. The devs are symlinks to themselves.

/boot is a primary ext3 partition everything else is LVM. The names are confusing. belly-edgy_root is actually Gutsy's root dir "/". Everything worked until the last dist-upgrade today. Actually, the last thing I did before reboot was installing the kubuntu-desktop package on my ubuntu installation.

Markus Kienast (elias1884) wrote :

dmraid was removed.
this might have been done by dist-upgrade.

so the reason most likely is that ubuntu-desktop or the like does not depend on dmraid anymore - deliberately or not?

Ryan Bair (dr.bair) wrote :

I have found that vgchange -an /dev/mapper/something; vgchange -ay /dev/mapper/something gets the volume working again. (For all the people trapped in the console)

Anders Kaseorg (andersk) wrote :

Running ‘dmsetup mknodes’ at the maintenance console allowed me to log in. Then running ‘update-initramfs -u -k all’ made my system start booting normally again.

On Wed, 2007-09-26 at 02:50 +0000, Anders Kaseorg wrote:
> Running ‘dmsetup mknodes’ at the maintenance console allowed me to log
> in. Then running ‘update-initramfs -u -k all’ made my system start
> booting normally again.
>

My LVM-root was successfully mounted even though there was no dev
in /dev/mapper. It was just my /home which did not get mounted. So I was
able to install the dmraid package wich solved the problem for me.

Ergosys (ergosys) wrote :

I used the following variation to fix it:

PATH=/usr/sbin:/usr/bin:/sbin:/bin # only had /sbin and /bin in maintenance mode
mount /dev/sda1 /boot # I have a boot partition
# not sure what is needed here, but this is what I did:
apt-get install dmraid
dmsetup mknodes
update-initramfs -u -k all

Ryan Bair (dr.bair) wrote :

We can probably consider the issue closed. I suspect the accidental removal of dmraid during a dist-upgrade caused this issue. My only addition to Ergosys' steps was that I needed to mount my unmounted LVM volumes before 'update-initramfs -u -k all'.

Anders Kaseorg (andersk) wrote :

I don’t think the dmraid package is related to anything, because I neither installed it nor ever had it installed.

Philip Muškovac (yofel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in ubuntu:
status: Confirmed → Incomplete

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers