[needs-packaging] opengrade

Bug #137103 reported by bcrowell on 2007-09-03
4
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned

Bug Description

OpenGrade is a desktop application that lets teachers keep track of their students' grades. It can put the students' grade reports on a web server, and allow the students password-protected access to them.

http://www.lightandmatter.com/ogr/ogr.html

GPL license

Dependencies: sox perl-tk libterm-readkey-perl libdigest-sha1-perl libdate-calc-perl libclone-perl libterm-readline-gnu-perl md5deep

There is an optional dependency on Digest::Whirlpool, which does not appear to have been packaged yet for debian. I've filed a separate packaging request for it, bug #137117.

I'm the upstream author. I know a little about Debian packaging, but not enough to whip this completely into shape myself. I've attempted to adhere to some debian standards in the makefile (use of bindir, etc.), and there is a manpage.

--

Update Jan 2009: The dependency on sox has been replaced with a dependency on alsa-utils, and there is also a new dependency on libjson-perl.

--

Update May 2009: Digest::Whirlpool has now been packaged for ubuntu as libdigest-whirlpool-perl, so that should be a dependency now.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers