segfaults after automatic security updates

Bug #1352769 reported by pnull on 2014-08-05
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

System segfaults after installing security updates:

complete transcript following
-----

root@anakin:~# apt-get update
Hit http://ubuntu-mirror.inogate.net lucid Release.gpg
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid/main Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid/restricted Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid/universe Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid/multiverse Translation-en_US
Hit http://repo.int.inogate.net lucid Release.gpg
Ign http://repo.int.inogate.net/ lucid/main Translation-en_US
Ign http://repo.int.inogate.net/ lucid/upstream Translation-en_US
Hit http://repo.int.inogate.net lucid Release
Get:1 http://ubuntu-mirror.inogate.net lucid-updates Release.gpg [198B]
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/multiverse Translation-en_US
Get:2 http://ubuntu-mirror.inogate.net lucid-security Release.gpg [198B]
Ign http://ubuntu-mirror.inogate.net/ubuntu-security/ lucid-security/main Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu-security/ lucid-security/restricted Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu-security/ lucid-security/universe Translation-en_US
Ign http://ubuntu-mirror.inogate.net/ubuntu-security/ lucid-security/multiverse Translation-en_US
Hit http://ubuntu-mirror.inogate.net lucid Release
Get:3 http://ubuntu-mirror.inogate.net lucid-updates Release [101kB]
Get:4 http://ubuntu-mirror.inogate.net lucid-security Release [57.3kB]
Hit http://repo.int.inogate.net lucid/main Packages
Hit http://repo.int.inogate.net lucid/upstream Packages
Hit http://ubuntu-mirror.inogate.net lucid/main Packages
Hit http://ubuntu-mirror.inogate.net lucid/restricted Packages
Hit http://ubuntu-mirror.inogate.net lucid/universe Packages
Hit http://ubuntu-mirror.inogate.net lucid/multiverse Packages
Hit http://ubuntu-mirror.inogate.net lucid/main Sources
Hit http://ubuntu-mirror.inogate.net lucid/restricted Sources
Hit http://ubuntu-mirror.inogate.net lucid/universe Sources
Hit http://ubuntu-mirror.inogate.net lucid/multiverse Sources
Get:5 http://ubuntu-mirror.inogate.net lucid-updates/main Packages [764kB]
Get:6 http://ubuntu-mirror.inogate.net lucid-updates/restricted Packages [4,624B]
Get:7 http://ubuntu-mirror.inogate.net lucid-updates/universe Packages [349kB]
Get:8 http://ubuntu-mirror.inogate.net lucid-updates/multiverse Packages [11.5kB]
Get:9 http://ubuntu-mirror.inogate.net lucid-updates/main Sources [336kB]
Get:10 http://ubuntu-mirror.inogate.net lucid-updates/restricted Sources [2,196B]
Get:11 http://ubuntu-mirror.inogate.net lucid-updates/universe Sources [110kB]
Get:12 http://ubuntu-mirror.inogate.net lucid-updates/multiverse Sources [5,817B]
Get:13 http://ubuntu-mirror.inogate.net lucid-security/main Packages [569kB]
Get:14 http://ubuntu-mirror.inogate.net lucid-security/restricted Packages [2,829B]
Get:15 http://ubuntu-mirror.inogate.net lucid-security/universe Packages [204kB]
Get:16 http://ubuntu-mirror.inogate.net lucid-security/multiverse Packages [5,373B]
Get:17 http://ubuntu-mirror.inogate.net lucid-security/main Sources [243kB]
Get:18 http://ubuntu-mirror.inogate.net lucid-security/restricted Sources [1,267B]
Get:19 http://ubuntu-mirror.inogate.net lucid-security/universe Sources [46.7kB]
Get:20 http://ubuntu-mirror.inogate.net lucid-security/multiverse Sources [2,347B]
Fetched 2,815kB in 1s (1,824kB/s)
Reading package lists... Done
root@anakin:~#
root@anakin:~#
root@anakin:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  dhcp3-client dhcp3-common kdelibs-bin kdelibs5 kdelibs5-data landscape-common libc-bin libc-dev-bin libc6 libc6-dev libpam-modules libpam-runtime libpam0g libplasma3 nscd python python-minimal
17 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.7MB of archives.
After this operation, 524kB disk space will be freed.
Do you want to continue [Y/n]?
Get:1 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main python 2.6.5-0ubuntu1.1 [148kB]
Get:2 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main python-minimal 2.6.5-0ubuntu1.1 [21.2kB]
Get:3 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libpam-modules 1.1.1-2ubuntu5.6 [392kB]
Get:4 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libc-dev-bin 2.11.1-0ubuntu7.14 [224kB]
Get:5 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libc6-dev 2.11.1-0ubuntu7.14 [2,734kB]
Get:6 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libc-bin 2.11.1-0ubuntu7.14 [821kB]
Get:7 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libc6 2.11.1-0ubuntu7.14 [4,403kB]
Get:8 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main kdelibs-bin 4:4.4.5-0ubuntu1.3 [242kB]
Get:9 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libplasma3 4:4.4.5-0ubuntu1.3 [819kB]
Get:10 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main kdelibs5-data 4:4.4.5-0ubuntu1.3 [3,986kB]
Get:11 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main kdelibs5 4:4.4.5-0ubuntu1.3 [7,661kB]
Get:12 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libpam-runtime 1.1.1-2ubuntu5.6 [116kB]
Get:13 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main libpam0g 1.1.1-2ubuntu5.6 [126kB]
Get:14 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main dhcp3-client 3.1.3-2ubuntu3.5 [276kB]
Get:15 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main dhcp3-common 3.1.3-2ubuntu3.5 [336kB]
Get:16 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/main landscape-common 13.07.3-0ubuntu0.10.04 [220kB]
Get:17 http://ubuntu-mirror.inogate.net/ubuntu/ lucid-updates/universe nscd 2.11.1-0ubuntu7.14 [214kB]
Fetched 22.7MB in 0s (28.4MB/s)
Preconfiguring packages ...
(Reading database ... 102975 files and directories currently installed.)
Preparing to replace python 2.6.5-0ubuntu1 (using .../python_2.6.5-0ubuntu1.1_all.deb) ...
Unpacking replacement python ...
Preparing to replace python-minimal 2.6.5-0ubuntu1 (using .../python-minimal_2.6.5-0ubuntu1.1_all.deb) ...
Unpacking replacement python-minimal ...
Processing triggers for man-db ...
Setting up python-minimal (2.6.5-0ubuntu1.1) ...
(Reading database ... 102975 files and directories currently installed.)
Preparing to replace libpam-modules 1.1.1-2ubuntu5.4 (using .../libpam-modules_1.1.1-2ubuntu5.6_amd64.deb) ...
Unpacking replacement libpam-modules ...
Processing triggers for man-db ...
Setting up libpam-modules (1.1.1-2ubuntu5.6) ...

(Reading database ... 102976 files and directories currently installed.)
Preparing to replace libc-dev-bin 2.11.1-0ubuntu7.13 (using .../libc-dev-bin_2.11.1-0ubuntu7.14_amd64.deb) ...
Unpacking replacement libc-dev-bin ...
Preparing to replace libc6-dev 2.11.1-0ubuntu7.13 (using .../libc6-dev_2.11.1-0ubuntu7.14_amd64.deb) ...
Unpacking replacement libc6-dev ...
Preparing to replace libc-bin 2.11.1-0ubuntu7.13 (using .../libc-bin_2.11.1-0ubuntu7.14_amd64.deb) ...
Unpacking replacement libc-bin ...
Processing triggers for man-db ...
Setting up libc-bin (2.11.1-0ubuntu7.14) ...

(Reading database ... 102976 files and directories currently installed.)
Preparing to replace libc6 2.11.1-0ubuntu7.13 (using .../libc6_2.11.1-0ubuntu7.14_amd64.deb) ...
Unpacking replacement libc6 ...
Setting up libc6 (2.11.1-0ubuntu7.14) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
(Reading database ... 102976 files and directories currently installed.)
Preparing to replace kdelibs-bin 4:4.4.5-0ubuntu1.2 (using .../kdelibs-bin_4%3a4.4.5-0ubuntu1.3_amd64.deb) ...
Unpacking replacement kdelibs-bin ...
Preparing to replace libplasma3 4:4.4.5-0ubuntu1.2 (using .../libplasma3_4%3a4.4.5-0ubuntu1.3_amd64.deb) ...
Unpacking replacement libplasma3 ...
Preparing to replace kdelibs5-data 4:4.4.5-0ubuntu1.2 (using .../kdelibs5-data_4%3a4.4.5-0ubuntu1.3_all.deb) ...
Unpacking replacement kdelibs5-data ...
Preparing to replace kdelibs5 4:4.4.5-0ubuntu1.2 (using .../kdelibs5_4%3a4.4.5-0ubuntu1.3_amd64.deb) ...
Unpacking replacement kdelibs5 ...
Preparing to replace libpam-runtime 1.1.1-2ubuntu5.4 (using .../libpam-runtime_1.1.1-2ubuntu5.6_all.deb) ...
Unpacking replacement libpam-runtime ...
Processing triggers for man-db ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Processing triggers for hicolor-icon-theme ...
Setting up libpam-runtime (1.1.1-2ubuntu5.6) ...

pam-auth-update: Local modifications to /etc/pam.d/common-*, not updating.
pam-auth-update: Run pam-auth-update --force to override.

(Reading database ... 102976 files and directories currently installed.)
Preparing to replace libpam0g 1.1.1-2ubuntu5.4 (using .../libpam0g_1.1.1-2ubuntu5.6_amd64.deb) ...
Unpacking replacement libpam0g ...
Setting up libpam0g (1.1.1-2ubuntu5.6) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
(Reading database ... 102976 files and directories currently installed.)
Preparing to replace dhcp3-client 3.1.3-2ubuntu3.4 (using .../dhcp3-client_3.1.3-2ubuntu3.5_amd64.deb) ...
Unpacking replacement dhcp3-client ...
Preparing to replace dhcp3-common 3.1.3-2ubuntu3.4 (using .../dhcp3-common_3.1.3-2ubuntu3.5_amd64.deb) ...
Unpacking replacement dhcp3-common ...
Preparing to replace landscape-common 12.05-0ubuntu1.10.04 (using .../landscape-common_13.07.3-0ubuntu0.10.04_amd64.deb) ...
Unpacking replacement landscape-common ...
Preparing to replace nscd 2.11.1-0ubuntu7.13 (using .../nscd_2.11.1-0ubuntu7.14_amd64.deb) ...
 * Stopping Name Service Cache Daemon nscd [ OK ]
Unpacking replacement nscd ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up python (2.6.5-0ubuntu1.1) ...

Setting up libc-dev-bin (2.11.1-0ubuntu7.14) ...
Setting up libc6-dev (2.11.1-0ubuntu7.14) ...
Setting up kdelibs5-data (4:4.4.5-0ubuntu1.3) ...

Setting up dhcp3-common (3.1.3-2ubuntu3.5) ...
Setting up dhcp3-client (3.1.3-2ubuntu3.5) ...

Setting up landscape-common (13.07.3-0ubuntu0.10.04) ...

Setting up nscd (2.11.1-0ubuntu7.14) ...
 * Starting Name Service Cache Daemon nscd [ OK ]

Setting up kdelibs-bin (4:4.4.5-0ubuntu1.3) ...
Setting up kdelibs5 (4:4.4.5-0ubuntu1.3) ...

Setting up libplasma3 (4:4.4.5-0ubuntu1.3) ...

Processing triggers for python-central ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
root@anakin:~# apt-get update
0% [Working]*** glibc detected *** /usr/lib/apt/methods/http: munmap_chunk(): invalid pointer: 0x00007fb0eb7a6588 ***
======= Backtrace: =========
/lib/libc.so.6(+0x78cc6)[0x7fb0ea9a9cc6]
/lib/libc.so.6(+0x125ec9)[0x7fb0eaa56ec9]
/lib/libc.so.6(+0x12628b)[0x7fb0eaa5728b]
/lib/libc.so.6(getservbyname_r+0x183)[0x7fb0eaa39de3]
/lib/libc.so.6(+0xb9ff2)[0x7fb0ea9eaff2]
/lib/libc.so.6(+0xbad50)[0x7fb0ea9ebd50]
/lib/libc.so.6(getaddrinfo+0x162)[0x7fb0ea9ee8f2]
/usr/lib/apt/methods/http[0x40b337]
/usr/lib/apt/methods/http[0x406748]
/usr/lib/apt/methods/http[0x407d39]
/usr/lib/apt/methods/http[0x40a0cb]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fb0ea94fcad]
/usr/lib/apt/methods/http[0x4041c9]
======= Memory map: ========
00400000-0040e000 r-xp 00000000 08:01 2629084 /usr/lib/apt/methods/http
0060d000-0060e000 r--p 0000d000 08:01 2629084 /usr/lib/apt/methods/http
0060e000-0060f000 rw-p 0000e000 08:01 2629084 /usr/lib/apt/methods/http
01387000-013a8000 rw-p 00000000 00:00 0 [heap]
7fb0ea52a000-7fb0ea52c000 r-xp 00000000 08:01 4457012 /lib/libdl-2.11.1.so
7fb0ea52c000-7fb0ea72c000 ---p 00002000 08:01 4457012 /lib/libdl-2.11.1.so
7fb0ea72c000-7fb0ea72d000 r--p 00002000 08:01 4457012 /lib/libdl-2.11.1.so
7fb0ea72d000-7fb0ea72e000 rw-p 00003000 08:01 4457012 /lib/libdl-2.11.1.so
7fb0ea72e000-7fb0ea730000 r-xp 00000000 08:01 4457019 /lib/libutil-2.11.1.so
7fb0ea730000-7fb0ea92f000 ---p 00002000 08:01 4457019 /lib/libutil-2.11.1.so
7fb0ea92f000-7fb0ea930000 r--p 00001000 08:01 4457019 /lib/libutil-2.11.1.so
7fb0ea930000-7fb0ea931000 rw-p 00002000 08:01 4457019 /lib/libutil-2.11.1.so
7fb0ea931000-7fb0eaab0000 r-xp 00000000 08:01 4457020 /lib/libc-2.11.1.so
7fb0eaab0000-7fb0eacb0000 ---p 0017f000 08:01 4457020 /lib/libc-2.11.1.so
7fb0eacb0000-7fb0eacb4000 r--p 0017f000 08:01 4457020 /lib/libc-2.11.1.so
7fb0eacb4000-7fb0eacb5000 rw-p 00183000 08:01 4457020 /lib/libc-2.11.1.so
7fb0eacb5000-7fb0eacba000 rw-p 00000000 00:00 0
7fb0eacba000-7fb0eacd0000 r-xp 00000000 08:01 4456500 /lib/libgcc_s.so.1
7fb0eacd0000-7fb0eaecf000 ---p 00016000 08:01 4456500 /lib/libgcc_s.so.1
7fb0eaecf000-7fb0eaed0000 r--p 00015000 08:01 4456500 /lib/libgcc_s.so.1
7fb0eaed0000-7fb0eaed1000 rw-p 00016000 08:01 4456500 /lib/libgcc_s.so.1
7fb0eaed1000-7fb0eaf53000 r-xp 00000000 08:01 4457014 /lib/libm-2.11.1.so
7fb0eaf53000-7fb0eb152000 ---p 00082000 08:01 4457014 /lib/libm-2.11.1.so
7fb0eb152000-7fb0eb153000 r--p 00081000 08:01 4457014 /lib/libm-2.11.1.so
7fb0eb153000-7fb0eb154000 rw-p 00082000 08:01 4457014 /lib/libm-2.11.1.so
7fb0eb154000-7fb0eb24a000 r-xp 00000000 08:01 2622207 /usr/lib/libstdc++.so.6.0.13
7fb0eb24a000-7fb0eb44a000 ---p 000f6000 08:01 2622207 /usr/lib/libstdc++.so.6.0.13
7fb0eb44a000-7fb0eb451000 r--p 000f6000 08:01 2622207 /usr/lib/libstdc++.so.6.0.13
7fb0eb451000-7fb0eb453000 rw-p 000fd000 08:01 2622207 /usr/lib/libstdc++.so.6.0.13
7fb0eb453000-7fb0eb468000 rw-p 00000000 00:00 0
7fb0eb468000-7fb0eb52d000 r-xp 00000000 08:01 2629080 /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0
7fb0eb52d000-7fb0eb72d000 ---p 000c5000 08:01 2629080 /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0
7fb0eb72d000-7fb0eb730000 r--p 000c5000 08:01 2629080 /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0
7fb0eb730000-7fb0eb731000 rw-p 000c8000 08:01 2629080 /usr/lib/libapt-pkg-libc6.10-6.so.4.8.0
7fb0eb731000-7fb0eb751000 r-xp 00000000 08:01 4457005 /lib/ld-2.11.1.so
7fb0eb7a6000-7fb0eb7db000 r--s 00000000 08:01 3936621 /var/cache/nscd/services
7fb0eb7db000-7fb0eb81a000 r--p 00000000 08:01 2755693 /usr/lib/locale/en_US.utf8/LC_CTYPE
7fb0eb81a000-7fb0eb81b000 r--p 00000000 08:01 2755694 /usr/lib/locale/en_US.utf8/LC_NUMERIC
7fb0eb81b000-7fb0eb81c000 r--p 00000000 08:01 2755695 /usr/lib/locale/en_US.utf8/LC_TIME
7fb0eb81c000-7fb0eb93a000 r--p 00000000 08:01 2755696 /usr/lib/locale/en_US.utf8/LC_COLLATE
7fb0eb93a000-7fb0eb93b000 r--p 00000000 08:01 2755697 /usr/lib/locale/en_US.utf8/LC_MONETARY
7fb0eb93b000-7fb0eb940000 rw-p 00000000 00:00 0
7fb0eb940000-7fb0eb941000 r--p 00000000 08:01 2755699 /usr/lib/locale/en_US.utf8/LC_MESSAGES/SYS_LC_MESSAGES
7fb0eb941000-7fb0eb942000 r--p 00000000 08:01 2755700 /usr/lib/locale/en_US.utf8/LC_PAPER
7fb0eb942000-7fb0eb943000 r--p 00000000 08:01 2755701 /usr/lib/locale/en_US.utf8/LC_NAME
7fb0eb943000-7fb0eb944000 r--p 00000000 08:01 2755702 /usr/lib/locale/en_US.utf8/LC_ADDRESS
7fb0eb944000-7fb0eb945000 r--p 00000000 08:01 2755703 /usr/lib/locale/en_US.utf8/LC_TELEPHONE
7fb0eb945000-7fb0eb946000 r--p 00000000 08:01 2755704 /usr/lib/locale/en_US.utf8/LC_MEASUREMENT
7fb0eb946000-7fb0eb94d000 r--s 00000000 08:01 2633290 /usr/lib/gconv/gconv-modules.cache
7fb0eb94d000-7fb0eb94e000 r--p 00000000 08:01 2755705 /usr/lib/locale/en_US.utf8/LC_IDENTIFICATION
7fb0eb94e000-7fb0eb950000 rw-p 00000000 00:00 0
7fb0eb950000-7fb0eb951000 r--p 0001f000 08:01 4457005 /lib/ld-2.11.1.so
7fb0eb951000-7fb0eb952000 rw-p 00020000 08:01 4457005 /lib/ld-2.11.1.so
7fb0eb952000-7fb0eb953000 rw-p 00000000 00:00 0
7fff9bdea000-7fff9bdff000 rw-p 00000000 00:00 0 [stack]
7fff9bdff000-7fff9be00000 r-xp 00000000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
E: Method http has died unexpectedly!
E: Sub-process http received signal 6.

T0mWz (t0mwz) wrote :

We had the same issue and fixed by reinstalling the previoused version (libc-bin_2.11.1-0ubuntu7.13_amd64.deb & libc6_2.11.1-0ubuntu7.13_amd64.deb). I hope they will fix the issue fast, because apt-get update and a lot more doesn't works anymore.

Doug Winter (doug-isotoma) wrote :

Same problem here, with the same solution.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Stein Henrik Jensaas (steinhj) wrote :

Same problem here on my organization only remaining lucid-installation. Where do I find the previous version of libc6 & libc6-bin
(2.11.1-0ubuntu7.12). It is not cached on my machine ? It is not cached on my machine.

Ro (robert-markula) wrote :

This bug breaks other important things as well like DHCP (dhcp3-server) and cfengine.

Result: all of our servers which are still running Lucid are returning problems and we can't even fix them automatically using cfengine. Partial breakdown of core services. At this point I still can't estimate which other services are affected by this bug. Condition red in our case.

Since a multitude of programs rely on this critical core library we have a highly serious condition. Requesting to increase importance of this bug.

Steve Mumford (steve-mumford) wrote :

For reference, our server saw the following packages updated via unattended-upgrades last night: libc6-dev, libc-dev-bin, nscd, libc-bin & libc6, all to 2.11.1-0ubuntu7.14.

Reverted by manually downloading packages from the following URLs (picking appropriate architecture):

http://de.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc-bin_2.11.1-0ubuntu7.13_amd64.deb
http://de.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc-dev-bin_2.11.1-0ubuntu7.13_amd64.deb
http://de.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6-dev_2.11.1-0ubuntu7.13_amd64.deb
http://de.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6_2.11.1-0ubuntu7.13_amd64.deb
http://security.ubuntu.com/ubuntu/pool/universe/e/eglibc/nscd_2.11.1-0ubuntu7.13_amd64.deb

then installed with "dpkg -i libc-dev-bin_2.11.1-0ubuntu7.13_amd64.deb libc-bin_2.11.1-0ubuntu7.13_amd64.deb libc6_2.11.1-0ubuntu7.13_amd64.deb libc6-dev_2.11.1-0ubuntu7.13_amd64.deb nscd_2.11.1-0ubuntu7.13_amd64.deb"

tux (wondersir) wrote :

Yes, many problems. apache won't start, ssh dumps with glibc errors. mysqldump and ntpdate also having problems. I'm sure many others. I have 12 production servers down at the moment. :/

/etc/cron.hourly/settime:
*** glibc detected *** ntpdate: munmap_chunk(): invalid pointer: 0x00007fe7420be3f0 ***
======= Backtrace: =========
/lib/libc.so.6(+0x78cc6)[0x7fe74164acc6]
/lib/libc.so.6(+0x125ec9)[0x7fe7416f7ec9]
/lib/libc.so.6(+0x12628b)[0x7fe7416f828b]
/lib/libc.so.6(getservbyname_r+0x183)[0x7fe7416dade3]
/lib/libc.so.6(+0xb9ff2)[0x7fe74168bff2]
/lib/libc.so.6(+0xbad50)[0x7fe74168cd50]
/lib/libc.so.6(getaddrinfo+0x162)[0x7fe74168f8f2]
ntpdate(+0x4b63)[0x7fe742117b63]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fe7415f0cad]
ntpdate(+0x32b9)[0x7fe7421162b9]
<snip>

*** glibc detected *** mysqldump: munmap_chunk(): invalid pointer: 0x00007fc44560b462 ***
======= Backtrace: =========
/lib/libc.so.6(+0x78cc6)[0x7fc44420ccc6]
/lib/libc.so.6(+0x125ec9)[0x7fc4442b9ec9]
/lib/libc.so.6(+0x12628b)[0x7fc4442ba28b]
/lib/libc.so.6(getservbyname_r+0x183)[0x7fc44429cde3]
/lib/libc.so.6(getservbyname+0x7b)[0x7fc44429cb5b]
/usr/lib/libmysqlclient.so.16(mysql_server_init+0x91)[0x7fc444e5e6e1]
/usr/lib/libmysqlclient.so.16(mysql_init+0xf)[0x7fc444e8a92f]
mysqldump(main+0x3bc)[0x7fc445668e6c]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fc4441b2cad]
mysqldump(+0x4da9)[0x7fc44565dda9]

Dan Woodard (dan-e-woodard) wrote :

Seems I have encountered this bug today. I issued an "apt-get udpate && apt-get upgrade" this morning and upon completion, I now get failures as described above.
root@messina:~# apt-cache policy libc6
libc6:
  Installed: 2.11.1-0ubuntu7.14
  Candidate: 2.11.1-0ubuntu7.14
  Version table:
 *** 2.11.1-0ubuntu7.14 0
        500 http://archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        500 http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
        100 /var/lib/dpkg/status
     2.11.1-0ubuntu7 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

This has broken the following as I can tell so far;
apt-get update
autofs

Ro (robert-markula) wrote :

Take a look at the original bug at https://bugs.launchpad.net/bugs/1352504. This issue has been fixed a few minutes ago.

Please re-do 'apt-get update && apt-get upgrade'. Should that segfault again, then stop the nscd daemon first:

/etc/init.d/nscd stop
apt-get update && apt-get upgrade
/etc/init.d/nscd start

That should pretty much resolve this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers