SATA disks not found after upgrade edgy - feisty

Bug #133892 reported by Steve Westwood on 2007-08-21
6
Affects Status Importance Assigned to Milestone
Debian
Invalid
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Machine is Toshiba Qosmio G20 laptop with Intel 82801FBM (ICH6M) SATA Controller. Worked with Edgy with kernel versions up to 2.6.17-11. Upgraded to feisty using aptitude dist-upgrade and kernel 2.6.20-15 was installed which would not boot - system hangs. Later upgrade to 2-6-20-16 did not resolve. Attempted clean install from Feisty CD image, OK as live CD but disks not detected. Same with latest snapshop of Gutsy and with vanillla Debian Etch. Can install/reinstall Debian Sarge and Ubuntu Edgy OK from CDs.

Baronek (baronek1) wrote :

I can confirm this bug on toshiba g20.

It seems that when ata_piix is loaded before ahci, ahci module will not see harddrives correctly.
This helps from initramfs shell:

rmmod ata_piix
rmmod ahci
modprobe ahci
exit

I resolved the problem by blacklisting ata_piix module in initrd image. It seems it is latter loaded correctly (latter in boot, when system already chrooted)

Also it seems it is duplicate of bug: #139790

Steve Westwood (steve-tmbox) wrote :

Still present after clean Gutsy install. Blacklisting ata_piix as suggested in bug 139790 does not work for me; I have to wait for the boot to fail and drop to a busybox shell. Is there any workaround to allow the machine to boot normally?

Also can this bug be upgraded from status New? Issue has affected both Feisty and Gutsy.

Thanks & Regards,
Steve.

Paolo Lopolito (sharkp) wrote :

I confirm this bug on my toshiba G20, and I can't solve it. How shall I do?

Baronek (baronek1) wrote :

Well I've got some additional info:

In kernel 2.6.23 the problem is still present (compiled with master kernel thread instruticons) but this time bug is less obviouse.
With kernel 2.6.22 and 2.6.20 chances to successfull boot were about 5% (guess the correct order of modules loading)
in kernel 2.6.23 chances of unsuccessfull boot are about 5% - this is progress. I will try kernel 2.6.24 from sources soon.

Also: this is forum thread that I described solving the problem: http://ubuntuforums.org/showthread.php?t=551435

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Is this still an issue with the latest release ?

Baronek (baronek1) wrote :

issue does not persist in ubuntu hardy, so I guess it just solved automagically.

Jean-Baptiste Lallement (jibel) wrote :

thanks for following up. I'm closing this report due to your last comment.

Quoting Jean-Baptiste Lallement <email address hidden>:

> Thanks for your report. Is this still an issue with the latest release ?
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> --
> SATA disks not found after upgrade edgy - feisty
> https://bugs.launchpad.net/bugs/133892
> You received this bug notification because you are a direct subscriber
> of the bug.
>
Amazing! I've just opened my mail to search for an email from Baronek
with the commands to remove ata_piix as I've just done a clean install
of Hardy on my Toshiba Qosmio and the disks have not been found after
the post-installation reboot.

Regards,
Steve.

Baronek (baronek1) wrote :

I'm going to check this Qosmio machine better soon and I will report back, why it's exactly working. But as far as I remember it just 'worked'.

reopening.

Please, can you boot with the livecd and run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

Thanks in advance.

I'm merging this report with bug #139790 because "workarounds" are better described in the other one. Please attach the previously requested information to the other report. Thanks.

Steve Westwood (steve-tmbox) wrote :

Quoting Jean-Baptiste Lallement <email address hidden>:

> reopening.
>
> Please, can you boot with the livecd and run the command "sudo lspci
> -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log"
> to this bug report.
>
> Thanks in advance.
>
> ** Changed in: ubuntu
> Status: Fix Released => Incomplete
>
> --
> SATA disks not found after upgrade edgy - feisty
> https://bugs.launchpad.net/bugs/133892
> You received this bug notification because you are a direct subscriber
> of the bug.
>
I've attached the output file to bug #139790.
Thanks & Regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers