Swap fails to activate in gutsy

Bug #133564 reported by darx on 2007-08-20
8
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Gutsy by Nokia

Bug Description

swap fails during boot.

/home/darx# fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa1dfa1df

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 1824 14651248+ 7 HPFS/NTFS
/dev/sda2 1825 4499 21486937+ 5 Extended
/dev/sda3 4500 14202 77934327 7 HPFS/NTFS
/dev/sda4 14202 14594 3146752 7 HPFS/NTFS
/dev/sda5 1825 4256 19535008+ 83 Linux
/dev/sda6 4257 4499 1951866 82 Linux swap / Solaris

/home/darx# vol_id /dev/sda6
ID_FS_USAGE=other
ID_FS_TYPE=swap
ID_FS_VERSION=2
ID_FS_UUID=8d63103b-28d2-4a1e-922e-af3af15d808f
ID_FS_UUID_ENC=8d63103b-28d2-4a1e-922e-af3af15d808f
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

fstab entry
# Entry for /dev/sda6 :
UUID=8d63103b-28d2-4a1e-922e-af3af15d808f none swap sw 0 0

fstab uuid entry seems ok..

whats happening?

Same here!
There's a thread in ubuntuforums too: http://ubuntuforums.org/showthread.php?t=563265

andrea@tre21:~$ sudo fdisk -l
Disco /dev/sda: 80.0 GB, 80026361856 byte
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes
Disk identifier: 0x54e3cf5c

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 7180 9729 20482875 7 HPFS/NTFS
/dev/sda2 1 6880 55263568+ 83 Linux
/dev/sda3 6881 7179 2401717+ 5 Esteso
/dev/sda5 6881 7179 2401686 82 Linux swap / Solaris

andrea@tre21:~$ sudo vol_id /dev/sda5
ID_FS_USAGE=other
ID_FS_TYPE=swap
ID_FS_VERSION=2
ID_FS_UUID=b38faaf6-74a1-428d-a199-91ecbbd4c1a5
ID_FS_UUID_ENC=b38faaf6-74a1-428d-a199-91ecbbd4c1a5
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

fstab entry:
UUID=b38faaf6-74a1-428d-a199-91ecbbd4c1a5 none swap sw 0 0

Have the exact same problem. Its not a fstab/uuid issue. What I've noticed is that when it fails and I do a sudo vol_id /dev/sda5. the output has "ID_FS_TYPE=suspend" instead of "ID_FS_TYPE=swap".

Once I do a mkswap and then add the new uuid to the fstab file, it starts to work on reboot until for some reason the ID_FS_TYPE get set to suspend again. Any chance this is related to hibernate ?

kenw (kenw) wrote :

I had the problem where swap wasn't getting activated on boot, but my issue was that the UUID in /etc/fstab didn't match the vol_id on the swap partition.

How that happened I don't have any idea, but setting /etc/fstab to match the vol_id fixed it.

Florent (florent.x) wrote :

I had the very same issue as kenw: "the UUID in /etc/fstab didn't match the vol_id on the swap partition"

It is just after an upgrade from Xubuntu 7.04 to Xubuntu 7.10.

balaknair (balaknair) wrote :

Swap partition failed to mount on resuming from hibernate with gutsy.
bala@bala-kubuntu:~$ sudo vol_id /dev/sda12
ID_FS_USAGE=other
ID_FS_TYPE=suspend
ID_FS_VERSION=s1suspend
ID_FS_UUID=50e4bada-e2bc-4cc4-b6a6-ce280decd803
ID_FS_UUID_ENC=50e4bada-e2bc-4cc4-b6a6-ce280decd803
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

I tried rebooting, on start up still got "Activate swap [FAIL]"

swapon didn't work either
had to format the swap partition and then swapon, whereupon it was back to normal

(I'm a newbie at Linux, and this is my first bug comment at Launchpad, so please excuse my ignorance if I haven't provided enough details.)

william (wennsi) wrote :

I've got the same problem after I used gpart to adjust my space. I might have changed the size of the swap partition after the operation. The swap partition failed to mount after the machine resume from sleep. Machine automatically restart with "activating swap fail" error... The problem loops every time I try to sleep my laptop.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers