[needs-packaging] sqlite-ruby

Bug #128262 reported by Neil Wilson on 2007-07-25
4
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned

Bug Description

There is a sqlite3-ruby package in Ubuntu, but no package that does the same for the standard sqlite database.

Neil Wilson (neil-aldur) wrote :

Package created and uploaded to REVU at http://revu.tauware.de/details.py?upid=6175

Neil Wilson (neil-aldur) wrote :

Ready for REVU by MOTUs.

Daniel Holbach (dholbach) wrote :

Marking as 'Fix Committed' to get it reviewed and on http://daniel.holba.ch/sponsoring/

Daniel Holbach (dholbach) wrote :

Oh sorry - the link does not exist anymore; please either do another REVU upload or make use of PPA: http://help.launchpad.net/PPAQuickStart

Daniel Holbach (dholbach) wrote :

Kees: can you please review the package and see if it's ok?

Kees Cook (kees) wrote :

Neil, thanks for the package, it looks good. Since it's a NEW package, we need 2 motu to +1 it (which is what we usually use REVU for). I think this package looks great -- it's mostly clone of sqlite3-ruby, which makes it easy to review. :) +1 from me.

Daniel Holbach (dholbach) wrote :

Uploaded. Should be sitting in the NEW queue: https://launchpad.net/ubuntu/gutsy/+queue

Changes:
 sqlite-ruby (2.2.3-0ubuntu1) gutsy; urgency=low
 .
   * Initial public release
 .
 sqlite-ruby (2.2.3-0~ppa1) gutsy; urgency=low
 .
   * Initial release

Neil Wilson (neil-aldur) wrote :

Such a simple little package this. I thought it'd take about five minutes to get it accepted since it is stable code and a stable packaging architecture. Here we are a good six weeks after I first uploaded it for review and still it is outstanding.

Anyway, we are where we are.

Now that we have mongrel in the archive, this is the last package required to get a standard set of Ruby on Rails application adapters installed on Ubuntu without requiring compilation.

I would ask that it be included in Gutsy simply so that I have a solid base of packages for further development in Hardy.

Scott Kitterman (kitterman) wrote :

"last package required to get a standard set of Ruby on Rails application adapters installed on Ubuntu" is a good reason to get this in. Ack from me for freeze exception. You'll need a 2nd. Setting to New as for freeze exceptions we move it to Confirmed once it is approved for upload.

Soren Hansen (soren) wrote :

This looks sensible and the potential impact is minimal. +1 from me.

Daniel Holbach (dholbach) wrote :

Uploaded, should be sitting in the NEW queue.

Daniel Holbach (dholbach) wrote :

accepted in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers