Adobe Reader doesn't work anymore

Bug #128212 reported by Christoph Singer on 2007-07-25
This bug report is a duplicate of:  Bug #131949: acroread fails to start. Edit Remove
14
Affects Status Importance Assigned to Milestone
Medibuntu
Confirmed
Undecided
Albin Tonnerre
Ubuntu
Undecided
Unassigned

Bug Description

When starting Adobe Reader from the command line with 'acroread' under Ubuntu Gutsy, it immediately
stops with the message
  Gtk-CRITICAL **: gtk_rc_get_style: assertion `GTK_IS_WIDGET (widget)' failed
I know you do not support third party software, but this error may be important for other software too.
Thanks a lot for developing and maintaining Ubuntu!

Vincent Legout (vlegout) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Did you install acroread from medibuntu or the official repos ?

Hello Vincent Legout,

I tried it with the original tar-ball from Adobe and with the version
from medibuntu. The result was identical, as I mentioned in the
bug report.

Greetings
Christoph Singer

Am Wed, 25 Jul 2007 18:43:10 -0000
schrieb Vincent Legout <email address hidden>:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better.
>
> Did you install acroread from medibuntu or the official repos ?
>
> ** Changed in: Ubuntu
> Status: New => Incomplete
>

Vincent Legout (vlegout) wrote :

This bug isn't related to Ubuntu.
I subscribe medibuntu and I mark the bugs as invalid in Ubuntu.

John Yates (andyfranyates) wrote :

Here is a strace of the problem.

Albin Tonnerre (lutin) on 2007-08-05
Changed in medibuntu:
assignee: nobody → lutin
status: New → Triaged
Albin Tonnerre (lutin) wrote :

I can't reproduce the bug. Are you running on i386 or amd64 ?

Tommy Mikkelsen (tamikkelsen) wrote :

I have the same problems. So do many others as well (quick google will show:-))

I run i386, have also tried the medibuntu and official tar files.

atreju (atreju-tauschinsky) wrote :

I get a similar problem with xsane. The bug is reported here: https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/131834

John Yates (andyfranyates) wrote :

As Per request on Ubuntu forums( http://ubuntuforums.org/showthread.php?t=515971)
attached is the deb to use in the instructions.

Saivann Carignan (oxmosys) wrote :

The last Gutsy update for libgtk version 2.11.6-1ubuntu4 fixed the problem for me

Same for me latest libgtk update fix the problem...

Lionel Le Folgoc (mrpouit) wrote :

Setting as 'Fix Released' according to previous comments.

Changed in medibuntu:
status: Triaged → Fix Released
Mikael Nilsson (mini) wrote :

Confirming as fixed.

sön 2007-09-02 klockan 15:02 +0000 skrev Lionel Le Folgoc:
> Setting as 'Fix Released' according to previous comments.
>
> ** Changed in: medibuntu
> Status: Triaged => Fix Released
>
--
<email address hidden>

Plus ça change, plus c'est la même chose

Funny, I've been getting:

---------
...
expr: syntax error
expr: syntax error
...
---------

The entire time I've been in Gusty no matter HOW many ever times I recompile Adobe Reader.

For me it only shows the splash screen and then exits with exit level 1. The main window does never appear. I have updated my Gutsy today.

I have downloaded and installed the Medibuntu package "acroread" today (for Gutsy). It has still the problem of the infinite loop of "syntax error". So I applied the fix described in bug #133464. After that I got Adobe Reader finally working on Gutsy.

Changed in medibuntu:
status: Fix Released → Confirmed
art alexion (art-alexion) wrote :

 brettalton:

I'm not sure how your are compiling Adobe Reader. It is proprietary and only comes in binary packages, not source. Unless, of course you are an Adobe developer.

art alexion (art-alexion) wrote :

Till:

The problem was with the gtk libs. Update them from the ubuntu repositories. I don't know what is in the medibuntu repos.

Lionel Le Folgoc (mrpouit) wrote :

No, gtk libs are fine. The issue is in the regexp which detects the gtk version in the acroread launch script. And acroread is in the medibuntu repository since it has been removed from Ubuntu.

You may be choose this Mediabuntu repo https://help.ubuntu.com/community/Medibuntu
Just install with this command
apt-get install acroread acroread-plugins

But if you run it, there is one warning message like "unable to find html rendering library", you need just follow instruction, and pointing to directory where the file "libgtkembedmoz.so" found. You can found by command "locate libgtkembedmoz.so"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers