install gz-0.5.7.5 : "depends of : ocaml-base-nox-3.08.3 but it is not installable"

Bug #128152 reported by chaying on 2007-07-25
2
Affects Status Importance Assigned to Milestone
Ubuntu Studio
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Hello

I need to compile Demexp, a voting software an for this I need to libraries :

librpc-ocaml-dev, libgz-ocaml-dev, libgz-ocaml and cduce

but when I tried to install the libgz-ocaml-dev, Synaptics answer :

libgz-ocaml-dev:
 Dépend: ocaml-nox-3.08.3 but it is not installable
 Dépend : libgz-ocaml mais ne doit pas être installé

Yours,

chaying (me-buss777) wrote :

Im under ubuntu studio..

This package is not in ubuntu, therefore not an ubuntu bug.

Please report ubuntustudio bugs to https://bugs.launchpad.net/ubuntustudio/

(i've now rerouted this)

Hello

> (i've now rerouted this)

So do I need to repost the bug in ubuntu studio ?
Yours,
D. Laerce

chaying (me-buss777) wrote :

I tried to compile it from the sources : ./configure works and make all give me this messge back :

 make all
ccopt "-D BZ_PREFIX " -c c_gz.c
/bin/sh: ccopt: not found
make: [c_gz.o] Erreur 127 (ignorée)
ccopt "-D BZ_PREFIX " -c c_bz.c
/bin/sh: ccopt: not found
make: [c_bz.o] Erreur 127 (ignorée)
ocamlmklib -oc mlgz c_gz.o c_bz.o -lbz2 -lz
gcc: c_bz.o : Aucun fichier ou répertoire de ce type
gcc: c_gz.o : Aucun fichier ou répertoire de ce type
make: *** [dllmlgz.so] Erreur 2

Yours

Andrew Hunter (rexbron) wrote :

Again, as Sarah said, this is not a bug (in the sense that it is a problem with Ubuntu Studio), but rather a support question. The one (possiblely more) of the libraries you need to compile that piece of software is not in Ubuntu. As Ubuntu Studio pulls its packages from Ubuntu, if it is not in Ubuntu, it won't be in Ubuntu Studio.

For help compiling software, search the wiki, the ubuntuforums.org site or ask for help on IRC (#ubuntu) .

Changed in ubuntustudio:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers