[needs-packaging] UFO:Alien Invasion

Bug #127341 reported by Aaron Whitehouse on 2007-07-21
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nominated for Lucid by mclaud2000

Bug Description

Please package UFO:Alien Invasion. The website is http://ufo.myexp.de/ and http://sourceforge.net/projects/ufoai

Deb is available here: http://www.getdeb.net/app.php?name=UFO+Alien+Invasion but it is only version 2.1 (the official release is up to 2.1.1)

It has a good installer, but it would be great to have it coming through the repos.

Michael Bienia (geser) wrote :

This software is over 250 MB in size. Do we really need such a big package in the archive (and on the mirrors) considering that only some users will install it?

That is a fair question.

Putting it on the mirrors would make life a lot easier than it is at
the moment. It is quite possible that we have 50, less-popular, 5MB
applications than this one.

If we really can't warrant the space then perhaps we could create a
dummy package. That would mean that we could have it get the
dependencies sorted (something that some people have had issues with),
download the files and start the installer. The installer is pretty
good, so that shouldn't cause too many problems.

Is there a policy on this issue? This can't be the only time it has
been asked and I'm sure it will not be the last.

I posted a question to ubuntu-devel-discuss:

I received the response:
"FYI: We already ship GPLed games like Nexuiz (500MB+), and are likely to
get openarena 0.7 (200MB+) during hardy."

So it looks like 250MB should be acceptable.

Dara Adib (daradib) wrote :

I think this would be a great idea, especially for 64-bit users.

Vladimir Yatulchik (yatul) wrote :

I will be also glad to see UFO:AI in Ubuntu repositories :)

Dara Adib (daradib) wrote :

Changing to confirmed status.

Dara Adib (daradib) wrote :

The GetDeb site only has a 32-bit packages, builds for other architectures (including x86_64) would be nice. And the UFOAI 2.2 (in SVN) is coming through very nicely, so that could be packaged for Ubuntu when it a stable 2.2 version is released.

Daniel Nylander (yeager) wrote :

I helped them fix some 64 bit issues when running UFO:AI on my PS3 (Ubuntu ppc64)
2.2 should compile and work on 64 bit systems

Ryan Prior (ryanprior) wrote :

UFO AI 2.2 is really looking polished and it runs great on Windows. Ubuntu really needs to compete with Windows on games, packaging quality GPL'd games at the very least. UFO: AI fills a space left by the other game selections in Ubuntu.

Note that the "fix released" from upstream isn't really "fix released". It is more a temporary "WONTFIX" while textures with "UNKNOWN" license tags are replaced.

@Ryan - it does compete with Windows on this front: visit the UFO website and download the installer, run it and you have the game installed. That is how I remember installing all of my games in Windows. That said, I obviously want this packaged (hence my filing of the bug) as installing through the package manager is one of Gnu/Linux's key advantages.

Note that the latest release is now version 2.2 (with some excellent enhancements). The latest deb is still available here:
(although I personally use the Gnu/Lunix .run file from the official site).

Bartosz Kosiorek (gang65) wrote :

I would like to create this package

Evgeny Kapun (abacabadabacaba) wrote :

Looks like it has already been packaged for Ubuntu: <https://launchpad.net/~gspreemann/+archive/ppa>.

Changed in debian:
status: Fix Released → New
Guest One (g.one) wrote :

Devs are doing a great work and they are replacing non-free stuff as you can read here: http://ufoai.org/wiki/index.php/News/2012#We_did_it.21

UFO:AI deserves to be in official repositories.

Changed in ubuntu:
status: Confirmed → Invalid
Ryan Prior (ryanprior) wrote :

Game still needs packaging. Is there a good reason to leave the bug as invalid? Are we interested in adding Free games to the archive, or should this maybe be packaged through the App Store process?

Changed in ubuntu:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.