Macbook Pro 15 Haswell/Retina 11.1 Speakers Do Not Work (Ubuntu 13.10)

Reported by Krzysztof Janowicz on 2013-11-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-base
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

On the new Macbook Pro 15 Haswell/Retina 11.1 the speakers do not work in Ubuntu 13.10.

I tried adding "options snd_hda_intel model=mbp101" (and mbp111) to alsa-base.conf but this does not work.

Reinstalling alsa-base and pulseaudio together with sudo alsa force-reload also does not work. Headset does work.

Florian Boucault (fboucault) wrote :

Workaround:
$ sudo apt-get install alsa-tools
$ sudo hda-verb /dev/snd/hwC1D0 0x1 set_gpio_data 1

Upstream seems to be working on the issue:
http://mailman.alsa-project.org/pipermail/alsa-devel/2013-September/066167.html

Krzysztof Janowicz (janowicz) wrote :

Thank you very much. Unfortunately it does not work for me. Do I still need the also-base settings?

Krzysztof Janowicz (janowicz) wrote :

Just as update: the workaround seems to work only for the version with the integrated graphics (see http://ubuntuforums.org/showthread.php?t=2184760&page=4&p=12839760#post12839760). I have the hybrid model running the open source driver (Gallium 0.4 on NVE7).

Krzysztof Janowicz (janowicz) wrote :

Just as update: it looks like they are still working on the speakers for 11.3, see https://bugzilla.kernel.org/show_bug.cgi?id=64401

Krzysztof Janowicz (janowicz) wrote :

Seems fixed with mba6 setting for 11.3 as well.

Changed in ubuntu:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.