Realtek RTL8188CUS Driver problems (can't connect to WiFi 802.11n)

Bug #1244408 reported by Angelos Sfakianakis on 2013-10-24
36
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The built-in driver for the Realtek RTL8188CUS (802.11bgn) Wireless Card is extremely buggy.
On Ubuntu 13.04 it was able to see all available networks, but when you tried to connect to any of them it entered an infinite loop of connection attempts. This was a fact, regardless of the Wireless Standard the network was using (b, g, n).
Now, on Ubuntu 13.10 and equipped with the latest updates and fixes, things are a little better. My computer can actually connect to Networks using the b and/or g Standards, however the problem persists for Networks that use the 802.11n Standard.
The Network at the University I am attending uses both g and n Standards; I can't tell whether the Access Points are operating at g/n mode or whether some are Broadcasting according to 802.11n while others use the 802.11g... Using a Smartphone Application I can see that there is Network activity both at 2.4GHz and at 5GHz, so I guess both are used simultaneously.
The fact is that I can't connect to the Network. Using `nm-tool` I found out that the University Network is broadcasting at channels 1, 4, 6 and 11. Whenever I search for Networks, I see that the Signal Strength is 100%; however, upon trying to connect, it suddenly drops to 10% and enters a loop for about 30 to 50 seconds, then reports an error. I tried to install the original Realtek driver, but it won't compile for kernel version 3.2 and above. There is also a project on Google Code - someone created a dkms Package - but it is operational only on Ubuntu 13.04 instead of 13.10 that I'm using now.
There is absolutely no problem with the University Network and my Wireless Card works like a charm on Windows 8. The only remaining problem is on Linux, regarding solely the 802.11n Standard, as far as I can tell.
This is a serious bug; my Computer is now completely deprived of its Wireless functionality. I just bought it (2 weeks ago), but still can't use it as a tool for my studies... Please, someone take time to address the Bug as soon as possible. I searched the Internet and found many other cases of users experiencing similar problems with the Realtek 8188CUS card on Ubuntu.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1244408/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Will this bug ever be fixed? I can find references to it since 2011... Please, someone let me know if I can do anything to help!

paulzeb (pc-lumija) wrote :

I had it working in 12.04 with the blacklisting older drivers and installing from the vendor package but this no longer works in 13.10.

PS I have no computer training or experience

Markcortbass (markcortbass) wrote :

I confirm this bug. It's not working in Ubuntu 13.10

Willem Vanhulle (wlvh42) wrote :

This patched version of the driver is working for me on Ubuntu 13.10 https://github.com/pvaret/rtl8192cu-fixes

Willem Vanhulle (wlvh42) wrote :

I found a fix on this site (did i have to choose for fix commited?): https://github.com/pvaret/rtl8192cu-fixes
from site:
"This is a port of Realtek's own 8192cu driver for USB Wifi chipsets, ported to kernel 3.11 as ships with Ubuntu 13.10.

It was initially based on Timothy Phillips's work as published here: https://code.google.com/p/realtek-8188cus-wireless-drivers-3444749-ubuntu-1304/, though no longer."

Changed in ubuntu:
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-03-23
Changed in ubuntu:
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers