Massive filesystem corruption with Intel Pro 1000 GT Desktop NIC

Bug #119565 reported by skunky on 2007-06-09
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Installed removed an SMC NIC, and installed the Intel one into a fully updated Feisty system. Everything worked! I didn't need to install drivers or anything. Life was good until I decided to see how hard I could push the NIC. I started copying files to another machine, and my system crashed. I actually had to hit reset. When my machine rebooted, the file system was toast. The superbolck was intact, but there were hundreds of errors on the drive. The file system was ext3.

I recovered my files, with a live CD, and transfered them to another PC over the network. I formated the partition, and reinstalled (with a Feisty beta CD). On reboot, Feisty started downloading updates, and while it was doing that, I decided to restore my evolution directory. This again caused a crash and massive file system corruption.

I'm not sure if it's important, but my BFG 6200 OC video card and the Intel NIC are sharing interrupt 11. I run PowerMax diagnostic software from time to time, so I'm sure that my hard drive is working well. The hard drive cable is new, and all of my PC's fans are turning.

When the system crashes, the mouse stops responding, the internet connection is lost, but the system still responds to keyboard inputs. Control alt backspace, and delete don't fully work, which is why I had to hit reset.

ProblemType: Bug
Architecture: i386
Date: Sat Jun 9 08:10:50 2007
DistroRelease: Ubuntu 7.04
Uname: Linux Linus 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

Thank you for your report.

Can you please povide us with more details? e.g.: dmesg, lspci -vv, lspci -vvn, /proc/interrupts. Have you also checked the log files in /var/log for any useful information?

Thanks in advance.

skunky (mark-mcdonnell) wrote :

I just reinstalled, and had a look at the things you suggested. I didn't see anything that looked really wrong, but then I'm not really sure what I'm looking for. I've attached the logs, and the output of the commands you suggested.

skunky (mark-mcdonnell) wrote :

OK, I just reproduced the problem, and collected all of the information I could. Here's what happened in chronological order:

* I browsed to the shared folder of my windows XP box (which also has a gigabit NIC), and started to download a 700 MB file to the desktop of my Ubuntu machine. It seems that I don't have any real problems with my Ubuntu box untill I get the NIC working at gigabit speeds. The NIC on my XP box is an on board VIA device. There's a gigabit switch between the two machines.

* 52.1 MB of the file downloaded, and that's it. The estimated time remaining indicator started increasing, and the mouse stopped responding. I believe this is around the time that I would have tried the control alt delete, and backspace before.

* A message popped up saying "Error "Timeout reached: while copying "smb://(not relevant....)". Would you like to continue?" The options were cancel and retry. I selected retry with the keyboard, but the same message popped up again, so I selected cancel.

* Around this time, the network connection was lost, and then reestablished. The mouse did not start working again.

* I control alt F1ed to a text screen and restarted.

* Unlike the times when I had pressed reset, I was able to boot to a full GUI. I seems that my use of the reset button, and lack of patience may have been responsible for some of the file system corruption.

* I collected the logs, crash report, and the output of dmesg, lspci -vv, lspci -vvn, and /proc/interupts, zipped them, and am uploading them with this message.

It seems that fsck found some file system corruption, but nothing as bad as what I saw before.

You also attached a crash report for graveman (the cd burn application). Did you use it in this context? Was the 700 Mb file an iso image?

skunky (mark-mcdonnell) wrote :

Woops. I probably should have included that file. No, I wasn't burning a CD when this happened. I was copying a CD sized file from an XP machine to my Ubuntu machine.

Thanks for your comment. Let me ask you if the file has been of a cd size or was name .iso or something like that so nautilus might have thought that this file gets burned. This would explain the graveman crash probably.

skunky (mark-mcdonnell) wrote :

Actually, the file ended with a .mp4 extension.

kurt belgrave (trinikrono) wrote :

Hey guys i was looking around and saw this old bug and was wondering if you where still affected?
Cheers

Changed in ubuntu:
status: Confirmed → Incomplete

I think I was. I sent that NIC back to Intel, and they swapped it out for a new one without testing it. My hardware has morphed so much since then anyways. I'm not concerned about this now.

M

----- Original Message -----
From: kurt belgrave <email address hidden>
Date: Friday, September 3, 2010 2:46 pm
Subject: [Bug 119565] Re: Massive filesystem corruption with Intel Pro 1000 GT Desktop NIC
To: <email address hidden>

> Hey guys i was looking around and saw this old bug and was
> wondering if you where still affected?
> Cheers
>
> ** Changed in: ubuntu
>        Status: Confirmed => Incomplete
>
> --
> Massive filesystem corruption with Intel Pro 1000 GT Desktop NIC
> https://bugs.launchpad.net/bugs/119565
> You received this bug notification because you are a direct subscriber
> of the bug.
>

kurt belgrave (trinikrono) wrote :

Closing this bug report due to your last comment, Keep filing bug reports and making ubuntu better!

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.