Dell Inspiron 1420 Intel i965 not supported

Reported by Roger Noriega on 2007-06-08
16
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Feisty
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

The default driver provided by the feisty LiveCD install does not work with Intel 's i965 chipset. I've tried the i810, vesa, and xserver-xorg-video-intel all failed.
I upgraded the driver to xserver-xorg-video-intel 1.9.4 from universe that driver displays a black screen when X is restarted and hard locks the system the only way recover is to press the power button.

Is there any chance of someone providing a backport of the 2.0 driver for the i965 chipset 2.0 it worked in Gutsy.

Bryce Harrington (bryce) wrote :

Hi Roger,

Sorry you're having trouble; yes, as I understand it, the latest -intel is required to get i965 support. I don't have access to an i965 system so have not been able to do any testing on it.

The vesa driver is supposed to work though. Could you send your /etc/X11/xorg.conf and /var/log/Xorg.0.log files when booting with the "vesa" driver?

Changed in xserver-xorg-video-intel:
status: Unconfirmed → Needs Info
Bryce Harrington (bryce) wrote :

Also, can you report whether you installed the "915resolution" package when using the i810 driver?

Ben Collins (ben-collins) wrote :

I have an update on the status of the v2 -intel xorg driver backport for feisty.

The problem we are having is that this package is in universe in feisty. We don't have a policy of updating packages in universe post-release, and I'm not even sure that our archive process will allow it. The -proposed and -updates pockets are for packages in main. We can put it in the backports pocket, however, this pocket isn't enabled by default in normal installations.

The other issue is that even if we did a big dance and moved this to main (doing this post-release is also way beyond what we normally do), it still wouldn't resolve the issue. For one, it's not part of the default install even if it is in main, and secondly, it wouldn't help people trying to install from live CDs. Respinning CDs would require a lot of testing, and would still only benefit users who download the images, not ones getting pressed CDs from shipit.

So the overhead here isn't really matching up with the benefit. What I've discussed with Colin, and I'm waiting to hear back from him on, is to simply create a backport package for Dell to use internally on their factory image, and document that if people wish to install Ubuntu with something other than the recovery process on this system, they will need to wait for gutsy to be released (which is in October).

Does this seem like an optimal solution?

Tim Gardner (timg-tpi) wrote :
Tim Gardner (timg-tpi) wrote :
Ben Collins (ben-collins) wrote :

Kyle is working on these packages.

Changed in xserver-xorg-video-intel:
assignee: nobody → kyle
status: Needs Info → In Progress
importance: Undecided → High
rez (rezwanul-kabir) wrote :

Building i915 and intel_agp, from the -16 kernel source as provided by Ben, against -15 kernel does resolve the issue. "intel" video driver can now be used to run X on -15 kernel.

 One problem I see ( which I probably have seen with -16 kernel as well), is that when I run "dpkg-reconfigure xserver-xorg" to configure xorg.conf with "intel" driver the screen goes blank when it tries to autodetect the monitor. However, on reboot X start fine.

    Tim, pls confirm on your end, since you have the Intel Gfx, that the solution (with new i915 and intel_agp )works and the above minor issue does occur.

I was just about to start building those debs, should I still make them?

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
rez
Sent: Wednesday, June 20, 2007 11:44 AM
To: WW Linux Engineering
Subject: [Bug 119232] Re: Dell 1420 (Lanai) Intel i965 not supported

Building i915 and intel_agp, from the -16 kernel source as provided by
Ben, against -15 kernel does resolve the issue. "intel" video driver can
now be used to run X on -15 kernel.

 One problem I see ( which I probably have seen with -16 kernel as
well), is that when I run "dpkg-reconfigure xserver-xorg" to configure
xorg.conf with "intel" driver the screen goes blank when it tries to
autodetect the monitor. However, on reboot X start fine.

    Tim, pls confirm on your end, since you have the Intel Gfx, that the
solution (with new i915 and intel_agp )works and the above minor issue
does occur.

--
Dell 1420 (Lanai) Intel i965 not supported
https://bugs.launchpad.net/bugs/119232
You received this bug notification because you are a direct subscriber
of the bug.

Changed in xserver-xorg-video-intel:
assignee: nobody → kyle
importance: Undecided → High
status: New → In Progress

See resolution for #122125

Changed in xserver-xorg-video-intel:
assignee: kyle → nobody
status: In Progress → Invalid
assignee: kyle → nobody
importance: High → Undecided
status: In Progress → Invalid
importance: High → Undecided
Changed in redfish:
assignee: nobody → timg-tpi
importance: Undecided → High
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

Packages for xserver-xorg-video-i810 and 915resolution have been submitted for upload that solve this problem.

Changed in redfish:
assignee: timg-tpi → nobody
status: In Progress → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305713

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers