[needs-packaging] nightingale

Bug #1190146 reported by Pander on 2013-06-12
80
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Nightingale
New
Low
Unassigned
Ubuntu
Wishlist
Unassigned
nightingale (Debian)
New
Unknown

Bug Description

name: nightingale

description: Nightingale is an audio player and web browser based on the Songbird media player source code.

url: http://getnightingale.com/ and http://en.wikipedia.org/wiki/Nightingale_%28software%29

license: GPLv2, MPL, BSD

justiication: It took a while but since Songbird has dropped support for Linux, Nightingale has continued to bring this player to a Linux audience. It should be positioned next to Rhythmbox.

note: PPA is already available, use

run:
gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.Sgx9GzBi47 --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 1F8E6217F8D14E2768237984807AE9E3672921BB

and add this line to /etc/apt/sources.list
deb http://ppa.launchpad.net/nightingaleteam/nightingale-release/ubuntu raring main

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Pander (pander) on 2013-06-13
description: updated
Erikcht (qrcyen) wrote :

This bug need be voteted to package goes to ubuntu !?

Idealy, it should be landing to Debian first, and then Ubuntu would catch it up.

Adolfo Jayme (fitojb) on 2013-06-26
Changed in ubuntu:
status: Confirmed → Triaged
Changed in nightingale (Debian):
status: Unknown → New
Pander (pander) on 2013-10-23
tags: added: 14.04
removed: 13.10
Pander (pander) on 2014-04-29
tags: added: 14.10
Sergio Benjamim (sergio-br2) wrote :

There is many lintians errors and warnings in this package. Take a look:

http://pastebin.com/zdEqXCzK

You should fix this first, to send to debian repo.

Erle Pereira (erle) wrote :

a shout out.....Just started to work on this, with version 1.12 (latest from repo). Building a debian binary, without those errors, with an aim to try and get it pushed into the Debian repo first, as mentioned above.

Have been making a few changes to the build, .. to work around those errors, and happy to report some progress here

Trying to go for a native build. As it currently stands, I have worked past a few of them,
lintian report is here http://pastebin.com/1QD8jR1S

as can be seen, some the image-file, jar-not-in-usr are easily fixed, my debian spec is just written well yet

the embedded-library errros like this..
E: nightingale: embedded-library usr/lib/nightingale/components/sbDBEngine.so: sqlite

are the points at which main chunk of the work is required, I would estimate. Each of those need compilation options to use the respective shared library from the repo instead. There might be some already in, not had a deep look in yet.

will report/ update the pastebin as I work through, and hopefully, get it to a point where it is ready to be sent in to the debian repo and take it from there.

Hello, the package was not found in the Debian repositories.

Guys, what do you think of launching the new package with updated dependencies, because the source code on github dependencies are different from older versions that exist in the Ubuntu repositories. To do so would involve all responsible for the packages to keep them updated and from there build another package, I'm talking to a programmer friend of Debian, I think he'll help us....

Martin Giger (freaktechnik) wrote :

Hi, Nightingale developer and the guy who maintains the release package of nightingale on launchpad here. First of, we are aware of the lintian errors. Most of them are in our dependencies, which might require a special build configuration for debian, yes. If you have patches to create such a configuration, please don't hesitate to shoot it back to us on github, even if it's a separate build config. The reason why the packages here on lp have different deps than what's in the github repo, is because that's what we were at at the last release, 1.12.1. We'll hopefully be able to get rid of some of the stuff in the deps in the future, but for example debian's taglib is giving us a lot of trouble (same with sqlite).
The github issues that might be of interest to you are
https://github.com/nightingale-media-player/nightingale-deps/issues/18 (as you can see, we've got some imporved eps right in that issue!)
https://github.com/nightingale-media-player/nightingale-deps/issues/17

We'd also appreciate if you'd stop by in our irc channel, #nightingale on irc.mozilla.org, as that'll help work together too, as we're interested in having a debian package! Also, our github branches, especially in the deps repo, might look like a mess to you, and we can help!

John Murray (johnmurrayvi) wrote :

Martin, I haven't pushed this to the ng-deps repo yet, but: https://github.com/johnmurrayvi/nightingale-deps/commit/b6279339c472bb0dff15cd3158567f3b9945cee4

I was going to try to add in changes mentioned by darealshinji in https://github.com/nightingale-media-player/nightingale-deps/issues/18 first, but I've gotten caught up in this windows issue.

There are some dependency packages in the second link that have some improvements.

@Emanuel I've been working on building an updated version of Nightingale that uses updated dependencies for a over year now. There are a lot of other issues to worry about besides using what's available in the Debian or Ubuntu repositories, unfortunately, and the build system is already incredibly complex, particularly for the dependencies. One of the primary problems with focusing on this issue is that Nightingale supports Mac and Windows. A number of the other problems, like using native TagLib and SQLite, come from the application itself previously relying on the patched dependencies, and the limited time and resources the development team has to allocate, prevent a quicker resolution to this.

It sadly won't be an overnight fix, but believe me, I would love to have this in the Debian and Ubuntu repos too!

Erle Pereira (erle) wrote :

HI,

agree, will do as you suggest,
thanks for the links, will go through them and get myself upto speed.

was planning to tackle sqlite first... though now I'm thinking different.

let me get my head around things, and will add to the effort.
see you IRC -- im @oneand0

got involved over past couple of weeks. one of the developers pointed me here.

Erikcht (qrcyen) wrote :

Erle, this is your code that you fix ...

can you explain more for everyone what miss ?

https://github.com/erlepereira/nightingale-hacking

Erle Pereira (erle) wrote :

Hi Everyone, I added an option to compile, using libsqlite as a system shared library. That code is forked off upsteam above. The option itself, is --with-sqlite-source=system,packaged.

With that the lintian error for libsqilte is no longer present, but I did introduce a bug it seems. When compiled using the shared libsqlite option, on running, it starts up with the message
"Nightingale has detected that your Library is corrupt and cannot be read.........Your media files are safe and will not be deleted, but you'll need to rescan them"

Choosing the "Delete and Restart"option results in the same message.
* It is triggered when using the system shared libray, it works fine when reverting back to the packaged option like it is now.
*tested on Debian Sid, and Ubuntu 14.04. Same message.

Updated the pastebin http://pastebin.com/hwUtNuY1 with the latest GDB backtrace, I suspect it is triggering a thread race condition somewhere, looking into it, any pointers / tips?

Sergio Benjamim (sergio-br2) wrote :

Erle, I forked from your fork, and merge upstream commits, and I got this:

E: nightingale: embedded-library usr/lib/nightingale/xulrunner/libsqlite3.so: sqlite

Is it right?

---

I'm trying to fix this hardening-no-relro thing, I tried what is described in https://wiki.debian.org/HardeningWalkthrough#Enabling_dpkg-buildflags_in_your_debian.2Frules_files , like this:

#!/usr/bin/make -f

export DEB_BUILD_MAINT_OPTIONS = hardening=+all

%:
 dh $@ --parallel

[...]

But I still getting hardening-no-relro lintian error.

Any idea?

Sergio Benjamim (sergio-br2) wrote :

For image-file-in-usr-lib and jar-not-in-usr-share, upstream should fix it, it seems they does not follow the Filesystem Hierarchy Standard.

https://github.com/nightingale-media-player/nightingale-hacking/issues/313
https://github.com/nightingale-media-player/nightingale-hacking/issues/314

---

There are more 5 embedded libraries in this program (Erle is working in libsqlite3.so: sqlite):

libnss3.so: nss
libxul.so: zlib
libxul.so: libtheora
libxul.so: libjpeg
updater: bzip2

https://github.com/nightingale-media-player/nightingale-hacking/issues/315

djcj (djcj) wrote :

Might wanna take a look at my NG PPA: https://launchpad.net/~djcj/+archive/ubuntu/nightingale

Changed in nightingale:
importance: Undecided → Low
Pander (pander) wrote :

Since we are almost a year down the road, any update for including this package from http://ppa.launchpad.net/nightingaleteam/nightingale-nightly/ubuntu

Pander (pander) on 2016-04-27
tags: added: yakkety
removed: 14.04 14.10
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.