[needs-packaging] [Upstream] LanguageTool, a grammar checker for LibreOffice

Bug #114375 reported by Dorota Kattowitz
118
This bug affects 19 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
Baltix
Invalid
Undecided
Unassigned
Ubuntu
Triaged
Wishlist
Unassigned
Declined for Maverick by Sebastien Bacher
libreoffice (Debian)
New
Unknown

Bug Description

Binary package hint: libreoffice

Although LibreOffice still has not come up with a built-in grammar checker, the grammar checker LanguageTool - 1.3.1, which is already available as an openoffice-plugin

http://www.languagetool.org/

is now quite mature and it already has a relative stable LibreOffice integration interface.

I believe we should immediately package LanguageTool and enter it to at least the universal section of the Gutsy repository, or preferably the main section and be installed by default whenever LibreOffice is installed, so that people can check their grammar *immediately*. This would place both Ubuntu and LibreOffice itself well ahead.

Changed in openoffice.org:
importance: Undecided → Wishlist
Revision history for this message
Fabián Rodríguez (magicfab) wrote : Re: [needs-packaging] LanguageTool, a grammar checker for OpenOffice.org
Changed in openoffice.org:
status: New → Confirmed
Changed in easyubuntu:
status: New → Invalid
Revision history for this message
Fabián Rodríguez (magicfab) wrote : Re: [Ubuntu] [hardy] [needs-packaging] LanguageTool, a grammar checker for OpenOffice.org

I changed original the description to reflect new URL of the project.

Java 5.0 is a requirement, and as such, should be a dependency. Can th eoriginal reporter (Dorota) or anyone else in the notification list check which exact packages should this one depend on, as a result of the Java 5 requirement ?

description: updated
Changed in openoffice.org:
assignee: nobody → magicfab
status: Confirmed → Incomplete
Revision history for this message
Suco (sucotronic) wrote :

Language tool is now in version 0.9.2. It would be a great idea to integrate it with ubuntu an openoffice.
+1

Chris Cheney (ccheney)
Changed in openoffice.org:
status: Incomplete → New
Chris Cheney (ccheney)
Changed in openoffice.org:
status: New → Triaged
Revision history for this message
Fabián Rodríguez (magicfab) wrote :

Satrting with Intrepid, Language tool would require the OpenJDK 6.

Changed in openoffice.org:
assignee: magicfab → nobody
Chris Cheney (ccheney)
Changed in openoffice.org:
importance: Wishlist → Undecided
status: Triaged → New
Changed in openoffice.org-dictionaries:
importance: Undecided → Wishlist
Revision history for this message
Jonathan Ernst (jonathan.ernst) wrote : Re: [needs-packaging] LanguageTool, a grammar checker for OpenOffice.org

OpenOffice.org 3.1 has an even better support of LanguageTool http://www.openoffice.org/dev_docs/features/3.1/index.html#r2.3 it would be excellent to take the opportunity of packaging it and make this package depend on openoffice.org (or specific language-support packages)

Chris Cheney (ccheney)
affects: openoffice.org-dictionaries (Ubuntu) → openoffice.org (Ubuntu)
Changed in openoffice.org (Ubuntu):
assignee: nobody → Chris Cheney (ccheney)
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Revision history for this message
Indian Art (goldfish-aol) wrote :

Hi Guys,
I second that. This would be so useful. Can help some of us avoid embarrassing grammatical mistakes.

Thanks!

Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu):
assignee: Chris Cheney (ccheney) → nobody
milestone: ubuntu-9.10-beta → none
Revision history for this message
Pander (pander) wrote :

Update 2009-11-01: Released version 1.0.0. Changes include:

    * Support for Danish, Catalan, and Galician
    * Rule and dictionary fixes for Dutch, French, Italian, Polish, Spanish, Swedish, and Russian
    * More rules for Dutch, Polish, Russian, Spanish, Slovenian, and English
    * Several bug fixes

Please package this version.

Revision history for this message
Pander (pander) wrote :

Please, make LanguageTool.jar directly available by the installation process of this package. Language Tool can be used as a stand alone application as can be seen here:
  http://www.languagetool.org/usage/
The OXT fie from OpenOffice needs to be unzipped somewhere in order to offer this. Perhaps /usr/share/languagetool would be a proper location. Note that deinstalling or upgrading the OXT will have to be reflected in the unzipped version.

Also /usr/bin or /usr/sbin should offer a shell script called languagetool that will call
  java -jar /usr/share/languagetool/LanguageTool.jar
with all arguments provieded to the shell script.

Makeing the JAR available in the proposed way will allow users to access the functionality directly from the command line. This will offer LanguageTool functionality also outside of OpenOffice.

Revision history for this message
Rune Philosof (olberd) wrote :

LanguageTool will probably make its way into Debian.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=403619

Revision history for this message
Indian Art (goldfish-aol) wrote :

LanguageTool 1.0.0 works very well with OpenOffice 3.2 on Ubuntu 9.10

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Packaging of LanguageTool is necessary. I'm really surprised that LanguageTool still not installed automatically in Ubuntu.

tags: added: maverick
Revision history for this message
usr_share (usrshare) wrote :

LanguageTool is a very important piece of software, it really should be included into Ubuntu's repositories.

Revision history for this message
darkshvein (darkshvein) wrote :

Strongest reqiured for russian dirting-paper mans!

Pander (pander)
tags: added: natty
Revision history for this message
Pander (pander) wrote :

On 2010-09-26 version 1.1 has been released. Please package this more than three year old bug according to proposed in comment number 8 so it will be available in OpenOffice and on the command-line too.

Revision history for this message
Pander (pander) wrote :

Keep in mind that a XUL Add-on like http://sourceforge.net/projects/thb-gramchecker/ should also be able to easily use languagetool's local installation.

Revision history for this message
In , RussianNeuroMancer (russianneuromancer) wrote :

Please provide grammar checking mechanism in the LibreOffice.

Revision history for this message
In , RussianNeuroMancer (russianneuromancer) wrote :

Maybe include Language Tool in LibreOffice? Or, if it's not possible or if there available better solution, maybe rules created for Language Tool can be useful?

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Mark Shuttleworth say the LibreOffice will be in the Ubuntu 11.04 instead of Go-oo.
http://www.documentfoundation.org/

Then maybe discuss with LibreOffice developers about creating grammar checking in the LibreOffice? (Not as a separate plugin, like a LanguageTool.)

Post your ideas about it here: https://bugs.freedesktop.org/show_bug.cgi?id=31059

Revision history for this message
In , Nopower (nopower) wrote :

languagetool is provided in beta2

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Since 3.3 Beta 2 LanguageTool integrated in LibreOffice. Then we can just wait for Natty release.

Revision history for this message
Pander (pander) wrote :

Will this also allow users to call language tool from the command line to run on text or source files?

Can Mozilla add-ons for grammar checking also call this functionality as explained above?

Can one upgrade language tool easily or will it be locked into the releases of LibreOffice?

A flexible system for upgrading and direct (command line) calling is preferred and I would like to suggest decoupling. What are your thoughts on this?

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Then It's should be reassigned from openoffice.org to ubuntu, lika a typical needs-packaging bug.

If LibreOffice already include LanguageTool and LibreOffice will be part of Natty, then it's not openoffice.org bug anymore, right?

Revision history for this message
Pander (pander) wrote :

But LibreOffice should be able to use a newer version of Language Tool installed via a package. So it would involve both Ubuntu and LibreOffice. Can representative from both parties have a look at this and come up with a solution?

I'd prefer: For both spelling and grammar on Linux, Open/LibreOffice should use what is offered via packages on the system, so both spelling and grammar can upgrade and be used independently of Open/LibreOffice.

Revision history for this message
In , Michael Meeks (michael-meeks) wrote :

We should prolly file the "Encourage LanguageTool to be in C++ or python, not Java" bug though :-)

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

When installing LibreOffice from the PPA it will remove OpenOffice.org (at least currently). Also please note LanguageTool will not be in LibreOffice, this was a mistake and has been reverted. See: https://bugs.freedesktop.org/show_bug.cgi?id=32377

Revision history for this message
In , RussianNeuroMancer (russianneuromancer) wrote :

Since RC2 LanguageTool is not part of LibreOffice anymore. Now opened again.

Revision history for this message
In , Michael Meeks (michael-meeks) wrote :

Good point; the basic complaint was a lack of translation, that and the Java requirement which tends to plague Windows users without Java with tens of annoying dialogs on first-start :-)

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :
Revision history for this message
In , Yr (yr) wrote :

Translation interface fixed in LanguageTool 1.1 and higer.
http://www.openoffice.org/issues/show_bug.cgi?id=114078

Alternative grammar checking extension is Lightproof.
Lightproof is written on Python.
http://extensions.services.openoffice.org/en/project/lightproof
But Lightproof is less powerful then LanguageTool.

Revision history for this message
In , Michael Burns (prescience500) wrote :

It would be nice if eventually java free grammar/style/similar stuff checking could be included inside libreoffice, but something more powerful than lightproof or even languagetool. I don't know if something like that would fit in with this bug though.

Revision history for this message
In , Yr (yr) wrote :

It maybe old Python version of Languagetool
http://tkltrans.sourceforge.net/gram.htm
But this version have not OpenOffice/LibreOffice integration.

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

I plan to fix this issue in the next few months, based on Lightproof, partially extending the English Lightproof demo with the results of LanguageTool development, too. But I strongly think, with the default settings the proofreader doesn't have to hurt the users any false warning messages. The Grammalecte French grammar checker extension (released a few days ago by its author, Olivier Ronez, athe developer of the French spelling dictionary) also follows this conception. Grammalecte is based on Lightproof: in their grammar rules it uses Hunspell and the installed French Hunspell dictionary for morphological analysis, also it has native Options menu in LibreOffice (see http://www.dicollecte.org/grammalecte/documentation.php).

It seems, Microsoft has also problems with their grammar checker:

"It would be possible to 'dial up the sensitivity' of the Word grammar checker to catch more errors, the company said. However, that could also cause it to flag sentences considered correct in colloquial usage.

That would risk making the tool more intrusive than people want, the company said. In fact, Microsoft dialed down the sensitivity of the grammar checker in certain respects starting in 2002, responding to customer feedback." See http://www.seattlepi.com/business/217802_grammar28.asp

Revision history for this message
In , michel (mnedeleg) wrote :

Have you heard about Gramadoir?

It's an open source grammar checking engine developed by Kevin Scannel:
http://borel.slu.edu/gramadoir/index.html
I haven't tried it but it seems to be usable and well documented.

Kevin Scannel is also involved in the irish translation of LibreOffice.

There is an effort to integrate it on OpenOffice:
http://www.beta.scriobh.ie/Page.aspx?id=38&l=2

Hope that helps.

Changed in openoffice.org (Ubuntu):
status: Triaged → Invalid
summary: - [needs-packaging] LanguageTool, a grammar checker for OpenOffice.org
+ [needs-packaging] LanguageTool, a grammar checker for LibreOffice
description: updated
Changed in libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Yr (yr) wrote :

Any progress?
Is planned grammar checker in LibreOffice 3.4?

Revision history for this message
In , Jeffdchang (jeffdchang) wrote :

This sounds like an enhancement... so I will mark it as such.

Changed in libreoffice:
importance: Medium → Wishlist
Revision history for this message
Christopher M. Peñalver (penalvch) wrote : Re: [needs-packaging] LanguageTool, a grammar checker for LibreOffice

Remarking openoffice.org as Triaged, undoing the Invalid by RussianNeuroMancer as no justification was given.

affects: libreoffice → df-libreoffice
Changed in openoffice.org (Ubuntu):
status: Invalid → Triaged
Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
summary: - [needs-packaging] LanguageTool, a grammar checker for LibreOffice
+ [needs-packaging] [Upstream] LanguageTool, a grammar checker for
+ LibreOffice
tags: added: lo33
Revision history for this message
Pander (pander) wrote :

Thanks for the recent activity and connecting it to Libre Office.make sure that LanguageTool gets packaged as languagetool, separate from Libre Office so it can be upgraded independantly. And what is said in comment #8 about also unzipping the plugin for possible command line usage.

Changed in libreoffice (Debian):
status: Unknown → Fix Committed
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote : migrating packaging from OpenOffice.org to Libreoffice

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Revision history for this message
In , Yr (yr) wrote :

Is it possible add this grammar checker extensions (based on LightProof) to LibreOffice 3.5?

Lightproof grammar checker for Russian
http://extensions-test.libreoffice.org/extension-center/lightproof-grammar-checker-for-russian
Grammalecte grammar checker for French
http://extensions-test.libreoffice.org/extension-center/grammalecte

Lightproof grammar checker for Hungarian
http://extensions-test.libreoffice.org/extension-center/magyar-mondatellenorzo

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

Created attachment 54135
Sentence checking patch for English dictionary extension

These patches add non-intrusive sentence/grammar checking to the
English and Hungarian dictionary extensions based on the Lightproof
Python environment, see the attached test file/documentation.
It uses LibreOffice resources (Hunspell spell checker, Calc functions
etc.) for complex tasks: dictionary lookup, morphological analysis or
optional measurement conversion.
Recent English dictionaries of LibreOffice have contained only partial
part-of-speech and morphological data, yet, but extending the
dictionary, we will be able to add more complex grammar rules, too
(like the Hungarian and French Lightproof based extensions).

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

Created attachment 54136
Hungarian sentence checking patch for the Hungarian dictionary extension

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

Created attachment 54137
Test file and documentation for the sentence checking patches

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

Created attachment 54138
Documentation for the sentence checking patches (PDF)

Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

Short description about the Lightproof integration with the dictionary extensions (it is not an automatic process yet):

1. Copy dialog/* and pythonpath/* directories and Lightproof.py, Linguistic.xcu of your Lightproof extension to the dictionaries/your_language/ directory of LibreOffice.

2. Extend COMPONENT_FILES variable of makefile.mk with these new files.

3. Extend manifest.xml with the following elements:

    <manifest:file-entry manifest:full-path="dialog/OptionsDialog.xcs"
                manifest:media-type="application/vnd.sun.star.configuration-schema" />
        <manifest:file-entry manifest:full-path="dialog/OptionsDialog.xcu"
                manifest:media-type="application/vnd.sun.star.configuration-data" />
        <manifest:file-entry manifest:media-type="application/vnd.sun.star.uno-component;type=Python"
                manifest:full-path="Lightproof.py"/>
        <manifest:file-entry
                manifest:media-type="application/vnd.sun.star.configuration-data"
                manifest:full-path="Linguistic.xcu" />

4. Change extension ID of dialog/OptionsDialog.xcu to the ID of the dictionary extension (see in description.xml):

<prop oor:name="Id">
    <value>org.openoffice.en.hunspell.dictionaries</value>
</prop>

Revision history for this message
In , Caolanm (caolanm) wrote :

this is integrated into master now I believe.

Can you give me an English grammar error which LightProof should be able to detect ?

Revision history for this message
In , Caolanm (caolanm) wrote :

oops, I see there's a sample attachment here of stuff it can detect. Yup that one works.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
papukaija (papukaija) wrote :

Please set the LO task back to triaged as the plugin isn't included in Ubuntu's LO, is not available in the repositories nor is integrated into LO (or it doesn't work). However, the current upstream LO is shipped with Lightproof, not LanguageTool. Please see bug 980991 for lightproof's packaging for Ubuntu.

Revision history for this message
papukaija (papukaija) wrote :

A proper status for LO might be won't fix as the plugin would be packaged separately.

tags: removed: maverick migrateoootolo natty
Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

> A proper status for LO might be won't fix as the plugin would be packaged separately.
You are right.

Changed in baltix:
status: New → Invalid
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

RussianNeuroMancer, please do not toggle the status of this bug without providing a comment justifying the status change.

Changed in libreoffice (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Christopher, please look at #27 and @28 comments.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

russianneuromancer: Still not "Fix released" in "libreoffice (ubuntu)" as clearly the libreoffice package of ubuntu does not yet include LanguageTool. This needs to be filed against Ubuntu as it is an independant package.

affects: libreoffice (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
milestone: none → ubuntu-12.10
Revision history for this message
Dominique Pellé (dominique-pelle) wrote :

> However, the current upstream LO is shipped with Lightproof, not LanguageTool.

Yes, but LanguageTool is more advanced than LightProof. LanguageTool supports far more languages.
So creating an Ubuntu package for LanguageTool would be good.

OpenSuse packages LanguageTool:
https://build.opensuse.org/package/binaries?package=libreoffice-languagetool&project=openSUSE%3A12.1&repository=standard

Revision history for this message
In , Gerry-treppel (gerry-treppel) wrote :

I grammar checking in the Linux version actually included? Having had a look at the manual here (http://www.numbertext.org/lightproof/sentencecheck.pdf), I could not get it working. As far as I understood, a functioning LightProof grammar checker depends on the existence of the right dictionary "English spelling and hyphenation dictionaries and thesaurus 2011.12.05". This extension seems to be not coming with the Ubuntu PPA. At least in my extension manager it is missing and I could not find it anywhere on the internet.
Is my assumption right that the Lightproof grammar checker is missing on Linux?

Changed in df-libreoffice:
status: Confirmed → Fix Released
Revision history for this message
In , László Németh (nemeth-libreoffice) wrote :

(In reply to comment #21)
Parts of the English dictionary extension are separated in different Ubuntu packages, but it seems, platform-independent grammar checking component of the original LibreOffice dictionary extension hasn't been supported in Ubuntu, yet.
Debian has got a single grammar checker package here: http://packages.debian.org/sid/libreoffice-lightproof-en, perhaps it works with Ubuntu, too. (If not, try this oxt LibreOffice extension: http://numbertext.org/tmp/lightproof_en-0.4.2.oxt)

Revision history for this message
Dominique Pellé (dominique-pelle) wrote :

This bug is marked as duplicate of bug #980991 but they are not duplicates:

Bug #980991 is about LightProof in LibreOffice
Bug #114375 is about packaging LanguageTool grammar checker

LanguageTool and LightProof are two completely different grammar checkers.
LanguageTool supports far more languages and detect more errors.
LanguageTool can also be used standalone without LibreOffice.
LanguageTool is written in Java. LightProof is written in Python.

Revision history for this message
Pander (pander) wrote :

Indeed, these are two different grammar checking engines. LightProof will support using the rules of LanguageTool but these have to be converted and shipped with LightProof. It should be up to the user which one or both to use.

Changed in ubuntu:
milestone: ubuntu-12.10 → none
Changed in libreoffice (Debian):
status: Fix Committed → New
no longer affects: openoffice.org (Ubuntu)
Changed in ubuntu:
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
Pander (pander)
tags: added: artful
Revision history for this message
Pander (pander) wrote :
Pander (pander)
tags: added: bionic
Pander (pander)
tags: added: cosmic
removed: artful
Pander (pander)
tags: added: disco
removed: bionic cosmic
Pander (pander)
tags: added: groovy
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.