[needs-packaging] PyQt5

Bug #1130784 reported by Michael Terry
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Now that Qt5 is available in raring and since upstream supports Qt5, it would be nice to see that support packaged in raring too.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] [NEW] Support Qt5

Is Qt5 in Main?

Revision history for this message
Michael Terry (mterry) wrote : Re: Support Qt5

Not yet. Its MIR is bug 1130281. Not approved yet, but likely will be this cycle.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] Re: Support Qt5

Python-qt4 would need to build-dep on Qt5, so this can't be done until it's in Main.

Revision history for this message
Michael Terry (mterry) wrote : Re: Support Qt5

Right.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

The stable version of PyQt4 supports only Qt 5 release candidate, support for final version is added in snapshots but not released yet.

Regarding this bug: are you going to do that in separate package set (i.e. python3-pyqt4-qt5-*)? I would not recommend to switch existing packages to using Qt 5 as theming support in Qt 5 is currently broken, so lots of apps will look ugly.

Changed in python-qt4 (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] Re: Support Qt5

It'll be different binaries for Qt5

Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Support Qt5

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-qt4 (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

wontfix until Qt5 is in Main.

Changed in python-qt4 (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

QtBase is already in main: https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1130281/comments/18.

I would prefer if QtSvg was also in main, but for the start you can support only QtBase (which is what most people need).

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] Re: Support Qt5

OK. I'd be willing to start with that. I don't know when I'll have time
though, so patches welcome. I'd like to see the Qt5 package split by module
to begin with as has been previously requested for Qt4. It'll also need
python and python3 versions.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Qt 5 is for bleeding-edgers, which most likely have ported their apps
to python3...

I'll prefer to wait for PyQt 4.10 which has working support for Qt 5
(their Hg repository doesn't seem to be publicly available, so it'll
be difficult to backport the relevant fixes to 4.9).

Revision history for this message
Scott Kitterman (kitterman) wrote :

Dmitry Shachnev <email address hidden> wrote:

>Qt 5 is for bleeding-edgers, which most likely have ported their apps
>to python3...
>
>I'll prefer to wait for PyQt 4.10 which has working support for Qt 5
>(their Hg repository doesn't seem to be publicly available, so it'll
>be difficult to backport the relevant fixes to 4.9).

Upstream has said the next release will be soon.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: Support Qt5

New PyQt is in raring, so this could be done now. Patches welcome (and you need to plan to write an FFe).

Changed in python-qt4 (Ubuntu):
status: Won't Fix → Triaged
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

I had a quick look at this bug today, for some reason it doesn't know about QtGui/QtWidgets split that happened in Qt5: http://paste.ubuntu.com/5622371/.

The easiest way will be to patch it to link QtGui stuff against QtWidgets, but I'm not sure if it's the correct approach (or maybe I'm doing something wrong). Maybe there's some wiki page describing how to build it against Qt5?

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Not sure if I had more or less success with my attempt: http://paste.ubuntu.com/5649003/
It certainly would be nice to know how it's suppose to be configured.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

I have linked a branch that "monkey-patches" the packaging and fully builds all binary packages (sans not-yet-ported or obsolete modules phonon & qtassistant) against Qt5.

Ideally we just do inplace transition and transition all reverse-dependencies to Qt5. In practice I doubt it will be possible, since Qt4 libraries might still be used by reverse dependencies (e.g. python-kde4).

Thus my questions are:
* what package names to use for the "against Qt5 build"? python[3]-qt4. python-qt4-qt5 (?!)
* how to handle co-installing qt4 and qt5 builds? given that pyqt4 upstream uses PyQt4 namespace for both builds.

Binary packages for Raring are build in this ppa:
https://launchpad.net/~xnox/+archive/scratch/+packages

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] Re: Support Qt5

If it were me, I'd find out when PyQt5 will be out since that's what we really want. Then there's no issue.

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: Support Qt5
Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 1130784] Re: Support Qt5

Right, but that doesn't say when.

Revision history for this message
Dmitry Shachnev (mitya57) wrote : Re: Support Qt5

Can we convert this bug to "needs-packaging: PyQt5" now that snapshots are available?

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Upstream won't be supporting newer Qt 5 versions in PyQt 4, so coverting it to "needs-packaging: PyQt5".

Good news: I was almost able to build PyQt 5 locally! Hope to have a packaging available next week.

affects: python-qt4 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: nobody → Dmitry Shachnev (mitya57)
summary: - Support Qt5
+ [needs-packaging] PyQt5
tags: added: needs-packaging
Changed in ubuntu:
assignee: Dmitry Shachnev (mitya57) → Scott Kitterman (kitterman)
Changed in ubuntu:
assignee: Scott Kitterman (kitterman) → nobody
Changed in debian:
status: Unknown → New
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

The package is available for testing in ppa:mitya57/ppa (based on the linked branch). Please test it, and I'll commit it to the DPMT SVN.

Based on my comment #11 and some IRC discussions, I dropped Python 2 packages (but will happily add them back if someone is interested). Here I also follow upstream, which dropped "installers" for Python 2.x.

Known issues:

- No dbus.mainloop.qt package yet, I'll discuss with upstream possible ways to avoid conflicts with PyQt4.
- No split by modules yet (requested in comment #10), but I'm going to split out at least WebKit module.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Quick status update:

> No dbus.mainloop.qt package yet, I'll discuss with upstream possible ways to avoid conflicts with PyQt4.

Upstream renamed that to dbus.mainloop.pyqt5 in the current snapshot, I've updated the packaging but it's commented out until the next upstream release.

> No split by modules yet (requested in comment #10), but I'm going to split out at least WebKit module.

Split by modules is now done.

I went ahead and committed the current version to DPMT SVN. Sponsorship welcome :)

Revision history for this message
Scott Kitterman (kitterman) wrote :

Can you cherrypick the dbus.mainloop changes from the snapshot so we can do that too? Otherwise it'll be another trip through New.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

> Can you cherrypick the dbus.mainloop changes from the snapshot so we can
> do that too? Otherwise it'll be another trip through New.

Done in SVN (though it looks like we'll have to do that trip anyway at some point because of the Declarative module).

Changed in debian:
status: New → Fix Committed
Revision history for this message
Scott Kitterman (kitterman) wrote :

Sync'ed from Debian experimental. In the Ubuntu New queue.

Changed in ubuntu:
status: Triaged → Fix Released
Changed in debian:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.