[needs-packaging] unity-tweak-tool

Reported by Barneedhar on 2013-02-15
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity Tweak Tool
High
Barneedhar
Ubuntu
Wishlist
Unassigned

Bug Description

Unity Tweak Tool is a configuration manager for Unity desktop environment.

URL: https://github.com/freyja-dev/unity-tweak-tool
License: GNU General Public License 3
Notes: Latest version 0.0.3

Barneedhar (barneedhar) on 2013-02-15
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Robert Roth (evfool) on 2013-02-17
Changed in ubuntu:
status: New → Confirmed
Barneedhar (barneedhar) on 2013-02-17
Changed in unity-tweak-tool:
importance: Undecided → High
assignee: nobody → Barneedhar (barneedhar)
status: New → Triaged
Barneedhar (barneedhar) wrote :

Just to make it clear, the GitHub repo already has the packaging and not just upstream code.

Also, subscribing the ubuntu-sponsors team for reviewing the package and sponsorship process, as I was told to do.

Daniel Holbach (dholbach) wrote :

The set up of your packaging is a bit strange - you have two options:
  + either make it "native", you remove debian/watch and changelog the version number in debian/changelog to "0.0.3" (without a dash something) or...
  + you make it non-native and push release tarballs (without the debian/ directory) to https://launchpad.net/unity-tweak-tool/+download and change debian/souce/format to "3.0 (quilt)"
right now it's a mix of the two options...

A few other small things:
N: Processing binary package unity-tweak-tool (version 0.0.3-0ubuntu1, arch all) ...
I: unity-tweak-tool: description-synopsis-might-not-be-phrased-properly
N:
N: The synopsis (first line in the package "Description:" field, the short
N: description) ends with a full stop "." character. This is not necessary,
N: as the synopsis doesn't need to be a full sentence. It is recommended
N: that a descriptive phrase is used instead.
N:
N: Note also that the synopsis is not part of the rest of the
N: "Description:" field.
N:
N: Refer to Debian Developer's Reference section 6.2.2 (The package
N: synopsis, or short description) for details.
N:
N: Severity: minor, Certainty: possible
N:
N: Check: description, Type: binary, udeb
N:
I: unity-tweak-tool: extended-description-is-probably-too-short
N:
N: The extended description (the lines after the first line of the
N: "Description:" field) is only one or two lines long. The extended
N: description should provide a user with enough information to decide
N: whether they want to install this package, what it contains, and how it
N: compares to similar packages. One or two lines is normally not enough to
N: do this.
N:
N: Refer to Debian Developer's Reference section 6.2.1 (General guidelines
N: for package descriptions) and Debian Developer's Reference section 6.2.3
N: (The long description) for details.
N:
N: Severity: minor, Certainty: possible
N:
N: Check: description, Type: binary, udeb

Apart from that it looks good to me. :)

Changed in ubuntu:
status: Confirmed → Incomplete
Barneedhar (barneedhar) wrote :

Thank you Daniel. We have decided on going native and I have since removed the debian/watch file and updated changelog with just the version number (0.0.3).

And the two minor niggles with the description in debian/control file have been fixed too.

Hoping for another review now. :)

Changed in ubuntu:
status: Incomplete → Confirmed
Michael Terry (mterry) wrote :

Looks better!

A few comments:
- You should use debhelper compat level 9 (instead of 8) to avoid running dh_pysupport by default.
- The app crashed for me on close.
- When you've fixed these, please let us know which git commit you want us to pull from. Otherwise, if someone comes to this bug in a few days, they'd grab trunk which might have some changes you didn't intend to land in Ubuntu yet.

Barneedhar (barneedhar) wrote :

Thanks Michael. I have since included changes that address both your concerns.

Please pull from git commit fedc33ac1. If there are any further issues that need our attention, please let us know. Thanks again for your feedback!

Barneedhar (barneedhar) wrote :

Actually pull from the newer git commit f4c7e5f4bac please. I just fixed a little issue with the symbolic icons.

Bhavani Shankar (bhavi) wrote :

looks great from the overall packaging perspective but the latest commit fails to build on my updated pbuilder

creating /tmp/buildd/unity-tweak-tool-0.0.3/debian/unity-tweak-tool/usr/share/applications
copying build/share/applications/unity-tweak-tool.desktop -> /tmp/buildd/unity-tweak-tool-0.0.3/debian/unity-tweak-tool/usr/share/applications
running install_egg_info
Writing /tmp/buildd/unity-tweak-tool-0.0.3/debian/unity-tweak-tool/usr/lib/python3/dist-packages/unity_tweak_tool-0.0.3.egg-info
Traceback (most recent call last):
  File "setup.py", line 75, in update_config_new
    for line in fin:
  File "/usr/lib/python3.3/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 340: ordinal not in range(128)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "setup.py", line 163, in <module>
    cmdclass={'install': InstallAndUpdateDataDirectory}
  File "/usr/lib/python3/dist-packages/DistUtilsExtra/auto.py", line 100, in setup
    distutils.core.setup(**attrs)
  File "/usr/lib/python3.3/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/usr/lib/python3.3/distutils/dist.py", line 917, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python3.3/distutils/dist.py", line 936, in run_command
    cmd_obj.run()
  File "setup.py", line 138, in run
    update_config(self.install_lib, values)
  File "setup.py", line 92, in update_config
    update_config_new(libdir,values)
  File "setup.py", line 86, in update_config_new
    except u.URLError as e:
NameError: global name 'u' is not defined
make[1]: *** [override_dh_auto_install] Error 1
make[1]: Leaving directory `/tmp/buildd/unity-tweak-tool-0.0.3'
make: *** [binary] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
E: Failed autobuilding of package
I: unmounting /var/cache/pbuilder/ccache filesystem
I: unmounting dev/pts filesystem
I: unmounting proc filesystem
I: cleaning the build env
I: removing directory /var/cache/pbuilder/build//17024 and its subdirectories
bhavani@bhavani-spagetti-monster:~/sponsoring/unity-tweak-tool$

Are you able to reproduce the same?/Am I missing something here?

Regards
Bhavani

J Phani Mahesh (phanimahesh) wrote :

We were able to reproduce the same. It was caused due to using an accented A for one of our team member's names and a typo in the error handling code. Both were fixed and the package now builds cleanly on pbuilder instance. Thanks for pointing those out.

Commit b1537482f3c1a1bfb8d8eb3a6b1f6ec48b3ecf88 has the fixed code. If there are any further issues that need our attention, please let us know.

Bhavani Shankar (bhavi) wrote :

Looks good on the latest commit. Builds installs and removes fine. Runs fine on my system.

Uploading.

Thanks a lot for your work

Regards
Bhavani

Bhavani Shankar (bhavi) wrote :

Uploaded. Sitting in new queue.

Regards
Bhavani

Changed in ubuntu:
status: Confirmed → Fix Committed
Bryce Harrington (bryce) wrote :

[Nothing left to sponsor, so unsubbing sponsors at this time.]

Barneedhar (barneedhar) on 2013-03-18
Changed in unity-tweak-tool:
status: Triaged → Fix Released
Changed in ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers