unable to install libcairo2:i386 on 12.10 x86_64

Bug #1079355 reported by odror

This bug report was converted into a question: question #214310: unable to install libcairo2:i386 on 12.10 x86_64.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Invalid
Undecided
Unassigned

Bug Description

When installing it I get the following message:

# apt-get install libcairo2:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libatk-wrapper-java-jni : Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be installed
                           Depends: libatk-wrapper-java (>= 0.30.4-0ubuntu4) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I suspect that it fails because the 32bit version is different from the 64 bit version. Because of this incompatibility I am not able to install seam on my Ubuntu 12.10 (64 bit). I have similar issue when trying to install wine.

Revision history for this message
Micah Gersten (micahg) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

for what it's worth, I was able to install this package in a clean chroot. I also had it installed on my quantal amd64 system.

affects: launchpad → ubuntu
Changed in ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions