[needs packaging] KSquirrel - image viewer for KDE

Reported by Alex_xxx on 2007-04-17
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Paul Gevers

Bug Description

I'm using KSquirrel image viewer for a long time and need always rebuild
it from sources for my KUbuntu. Can anybody become a maintainer for it and
put this viewer in KUbuntu repos ?

Here is project page: http://ksquirrel.sourceforge.net/

This is an image viewer for KDE, which supports many image formats and using OpenGL to show images. IMHO, It is faster than Gwenview and also supports PSD images.

Richard Johnson (nixternal) wrote :

This will be a packagers nightmare due to all of the different licenses the ksquirrel-libs contain.

Jonathan Davies (jpds) wrote :

I'll take this on (pbuilding test package now).

Jonathan Davies (jpds) wrote :

Too difficult to get source to build.

Alex_xxx (alex-x1980) wrote :

Built without problems on Debian Etch. Feisty can use Etch packages. Which problems did you meet ?

Sergei Andreev (seajey) wrote :

Problem in gutsy with ksquirrel-libs:
in gutsy we have libjasper1 version 1.900.1-3 (gutsy)
in debian etch libjasper-1.701-1

So, synaptic says:
Package: ksquirrel-libs
Status: Error:Dependency is not satisfiable: libjasper-1.701-1

There is ksquirrel-libs compiled for gutsy:
http://www.badongo.com/file/4586264

but it has not svg codec :(

Alex_xxx (alex-x1980) wrote :

JPEG2000 dependency is fixed. See

http://kde-apps.org/content/show.php?content=12317&forumpage=10

for more.

Harald Sitter (apachelogger) wrote :

I guess, I'm the 3rd one to try packaging it ;-)

In fact I already have packages, just needs polishing and licence/copyright checking.

Daniel Holbach (dholbach) wrote :

Where is the source package? Are we talking about http://revu.tauware.de/details.py?package=libksquirrel ?

Alex_xxx (alex-x1980) wrote :

Original source code could be downloaded from http://ksquirrel.sourceforge.net/download.php

Daniel Holbach (dholbach) wrote :

Bumping back to 'triaged' until there's a link to the source package.

Harald Sitter (apachelogger) wrote :

depends on bug 172740

Sergei Andreev (seajey) wrote :

What is the current status?
bug 172740 is Fix Released

Harald Sitter (apachelogger) wrote :

Ubuntu Hardy Heron (8.04), the next version of Ubuntu, is in feature freeze. So ksquirrel will go into Ubuntu 8.10 as soon as it's developmented is kicked off.

Sergei Andreev (seajey) wrote :

Well, libksquirrel already in Hardy and Interpid, how about ksquirrel itself?

Sergei Andreev (seajey) wrote :

Any news?

Paul Gevers (paul-climbing) wrote :

I am volunteering to help package KSquirrel. Is there any way I can help? Any place where I can see what has already been done? It runs straight on my home system, I guess the main job is to figure out the licenses and some man-pages like stuff (as far as my lintian complains).

Harald Sitter (apachelogger) wrote :

Paul, apparently the ksquirrel packaging got lost in a REVU move, and I don't have a local copy anymore.

I probably won't have time to work on it for quite some time, so you would have to start all over again (which might not be that bad of an idea anyway).... but I have to warn you, for the libs the licensing was already pretty time conusuming, so I think it will be very much the same for the GUI, if you want to work on it, just go ahead :)

I'll add myself as Mentor, if you start working please assign the bug to yourself.

Paul Gevers (paul-climbing) wrote :

Harald,

I have a serious problem with the package. I have the package which builds clean on Hardy, but the build dependencies can not be for filled in Intrepid. KSquirrel build depends on libkexif1-dev and libkonq5-dev (Hardy libkonq5-dev) (upstream says kde-devel). Only IIUC the former is a KDE3 library and the latter a KDE4 library. I have tried briefly to build libkexif1-dev myself, but if that is the way, than I have to spend some time on it to make a patch for that (it is not trivial, as far as I can see it). I am not sure how to proceed, any idea? I'll attach the package diff, which only contains the debian dir.

Paul Gevers (paul-climbing) wrote :

I made a PPA for KSquirrel (Hardy). Available for i386 if you include the following in your apt sources.list entries:
"""
deb http://ppa.launchpad.net/paul-climbing/ubuntu hardy main
"""

Sergei Andreev (seajey) wrote :

It works good in hardy.
And it would be nice to have KSquirrel in interpid.

Harald Sitter (apachelogger) wrote :

Paul, it's fairly impossible to get libkonq5 in Intrepid.

I guess no KSquirrel untll Sergei ports it to KDE 4 really.

Harald Sitter (apachelogger) wrote :

meant to say libkonq4 (i.e. the KDE 3 version).

Paul Gevers (paul-climbing) wrote :

> I guess no KSquirrel untll Sergei ports it to KDE 4 really.

Which, he wrote to me, he is not going to do shortly. He has no time at the moment. So don't count on it soon.

Sam Rog (samrog131) wrote :

KSquirrel and Intrepid

As said KSquirrel needs libkonq4 (and libkonq4-dev to build).

Workaround:

Dropping kdebase (4:3.5.10-0ubuntu1) to the PPA => libkonq4 + libkonq4-dev for Intrepid.
After this, it is possible to build and have KSquirrel in the Intrepid.

=> It is here: https://launchpad.net/~samrog131/+archive

It is working fine EXCEPT

#1
It is build without kipi support as libkipi5 conflicts libkipi0. If you try to install libkipi0 (or KSquirrel with kipi support):

gwenview will be removed
libkipi5 will be removed
libkipi0 (version 0.1.6-1) will be installed

#2
KSquirrel is not working when KDE 4.1 desktop effects are enabled (KSquirrel is showing black pictures). OpenGL conflict ?

Sergei Andreev (seajey) wrote :

>KSquirrel is not working when KDE 4.1 desktop effects are enabled (KSquirrel is showing black pictures). OpenGL conflict ?

In my case KSquirrel works but with some glitches.

KDE 4.1.2
nVidia with prop.driver, desktop effects are enabled

>> KSquirrel is not working when KDE 4.1 desktop effects are enabled
> (KSquirrel is showing black pictures). OpenGL conflict ?
>
> In my case KSquirrel works but with some glitches.
>
> KDE 4.1.2
> nVidia with prop.driver, desktop effects are enabled

Did you build KSquirrel yourself or did you use one of the PPA versions
(Sam Rogs)?

Paul

Sergei Andreev (seajey) wrote :

From this PPA:

## Ksquirrel
deb http://ppa.launchpad.net/paul-climbing/ubuntu hardy main

There is a problem with loading speed of big high quality wallpapers in full screen and sometimes high cpu load when when switching from fullscreen mode to regular one.

Some times picture view just closing when Enter is pressed, instead of fullscreen.

And by the way - there is no tabs anymore.

Sergei Andreev (seajey) wrote :

>Some times picture view just closing when Enter is pressed, instead of fullscreen.

Strange, mouse double click works

Sergei Andreev (seajey) wrote :

>Some times picture view just closing when Enter is pressed, instead of fullscreen.

Strange, mouse double click and middle click works.

Paul Gevers (paul-climbing) wrote :

>>From this PPA:
>
> ## Ksquirrel
> deb http://ppa.launchpad.net/paul-climbing/ubuntu hardy main
>
> There is a problem with loading speed of big high quality wallpapers in
> full screen and sometimes high cpu load when when switching from
> fullscreen mode to regular one.
>
> Some times picture view just closing when Enter is pressed, instead of
> fullscreen.
>
> And by the way - there is no tabs anymore.

Ok. So thanks for the bug-report, but the problem is that I created that
package with build dependencies from Hardy. It can not be build as it is
on Intrepid, because the dependencies were removed or changed.
Therefore, it is nice that it (nearly completely) works, but that
doesn't mean we are closer to closing this bug. I haven't checked it,
but I assume Sam Rog is right.

Unfortunately we can not get the package in Intrepid with
build-dependencies in a PPA, it needs proper building on intrepid
packages. So until the source is properly upgraded to KDE4 I don't think
this will find a solution. And as I don't know much about KDE yet, I am
not going to help upstream at this stage to accomplish that. Of course,
people can use the PPA if they find it useful.

Kind regards
Paul

Jonathan Thomas (echidnaman) wrote :

Upstream hasn't made a release in two years, so a KDE4 port is probably not going to happen. (At the least not any time soon)
Since it's unmaintained and requires KDE3 components not available in the current development release (or any release since 8.10) I will be closing this bug.

Changed in ubuntu:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers