[needs-packaging] OpenCollada library (for blender Collada import/export plugins)

Bug #1058777 reported by daniel mejia on 2012-09-29
114
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

on the blender package that comes with Ubuntu 12.10 the collada import/export pluging seems to be missing due to OpenCollada libraries not available on ubuntu/debian.

Debian RFP: http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=15;bug=694879

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blender (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-03-12
Changed in blender (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Changed in blender (Debian):
status: Unknown → New

Blender 2.67b on Windows 7 - Collada exporter present and works.
Blender 2.67b on Ubuntu 12.04 LTS - Collada exporter does not appear in Blender Export menu.

Bug open for 9 months.
FAIL.

Blender maintainer "Thomas Dinges" claims in Blender 2.6 bug report #36129:

"Install blender from blender.org, we have no control over third party builds. They seem to have Collada disabled."

Blender.org then closed the bug report, blaming Ubuntu for bad packaging.

This bug was incorrectly triaged. It's not an enhancement request.

Now that we have acknowledgement from Blender maintenance that this is a Ubuntu failure of a valid feature, the status should be changed from "Wishlist".

Downloaded Blender 2.67b from Blender.org. Same version as obtained with apt-get from the Ubuntu repository.

Collada exporter PRESENT and works in copy downloaded from Blender. org.
Collada exporter MISSING in copy downloaded from Ubuntu repository.

Something definitely went wrong in the Ubuntu packaging of Blender. I wonder what else is missing?

Sam Bull (dreamsorcerer) wrote :

As already mentioned, this is not a wishlist item. A feature of the application does not exist in the Ubuntu version due to bad packaging, and appears to have been that way for a long time. This is affecting many people, and should be fixed.

Matthias Klose (doko) wrote :

This is not "bad packaging" but a library which is not yet packaged. The best thing is to provide a source package packaging this library.

Dimitri John Ledkov (xnox) wrote :

As per https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages requests for new packages are filed against "Ubuntu distribution no package", once opencollada is packaged it can be enabled in Blender package in ubuntu.

affects: blender (Ubuntu) → ubuntu
summary: - Collada import/export is missing
+ [needs-packaging] OpenCollada library (for blender Collada import/export
+ plugins)
tags: added: needs-packaging
description: updated
description: updated
Mattia Rizzolo (mapreri) wrote :

Since this is a missing package issue, there is also the relative wnpp bug. Linking it instead of the missing collada import/export feature in blender

affects: blender (Debian) → debian
Changed in debian:
status: New → Unknown
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Released

This is getting ridiculous. Usually Collada is the DEFAULT blender export format, and yet it has been non-existent in Ubuntu builds for more than 3 years now.

Mara Kim (hacker-root) on 2016-01-14
Changed in ubuntu:
status: Triaged → Incomplete
status: Incomplete → Confirmed
Bernard Hugonnet (bernard-y) wrote :

This NOT a missing "OpenCollada" Library, The 2.69 ubuntu version is just compiled without the collada extension plugin, as explained on the blender plugins site. As a matter of proof, when you download the 2.76b binaries from the blender site, it works perfectly and features the .dae/collada import and export.

As Blender is a major element of Ubuntu distibutions (especially the studio one), and because .dae is one of the most important data formats for file exchange and transfer, fixing it is not a simple comfort wish but an important point.

OpenCollada library might be interesting for other software, According to http://opencollada.org/, it is used to deveop Iāˆ•O plugins for 3ds-MAX and Maya at the moment.
Blender seems to use its own code: http://fossies.org/dox/blender-2.76b/collada_8cpp.html

Sam Bull (dreamsorcerer) wrote :

If I understand correctly, the Debian/Ubuntu package is built from packages from the repo. So, it is a missing package, as the packager must build it using the opencollada debian package. The pre-built binary from Blender has already been built with all these dependencies in a non-Debian fashion (and thus could not be part of the repositories).

However, as the upstream bug reports fix released, this looks like the Blender package should be able to be built correctly for Debian repositories now. The upstream package appears to be here: https://packages.debian.org/stretch/opencollada-dev

Ajay Anand (aanand-ub) wrote :

I am disappointed to see the same mistake has been carried over to Ubuntu 16.04 which installs Blender 2.76 by through default repositories. It has been years and Ubuntu developers still have not been building Blender properly for the release. Is it not clear that a critically important feature of Blender has been missing for over 3 years due to improper building process adopted by Ubuntu community that requires an urgent change. If you need to put Blender's dependency on OpenCollada then do it. What are you waiting for?

Ajay Anand (aanand-ub) wrote :

Steps requires to install blender on Ubuntu 16.04:
1. apt -y install blender
2(important). Launch blender. Spend hours modeling a product and be frustrated on your inability to export.
3. apt autoremove blender
4. Open your web browser and download a copy of Blender from blender.org

Ajay Anand (aanand-ub) wrote :

OpenCollada is optional but important. It is not just a wishful feature, it is an important productivity feature (just like assistive technologies are more than mere wishes).

https://wiki.blender.org/index.php/Dev:Doc/Building_Blender

And opencollada-dev is already in Ubuntu's official repository.

$ apt-cache show opencollada-dev
    Description-en: Stream based reader and writer library for COLLADA files (development files)

Please take immediate steps.

Tobias Voit (antaragtc) wrote :

This bug is now 4 1/2 years old. Stuff like this gives Linux in particular (and open source software in general) a bad name.

Sam Bull (dreamsorcerer) wrote :

Just checked in an Ubuntu 17.04 VM, and I'm seeing Collada (.dae) under the export option. So, this has been fixed.

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.