System eventually freezes during large data transfer from samba share

Bug #104256 reported by Tomas Plesek on 2007-04-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When transferring large amount of data (several gigs) from server samba share to local machine over the wireless, the transfer hangs after while (no pattern here, sometimes it's after few hundred M, sometimes the transfer finishes). At first, it is possible to kill the window with transfer status and to continue using the computer, but in about a minute, the system starts to lockup. It is possible, to hit ctr+alt+backspace to restart X, but the screen just goes blank and the X server is not able to start again. Also, if you try to jump over to console, you can use say reboot command, but during the process, the system locks up completely. Logs show no useful info.

Found similar bug report on ubuntuforums: http://ubuntuforums.org/showthread.php?t=400276

System:
Feisty Fawn beta with latest updates from repositories
CPU: Intel Core 2 Duo T2300E
RAM: 1024 DDR2
Intel 945GM Express

description: updated

I too am experiencing lockups on large file transfers.

I am trying to transfer several gigs from an external hard drive (FAT32) to a secondary internal hard drive (ext3) mounted at /home.

The progress bar comes up and says 2 hours remaining, but shortly after, the system completely locks; the clock doesn't even change.

I thought that I might have install some package that corrupted Ubuntu's ability to successfully complete large file transfers, so I did a full reinstall. After the re-installation and immediately after my first login, I attempted to do the same file transfer again. It again locked the system as it did before.

Additional info:

I have a pci USB2 / Firewire card (internal hub), because this PCs motherboard only has USB1 ports natively. The external hard drive that I mentioned earlier, was hooked up through this PCI card.

I tried the same large transfer again using one of the motherboard USB1 ports and it has yet to freeze, with 38 hours remaining for the transfer to complete!

The question is this:

Is it the USB2 / Fireware PCI card that Ubuntu has a problem with OR the speed of the transfer? Is a buffer getting overloaded somewhere?

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Tomas Plesek (tomas-plesek) wrote :

Well, I am using Gusty now and it does not seem to be a problem anymore. However, I determined that the bug occured only if my system used xfs or reiserfs filesystem, on ext3 things run fine (at least for me, but Lonnie here has different experience). All things considered, I cannot help you investigate any further. Thanks for your concern and keep up the good job!

Miłosz Kosobucki (mikom) wrote :

I can confirm that. I am using gutsy gibbon on HP pavilion notebook (AMD Turion processor, nvidia ethernet on both computers ). I tried copying large .iso file over wifi network (through linksys WRT54GC router) from ubuntu to windows xp. In about middle of the operation my ubuntu laptop freezed completely (for some unknown reason the capslock led was blinking, however it does so on every hard lockup). It wasn't the first time like that. Eariler I tried copying the same file to other winxp machine.

cirobr (ciro-rosa) wrote :

Hello,

I confirm the problem on Ubuntu Hardy under the following conditions, system updated as of today.
* Hardy Server to Hardy Desktop
* Hardy Desktop To Hardy Desktop

Any word on problem solving is appreciated.

Thanks.

ALo (aluminum3458) wrote :

I am experiencing this issue in Intrepid.
I have an external hard drive (WD) that is hooked up by a USB cable. Small files transfer fine, and the HD works flawlessly in vista. However, using Ubuntu, During large file transfers, the system randomly locks up.
At the start of the transfer the transfer looks smooth (i.e. the ##mB transfered increments steadily), then it starts jumping up instead of steadily increasing (i.e. it jumps from 90mB to 120 then to 150, etc..) and then it stops at a certain point. Usually this point is over 500MB, but other than that it seems to be random (even when transfering the same file, it stops at different points). When I try to close the transfer or cancel it, the window does not respond. Then after a few seconds the desktop background and the top/bottom ubuntu panels become frozen. I can restart GDM, but doesn't solve the problem - GDM doesn't load properly - only loads background I think. I try to shutdown, and it wouldn't do it... GDM closes but then it gives me some text (something about SDC), and sits there, so I have to do a forced reboot. The message that it gives me wasn't very helpful anyway, it made little sense. If someone wants to diagnose the issue properly, please let me know and I'll try it again and tell you the message. Also, ubuntu won't start up again unless I shut off the external hard drive and turn it on again.

A few times I was able to close the transfer (can't remember how, but I remember it involved waiting for like 5 minutes). Then I did "lsusb" and the hard drive doesn't show up. I tried shutting off the HD, turning it on, and it won't show up, and I couldn't mount it in ANY WAY So I ended up having to reboot the system and the HD before they can work again.
Here are my specs:
Thinkpad Notebook T61, 2.0Ghz, 2GB 667Mhz DDR ram, X3100 video card, usb 2.0, 80GB SATA internal drive
Ubuntu: Intrepid Ibex (did fresh Intrepid install, and applied ONLY critical updates --> still problem)
uname -a:
Linux ls1 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

Tomas Plesek (tomas-plesek) wrote :

Seems like no reports of this problem for jaunty , tagging as fix released

Changed in ubuntu:
status: Confirmed → Fix Released
Angus (eightmillion) wrote :

This bug is affecting me on Karmic. I've been trying to copy several gigs of files to a drive mounted with cifs. It starts with mouse movements getting jerky and then the computer locks up hard. If I catch it happening in time, I can kill the xserver and recover.

Changed in ubuntu:
status: Fix Released → New
David Tombs (dgtombs) wrote :

Hi Angus, you're probably experiencing a different issue. Please submit a new report with "ubuntu-bug smbfs". Thanks!

Setting back to Fix Released.

Changed in ubuntu:
status: New → Fix Released
mcasperson (matthewcasperson) wrote :

I've experienced a similar problem in Ubuntu 10.10. Transferring large amounts of data from a Windows PC to a Samba share caused my netbook to lock up. The problem occurred copying many small files, and also one large one. Ubuntu would completely freeze: the mouse would not move, the screen saver (if one was running) would freeze and CTRL-ALT-F# keys would not drop back to a terminal.

The Ubuntu 10.10 install was only a day old (so I hadn't installed many additional packages).

After several attempts to copy the files I ended up setting up an FTP server on Windows and accessing the files that way. Transferring the files over FTP worked flawlessly, so it probably is not a hardware issue.

Since completing the file transfer I have not had any further lockups in Ubuntu.

The notebook is an ASUS 1201N, and I'm running the 64 bit version of Ubuntu. The only Samba related change I made was to add the following line to smb.conf (as per the bug listed at https://bugs.launchpad.net/ubuntu/+source/samba/+bug/375593):
name resolve order = lmhosts wins bcast host

David Tombs (dgtombs) wrote :

Hi mcasperson,

There have been many changes to Ubuntu since this report was filed. If you'd like to pursue a bug report, please file a new one with 'ubuntu-bug samba'. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers