[needs-packaging] pcsx2

Bug #103791 reported by Remo Quintino on 2007-04-06
110
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

PCSX2 is a PlayStation 2 emulator that attempts to allow PS2 code to be executed on your computer.

URL: http://www.pcsx2.net/
License: GPLv2

I've built some versions of pcsx2 in my local system, making also a deb package, but actually it's quite hard to have a working deb because the pcsx2 looks in it's dir for plugins or bios paths...
I should look better at it...

Elez (elez) wrote :

PCSX2 0.9.4 is out. It's release for Linux as source code only. It really needs to be packaged. I couldn't get it to work properly.

Kels (echukwuogor) wrote :

I second the *request* of the above named. Please....

I don't think it would be hard to package it without the BIOS and plugins. PCSX2 <strong>doesn't</strong> require these plugins or BIOSes to compile. I don't know DEB packaging yet but if I ever learn how to do that, I'll try making packages. [I would love to be able to play Final Fantasy X without having to pay for anything :P]

The BIOS is copyrighted so the user needs to get it themselves (if you have a PS2, you can use a tool to copy the PS2 firmware, including BIOS and DVD-ROM firmware, to BIN files). The plugins can be found on the PCSX2 website and other sites (linux versions and windows versions are usually available for the most popular plugins).

Prefix (prefix100) wrote :

I second this request

Adilson Oliveira (agoliveira) wrote :

Ok, this is my first attemp to make a package from scratch so, be gentle :)
The orig.tar.gz

Adilson Oliveira (agoliveira) wrote :

The .diff

Adilson Oliveira (agoliveira) wrote :

The .dsc

Adilson Oliveira (agoliveira) wrote :

Sorry, I got the wrong session.
There goes the corrrected files

Adilson Oliveira (agoliveira) wrote :

Resending files after corrections and wipping by a Steven Kowalik.

Adilson Oliveira (agoliveira) wrote :

Sorry about that, last minute correction.

Adilson Oliveira (agoliveira) wrote :

... and the dsc file.
The binaries can be found at my PPA: https://edge.launchpad.net/~agoliveira/+archive

Adilson Oliveira (agoliveira) wrote :

The packages above are for Hardy. There's no chance to include it on on the proper release but will schedule to be on Intrepid Ibex (8.10).

  • unnamed Edit (1.0 KiB, text/html; charset=ISO-8859-1)

Great man! Thanks!

On Tue, Apr 8, 2008 at 4:24 AM, Adilson Oliveira <email address hidden>
wrote:

> The packages above are for Hardy. There's no chance to include it on on
> the proper release but will schedule to be on Intrepid Ibex (8.10).
>
> --
> [needs-packaging] pcsx2
> https://bugs.launchpad.net/bugs/103791
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
http://obsidianlake.wordpress.com/ - Personal blog (in English)
http://imiplacelinux.wordpress.com/ - Blog despre Linux pentru utilizatorii
romani de Linux

hikaricore (hikaricore) wrote :

So, anyone working on getting this done or no?

Adilson Oliveira (agoliveira) wrote :

I'll take care to update and see if we can have it for 9.10. The one at the repository is quite old.

Adilson Oliveira (agoliveira) wrote :

Just to be clear, there is no pcsx2 in any repository but my PPA. I'm working on updating it.

Adilson Oliveira (agoliveira) wrote :

Unfortunately, it won't make it to Karmic. I didn't have the time to go over the proper procedures in time for that but I'll update the package and keep it updated on my PPA.

No problem.

Off topic question. What's the status of FFX working with PCSX2?

On Thu, Sep 3, 2009 at 5:11 AM, Adilson Oliveira<email address hidden> wrote:
> Unfortunately, it won't make it to Karmic. I didn't have the time to go
> over the proper procedures in time for that but I'll update the package
> and keep it updated on my PPA.
>
> --
> [needs-packaging] pcsx2
> https://bugs.launchpad.net/bugs/103791
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
My project - http://obsidianlake.org/
My blog and OL updates - http://blog.obsidianlake.org/

Andre Terra (andreterra) wrote :
Tim Dobson (tdobson) wrote :

I'm another person who would be very happy by a package in lucid :)

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Paul-Sebastian Manole

Paul-Sebastian Manole
Electronic Security Systems Technician at SHIFT 3 SECURITY S.R.L.
Romania

Confirm that you know Paul-Sebastian Manole
https://www.linkedin.com/e/isd/1040409541/ygb5pGNp/

------
(c) 2010, LinkedIn Corporation

benpicco (benpicco) on 2010-03-22
tags: added: emulator

So... any news on this?

Changed in ubuntu:
status: Confirmed → New
Mackenzie Morgan (maco.m) wrote :

When superceding old uploads, can you please delete the incorrect versions? Very confusing to look at the patch list on the side and see 4 files of the same name.

Changed in ubuntu:
assignee: MOTU (motu) → nobody
status: New → Triaged
Mackenzie Morgan (maco.m) wrote :

Is there some (good) reason why:
1. the source package is being sent to Ubuntu instead of Debian (which would allow more users to benefit)
2. REVU is not being used
?

Loïc Martin (loic-martin3) wrote :

@Mackenzie: in answer to 1 and 2, I think a simple look at the diff.gz explains why ;)

For everybody following the thread, I'll try to summarize why nobody has packaged pcsx2 in Debian and Ubuntu (maybe it will encourage others to pick up some of the work instead of just "me too" comments):

1. Licensing work:

It's an emulator, and not a simple one. Usually "emulator" equals "mess of copyright/license problems", with code borrowed here and there without everyone's notice. Thus, if you plan to package it, you'll probably spend a few days of full time work just tracking everything (the fact any project says all copyright is ok means nothing if even one file comes from somewhere else), maybe only to realise there won't be any way to get the package distributed. Not speaking about pcsx2, but there's other open source emulators not packaged for just this reason, while the relevant projects still distributes the binaries. That's also probably the reasons lots of emulator developers prefer closed-source, since open sourcing would reveal the licensing issues :(

In the case of pcsx2, you'll also have to make sure the necessary plugins are redistributable, since they come from other sources and can have different licenses. Only one necessary plugin affected, and you end up with a useless program.

2. Programming:

Last I checked, pcsx2 wasn't designed with Linux packaging in mind, more like a "drop where you've got user rights and start/configure". Packaging it would entail modifying the code so it uses XDG environment variables.

The Linux side off side has also been neglected, with development mostly targeting Windows. There's at least one Pcsx2 developer that has started to improve the Linux emulator (for at least a year IIRC), but it's still not up to par with Windows. Thus any prospective packagers might have been turned off by the fact that the emulator couldn't run any games they threw at it, even though the Pcsx2 compatibility list says they should run perfectly. How do you test your package is good if you don't know which games should work on Linux?

Any one with the skills to fix 2. will probably spend its time more wisely just committing to Pcsx2's Google Code, rather than first loosing many hours with 1.

Since Pcsx2 is developing at a frantic pace, there'll probably be a time when it can be reasonably packaged in a Linux distribution. We'll have to see with 0.9.7, but it depends how much the Linux side will have improved by that time (and if 1. can be done).

With 1. being the main showstopper, there's something people can do even if they're not a developer. Grab the latest Pcsx2 code from Google Code, open an editor and check every file license one by one, documenting your findings on a wiki page so others can see the work done and help and write a decent copyright file (http://dep.debian.net/deps/dep5/). Check also what are the required plugins for Linux, and if they can be redistributed.

  • pcsx_licenses Edit (14.2 KiB, text/plain; charset="UTF-8"; name="pcsx_licenses")
  • zlib.h Edit (56.4 KiB, text/x-chdr; charset="UTF-8"; name="zlib.h")

Hmm yes, licensecheck says that a LOT of the files lack copyright info. All
the zlib/ ones say "see zlib.h" which does not say GPLv2, though the person
who made the package uploaded here lists only GPLv2 in debian/copyright.

So OK, yes, it isn't ready to go on REVU (though really, that is the correct
place to upload source packages and get feedback and sponsorship, *not*
here!) or into Ubuntu or Debian at all. When it is brought up to par, I do
recommend submitting it to Debian, not just Ubuntu.

For reference, I'm attaching licensecheck's output and zlib.h so you can all
see the license in there.

Adilson Oliveira (agoliveira) wrote :

When I did the first packaging attempt above, waaaay back in time, at first I just created a starting point with no intention to go all the way to include on the distro. After that I thought about it but never really was happy with the MOTU/REVU process (I think Loic remembers how I feel about it ;) ) so, if you guys want to do a proper work, please go ahead. It's being ages that I don't do any packaging and I have no interest at this time to do it.

Mackenzie Morgan (maco.m) wrote :

Woops, just read https://wiki.ubuntu.com/Bugs/HowToTriage#Needs%20Packaging%20Bugs, and realised I shouldn't have set this to Triaged.

Changed in ubuntu:
status: Triaged → Incomplete
John Vivirito (gnomefreak) wrote :

We need more info on the Licenses (best for author of the package to fix this rather than us.) before we can do anything with this. Did anyone contact author about this?
I purposely did not use the word "upstream" as people automatically say upstream == Debian but i mean the people that provide the source code. I will wait to mark it confirmed until there has been activity on the license work/contact

papukaija (papukaija) on 2010-06-25
tags: removed: emulator
gregory (gregory-hainaut) wrote :

Hi,

I'am currently working on pcsx2. We are aware that licenses are not totally clean. Work is on going to ameliorate the situation as much as possible.

Note: we provide a script to create a nice tarball for packaging feel free to use it. Under the trunk: debian-unstable-upstream/create_pcsx2_tarball_from_svn_repository.sh

Gregory

gregory (gregory-hainaut) wrote :

Quick status update: most of the license issues are now fix.

If you use the debian-unstable-upstream/create_pcsx2_tarball_from_svn_repository.sh script (which removed bad licences files), about 10 files are missing copyright information (on the graphics plugings). I'm currently trying to contact the author to confirm the gpl2 license.

Note: all licenses informations are sum up in the file debian-unstable-upstream/copyright

description: updated
Changed in ubuntu:
status: Incomplete → New
gregory (gregory-hainaut) wrote :

License update:

The remaining license issues was fixed. If you use the create_pcsx2_tarball_from_svn_repository.sh script, you will get a 100% copyright open-source tarball :)

Enjoy,
Gregory

gregory (gregory-hainaut) wrote :

Hello,

You are going to release the version 0.9.8 of PCSX2 in 1 or 2 month. The linux version is a little less compatible than the MS version but I was able to finish several games ;).
svn checkout http://pcsx2.googlecode.com/svn/branches/0.9.8 PCSX2-0.9.8

An example to create a PCSX2 package is provided under debian-upstream directory. The package include 2 small patch to change default configuration path to be more FHS compliant (I hope!). A script (create_pcsx2_tarball_from_svn_repository.sh) to create a nice tarball without licences issue (and remove useless stuff) is also provided. Others stuff are pretty standards. You could also get it from ours PPA:https://launchpad.net/~gregory-hainaut/+archive/pcsx2.official.ppa

Unfortunately the graphic plugins depends on nvidia-cg-toolkit which is non-DFSG free but free enough to be distributed in the non-free Debian repository. Moreover PCSX2 requires at least an SSE2 capable CPU. We make this choice because older CPU without SSE2 will not be able to run PCSX2 anyway. PCSX2 is only 32bits compatible (because it is a virtual machine like flash), it would need multi-arch support to be easily installable on amd64.

We are open to heard any suggestion that could ease the packaging of our beautiful emulator.

Best regards,
Gregory

gregory, with the release of Ubuntu 11.10 a few days ago, we now have multi-arch support. I believe this means that the way is paved :).

gregory (gregory-hainaut) wrote :

Hello Chauncellor,

Multiarch is not yet perfect. There are some packages that need to be converted. Note I only use Debian so it might not be 100% accurate.

1/ Wx: complex, I send a patch few days ago on Debian
2/ nvidia-cg-toolkit: medium, package need to be split into 3 parts.
3/ portaudio: easy, I send a patch few days ago on Debian
4/ libglew: easy, libglew1.6 was converted on Debian (a patch of mine too). I think ubuntu have 1.5 in main. Upstream release 1.7 and debian package is orphaned.
5/ sdl: complex, it will probably be converted with others ia32-libs.

Cheers,
Gregory

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
kroq-gar78 (kroq-gar78) wrote :
Changed in debian:
status: New → Fix Released
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting, and to those who have worked on this over the years.

As noted from the Debian bug report, pcsx2 was packaged in Debian a while back. Afterwards it was automatically synced to Ubuntu where it has been available since 15.10 (https://launchpad.net/ubuntu/+source/pcsx2/+publishinghistory).

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.