kinit: No resume image

Reported by robertpolson on 2007-04-05
48
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I and other people have been having this kinit problem with the latest Ubuntu 7.04 Beta when Ubuntu loads

when I start my Ubuntu I get this message:

Code:

 Loading, pease wait...
Kinit: name_to_dev_t(/dev/disk/by-uuid/3c7a8f65-b709-494a-92f1-318a38220def)= sda5(8,5)
kinit: No resume image, doing normal boot...

(Then it takes about 2 minutes for me from this step on for it to continue loading)

We have a discussion going on here, but no one know what the problem is:

http://ubuntuforums.org/showthread.php?t=385869

ProblemType: Bug
Architecture: i386
Date: Wed Apr 4 23:20:48 2007
DistroRelease: Ubuntu 7.04
Uname: Linux laptopishe 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

muzzamo (murray-waters) wrote :

Ok my experience is the similar to above.

It seemed to happen after resizing some fat32 partitions using the gparted livecd and then booting back.

Also before these messages i had the message:

lookup_group: specified group 'nvram' unknown

Which i fixed by adding nvram to the system group or something (I followed instructions from elsewhere on the web).
I can also continue the boot by hitting ctrl-alt-delete at this point and killing this process.

muzzamo (murray-waters) wrote :

Forgot to mention in running Feisty Beta, been keeping it up to date as well.

permafrost91 (permafrost91) wrote :

Having the same problem on my X60 ... hitting Ctrl-Alt-Delete when this happens though will skip the long wait and continue the boot-up process (it's annoying having to intervene like this though).

Dennis Laumen (dennislaumen) wrote :

Same problem here. I've got this problem on a HP 510 laptop. I don't think I had this problem when I installed the beta but got it later on. I'm not sure whether or not this started happening when I installed some updates or when I first used the hibernate functionality.

I'm confirming this bug.

The exact console message:

Starting up...
Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/c7c2ccbc-18c3-4137-9cb2-f5cc7220f73) = sda7(8,7)
kinit: trying to resume from /dev/disk/by-uuid/c7c2ccbc-18c3-4137-9cb2-f5cc7220f73
kinit: no resume image, doing normal boot...

-----
Is this written to any file or something? Because having to write this entire text is a bit of a burden :-P

I can't remember having this problem with the Feisty Beta CD, it was only after I installed later updates that the error occured.

Oh, and sda7 is my swap partition, that might matter.

man initramfs-tools :

resume
On install initramfs-tools tries to autodetect the resume parti‐
tion. On success the RESUME variable is written to
/etc/initramfs-tools/conf.d/resume. The boot variable noresume
overrides it

sudo nano /etc/initramfs-tools/conf.d/resume

add # in front of RESUME=XXXXx-XXX-XXXX-XXXX

save

sudo update-initramfs -u

i'have make a mistake don't add #

https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/66637/comments/23

just check the swap partition

sudo fdisk -l | grep swap
sudo vol_id -u /dev/???

UUID must be the same in

/etc/initramfs-tools/conf.d/resume

sudo update-initramfs -u

seby (sebit) wrote :

same problem with feisty and kernel 2.6.20-15-generic on hp pavillion dv6000

Starting up...
Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/fb61edb2-d142-45f9-a749-60ed015993cd) = sda3(8,3)
kinit: trying to resume from /dev/disk/by-uuid/fb61edb2-d142-45f9-a749-60ed015993cd
kinit: no resume image, doing normal boot...

fb61edb2-d142-45f9-a749-60ed015993cd is uuid of my swap partition (sda3) and is the same in /etc/initramfs-tools/conf.d/resume

It seems my swap partition has lost its UUID after upgrading to feisty.
Both my swap, root and home partition are stored on a lvm partition.
After my upgrade to feisty I get the same error at boot and freeze for a minute.
When my computer later boots the mount command doesn't report any swap being mounted.

Tried to check my UUIDs as suggested above:

per@pers:~$ sudo vol_id -u /dev/mapper/Ubuntu-Root
d1cd2492-6b03-4476-96a9-c764c1770eff

per@pers:~$ sudo vol_id -u /dev/mapper/Ubuntu-Swap

which returns nothing.

Tonatiuh (huitanot) wrote :

I have this problem also with https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/102982
I think it starts to happen after I make an hibernation or suspension. After that I never have this problem.
I was so happy that it used to boot really fast... and now is just... terrible.

Dara Adib (daradib) wrote :

I have a similar problem (Kubuntu Feisty 32-bit), with the same message, except the message only stays for about three seconds before coming on to the K Login Manager. Still annoying, however.

Dara Adib (daradib) wrote :

Just to add that there is nothing wrong with my message, because it is normal. But it is still annoying because I do need to be notified every time I did not hibernate (which is practically always).

scottvan (laylathedog) wrote :

Joining this thread with the same problem, it seems.

On boot, I get a black screen (after the Ubuntu orange progress bar completes). I have to hit ctrl-alt-F1, and I get:

Starting up...
Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/5e3234bd-e136-49b5-b97c-663caddc0481) = sda2(8,2)
kinit: trying to resume from /dev/disk/by-uuid/5e3234bd-e136-49b5-b97c-663caddc0481
kinit: no resume image, doing normal boot...
resume: libgcrypt version: 1.2.3
resume: could not stat the resume device file
        please type in the file name to try again or press ENTER to boot the system:

I'm using Ubuntu Feisty.

My machine's history is a little different than what I saw. Approximately 10 days ago I upgraded from 7.04 to Feisty. It went pretty well. I have been installing updates as they came along.

Two days ago the console freezes, the mouse stops working, but the clock is still running. Eventually I found that the problem (at least for me) was related to Grub. Through trial and error I figured out that Grub now had swapped its root indicators. i edited my menu.lst and swapped all hd1 to hd0 and the hd0 to hd1. Things improved and I could boot but failures were occuring later. Eventually I edited /etc/fstab and converted the UUID references back to device references for all file systems (/dev/sdb2 instead of UUID).

My suspicion is that it is a combination of Grub and the use of UUID references. If I could figure out how to get kinit to use hard references (/dev/sdb70 instead of 'by-uuid" references i suspect the issue will be resolved.

I'm no expert but the majority of my problems seemed to be related to Grub's indexing my drives differently even though I haven't changed the cables to them.

Sorry I failed to read the previous entry before submitting it. Hopefully this one is clearer.

My machine's history is a little different than what I saw here. Approximately 10 days ago I upgraded from Edgy to Feisty. Things ran pretty well for a few days. I have been installing updates as they came along.

Two days ago the console freezes, the mouse stops working, but the clock is still running. Eventually I found that the problem (at least for me) was related to Grub. Through trial and error I figured out that Grub now had swapped its root indicators (hd0 is now references as hd1 and hd1 is not referenced as hd0). i edited my menu.lst and swapped all hd references (hd1 to hd0 and hd0 to hd1.) Things improved and I could boot but failures were occurring later after trying to mount the additional file systems. Eventually I edited /etc/fstab and converted the UUID references to device references for all file systems (/dev/sdb2 instead of UUID). Everything seems to boot well at this point. My sound is no longer working when I'm fully booted though I get all the music related to the login, but none of the audio, even the bell, seem to work now.

My suspicion is that it is a combination of Grub and the use of UUID references. If I could figure out how to get kinit to use hard references (/dev/sdb7 instead of 'by-uuid" references i I suspect the issue will be resolved.

I'm no expert but the majority of my problems seemed to be related to Grub's indexing my drives differently even though I haven't changed the cables to them

Hey guys... ur going to hate how easy it is to fix this... I was trying to fix the sound on my computer when I uninstalled something I wasn't supposed to and this problem occurred where I got the same output u guys did...but go ahead and login at the screen where it gives u that message...then type:

# su (then type in ur password)
# sudo apt-get install ubuntu-desktop
# reboot

Then your computer will reboot and you will be back into your computer...send me an email and let me know if this works for you or if it doesn't... <email address hidden>

permafrost91 (permafrost91) wrote :

I still have ubuntu-desktop installed ...

Zorael (zorael) wrote :

I experience this pause as well, can be up to about 40 seconds on my system. Works fine otherwise though.

I tried changing the root= reference in GRUB to /dev/sda6 instead of its uuid, and also the entries in fstab, but neither had any noticeable effect.

familjen@svart:/dev/disk/by-uuid$ echo && echo -- swap disk: && sudo fdisk -l | grep swap && echo -- disk/by-uuid symlink && ls -l /dev/disk/by-uuid | grep sda6 && echo -- resume uuid: && cat /etc/initramfs-tools/conf.d/resume

-- swap disk:
/dev/sda6 14091 14589 4008186 82 Linux swap / Solaris
-- disk/by-uuid symlink
lrwxrwxrwx 1 root root 10 2007-08-07 00:54 e6af80cf-ad65-469f-8f99-8a22c5e156f2 -> ../../sda6
-- resume uuid:
RESUME=UUID=e6af80cf-ad65-469f-8f99-8a22c5e156f2
familjen@svart:/dev/disk/by-uuid$

So the resume file seems to be pointing towards the right uuid, too...

Zsuzsanna Sukosd (dsokus) wrote :

Confirming the bug. This is very annoying... It happened for me after I installed Automatix, I suspect it's perhaps something to do with the automatic (rw) window partition mounts....

Ricky Hewitt (rickyhewitt) wrote :

Confirming the bug, however I do not receive any delay. I just get the kinit warning and the boot process continues almost instantly.

Might be worth noting that I have no windows mounts at all, it is just a pure (x)ubuntu system using XFS partitions.

blekos (ilias) wrote :

I confirm this bug. I am having a dual boot (XP) laptop sony vaio SZ3xp and using Kubuntu.
I have come accross with this back twice in Feisy (final release no beta) and now with Gutsy.
I cannot boot to linux, and I cant spend more to time to reinstall it for 3rd time...

Msg: Kinit: trying to resume from /dev/disk/by-uuid/
Kinit: no resume image

how can i change the boot uuid?

stef123 (stephane-auneau) wrote :

Hello
When i start my ubuntu (kernel 2.6.16.20), there are no problems but after STARTING UP .....in a black screen, i ve got this

    kinit : name_to_dev_t(/dev/disk/by-uuid/f8/..........) = sda5 (8.5)
    kinit : No resume image, doing normal boot.....
    stef login...

And i must do STARTX to go to my desktop

When i'm on my desktop and i want to shut down, i have got only HIBERNATE and "GO TO THE WAKING" (sorry for the traduction)

And i don't known what i can do, if you have an idea

Thanks

stef123 (stephane-auneau) wrote :

EDIT
I don't telll.....This problem come after i install my sound card with the last alsa driver (15rc2)
In my folder ASOUND, i must copy this

  pcm.!default {
  type hw
   card 0
   }

   ctl.!default {
    type hw
   card 0
   }

I don't if the problem come with this commande...

Thanks

stef123 (stephane-auneau) wrote :

it s ok for me

Ric Flomag (ricflomag) wrote :

Still in Gutsy RC

jan37 (dotjan-msn) wrote :

Same error "no resume image..." with Gutsy on Fujistu Siemens Amilo Pi 1536 laptop with ATI mobilty x1400

Viriatus (rmpp) wrote :

same problem here on a Acer Aspire 1692WLMI

i'm using Ubuntu 7.10 and this never happened in previous versions. It takes 2 minutes to boot if i don't press any key. After choosing Ubuntu in GRUB (i have dual boot with XP in the same disk) screen goes black for 2 minutes, i don't see any progress bar then the login screens appears 2 minutes later. If i press immediately ctr-alt-f1 i boot normally, it displays "kinit: No resume image, doing normal boot.."

Stefanauss (stefanauss) wrote :

Same problem on Gutsy new installation on HP Pavillion DV4295EA.
There is no boot spash screen, just a black screen. It occurs almost two minutes to run into GDM.

I workarounded the boot delay by just removing "spash" kernel option in /boot/grub/menu.lst. It performs "normal boot" immediately after displaying this error.

Stefanauss (stefanauss) wrote :

Sorry.
"splash" kernel option.

Lo_pescofi (corbieres) wrote :

I have the similar problem :

System freeze on boot just after checking File System. When I do "Alt-F1", I see :
"kinit : trying to resume from /dev/.....
kinit : No resume image, doing normal boot"

I have this bug with Ubuntu Gutsy (x64) and kubuntu Gutsy (i586).
I have 2 sata disk and I meen it's a sata disk identification problem.

Nicolas Borboën (ponsfrilus) wrote :

Same problem here....
ASUS A7VB-R002H

I read on a french forum (here: http://forum.ubuntu-fr.org/viewtopic.php?pid=1254149#p1254149) that formating the swap + changing the fstab can work (not tested yet).

Ric Flomag (ricflomag) wrote :

The tip on the French forum worked for me, though i had to fix https://bugs.launchpad.net/ubuntu/gutsy/+source/ubiquity/+bug/150930 to have the splash logo showing up. Probably there is not any relation between the two bugs, just commenting in any case someone would be in the same situation.

sewerraccoon (sewerraccoon) wrote :

I've got this on Gutsy X86.

I got this problem with Gutsy on my HP Pavilion dv5035 laptop. Did a fresh install and it started happening.

ilexius (t-schlueter) wrote :

Hi all,
I had this problem as well. But I changed the xserver conf and this stopped my Kubuntu 7.10 from booting. After switching back to the old xorg.conf the system started just like before.

I hope this helps!
Thomas

thekip (thekip) wrote :

I've the same problem, I have to switch to console (CTRL+F1) in order for my laptop to boot.

Alexey (lordeep) wrote :

it's a pity, but I've got the same problem in 7.10.
It seemed, that it was happened when I change my usplash
sudo update-alternatives --config usplash-artwork.so
sudo update-initramfs -u
I haven't ever seen some solution of this problem.
ps Have a big desire to return in stable debian, :(

Just I had this problem when i installed Ubuntu 7.10 The Gutsy Gibbon to my laptop Toshiba Satellite A135-S2326: Intel Celeron M, Display Size 15.4" widescreen, Graphics ATI Radeon Xpress 200M, I had to switch to console (CTRL+F1) so I checked the link mentioned by Ric Flomag: https://bugs.launchpad.net/ubuntu/gutsy/+source/ubiquity/+bug/150930

And first at all I noticed my usplash.conf was different of the Screen Resolution of the xorg.conf file so I commented the original values of the usplash.conf and I changed to
# Usplash configuration file
#xres=1280
#yres=1024
xres=1280
yres=800

And I followed the explanation of bluwShark who found the solution in https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/63558:

1) Change the resolution in /etc/usplash.conf to 1024x800 # like my xorg.conf
2) Add vga=791 to the kernel line in /etc/boot/menu.lst
3) sudo update-initramfs -u -k `uname -r` # In my case 2.6.22-14-generic

Restart it and ready! my laptop right now is booting fine, I hope this can help you guys.

itcrowd (itcrowd) wrote :

Hi All,

First time mailer, so please be nice.

I had this problem, early this week, after a software update, tried everything to remove it, but to no avail, so I bit the bullet and re-installed.

It's taken 2 full days to get it back to normal.

But I just installed compiz-fusion- manager, played a bit and noticed the following. (I'm not saying this has anything to do with compiz, but I only noticed this after installing compiz).

If it click 'Ctl-Alt-F1' I get the exact same 'Black screen of death' back again, complete with kinit error message.

When I click 'Ctl-Alt-F7' , I get my proper desktop.

Clicking 'Clt-Alt F2 to F6, creates tabbed 'terminal windows' using tty2 to tty6.

Seeing as I don't have this problem anymore (thankfully), I can't check if this would fix it, so this might be helpful to some one who reads this notice. (like I did myself a couple of times).

Best regards to all, your help makes it all the more enjoyable.

itCrowd.

Richard James (rjames13) wrote :

With Ubunutu 7.10 after I changed both my motherboard and video card. I got the following
Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/489a5508-8b66-471c-a111-4db9076dd216) = hdc5(22,5)
kinit: trying to resume from /dev/disk/by-uuid/489a5508-8b66-471c-a111-4db9076dd216
kinit: No resume image, doing normal boot...

X would not start automatically

I first fixed up the kinit error message by
$ sudo swapoff /dev/hdc5
where /dev/hdc5 is my swap partition
$ sudo mkswap /dev/hdc5
$ sudo update-initramfs -u

That fixed the kinit error but did not make X start automatically.

I tried the upslash resolution == xorg.conf resolution: does not work
I tried apt-get remove ubuntu-desktop apt-get install ubuntu-desktop: does not work
Then I tried to from the console run gdm, which works until you restart
Then I tried looking for the script to start gdm
I was in the /etc/init.d directory and I noticed I had gdm and gdm~ which means that something had altered gdm and had left a backup.
The difference between these was the added line
insmod /lib/modules/$(uname -r)/misc/fglrx.ko

I said before that I had changed graphics cards. I had changed from ATI to NVIDIA and had removed all traces of the ATI drivers so this was crashing gdm on startup

commenting out that line made my system start X on boot again
Maybe I could have apt-get remove gdm and apt-get install gdm to achieve the same results.

Note that the Kinit no resume error is unrelated to the X windows not starting automatically.

Lo_pescofi (corbieres) wrote :

I fix the bug !
You can see my post here : http://linuxfr.org/forums/10/23481.html (in french)
It's the field fspassno in /etc/fstab that be fix at 1. It must be fix at 2 for vfat partition !

thekip (thekip) wrote :

Thx Lo_pescofi, I've managed to get it fixed too. Wrote a post about it (in english) here:
http://www.thekip.nl/2007/12/18/kinit-no-resume-image-fixed/

bardo (ozanturkkan) wrote :

Loading, please wait...
kinit: name_to_dev_t(/dev/disk/by-uuid/489a5508-8b66-471c-a111-4db9076dd216) = hdc5(22,5)
kinit: trying to resume from /dev/disk/by-uuid/489a5508-8b66-471c-a111-4db9076dd216
kinit: No resume image, doing normal boot...

for this problem just write:

sudo apt-get install ubuntu-desktop

and then reboot.

Deffe (marc-defossez) wrote :

I've the same problem after my laptop died from a empty battery.
    Dell Latittude C840
    Kunbuntu 7.10

After the KUNBUNTU display with moving horizontal bar, text is displayed "Starting K Display manager" as normal.
Also as normal services are started. Before teh problem, after the text message "Starting Common Unix Printing Ssytem Cupsd OK" the KDE graphical login sceen was showed.
Now after a few seconds, and after first going blank, the text messages continue with "Starting powernowd OK".
this end with:
  Starting up....
  Loading, please wait ...
  kinit: name_to_dev_t(/dev/disk/by-uuid/2524f0f6-424d-418f-bdd1-e59bd659e776+ = sda5(8,5)
  kinit: trying to resume from /dev/_the_same_path_as_above
  kinit: no resume image, doing normal boot ...
login prompt

I've read all previous messages and tried all proposed solutions. I still have the problem.

sudo fdisk -l | grep swap ---> This list shows that sda5 is my swap
sudo vol_id -u /dev/.... ---> This replies the 2524......776 number.
The UUID line in this file:"/etc/initramfs-tools/conf.d/resume" is the same number as in the reported.line commands above.
sudo update-initramfs -u
reboot --> problem stays.

changing the last '0' by a '2 in the UUID line in /etc/fstab then
sudo update-initramfs -u
reboot --> problem stays

sudo apt-get install ubuntu-desktop is doing a lot of stuff but at the end a reboot keeps the problem.

/etc/X11/xorg.conf file has for the display different screen resolution settings.
The lines in the /etc/usplash.conf have the numbers for X and Y that fit one of the settings from teh xorg.conf file.
Changing one or both doesn't do anything after reboot.

Has somebody some exta hints to try?

Can somebody mail (<email address hidden>) me his /etc/X11/xorg.conf file for comparing with mine?
   In this file on my PC two entries exist: Monitor and Screen.
   Both have different settings
   At tthe end of the file both refer to teh same "monitor1"

Kind regards,

Marc

Deffe (marc-defossez) wrote :

Hi,

Thanks Pascal for the file.
My impression that something is wrong with this file was correct.

The problem did not occur due to the sudden shutdown due to an empty battery.
Just before that I enabled in KDE “System Settings” “Monitor & Display” the second display by clicking the tick box in the “Size, Orientation & Positioning” tab.

This wrote strange settings into the /etc/X11/xorg.conf file.
Due to that I had the problem message we have all seen.

Once this file changed, following the example I got from Pascal, the PC booted again as usual.

I can repeat the error when I perform the same actions as described above.

The attached xorg.conf file is the one brewed by KDE.

Marc

Deffe (marc-defossez) wrote :

Hi again,

I'm now that far that I know what's causing the error.
What I don't know is why this error is generated at the place it is, in my opinion the reason has no relation with the error.

When I modified the display settings from within KDE, KDE wrote a new xorg.conf file.
In that file one line is wrong, afein it is not wrong but it points to something that doesn't exist on my PC.
   Result: the error.

In the file, the one I previousely attached, KDE wrote a section referring as: Section "Module" with some load commands.
Following 'man xorg.conf' this loads some modules from a path /usr/lib/modules/fonts or /usr/lib/modules/extensions.

On my PC there is no /usr/lib/modules directory and therfore the error appears.
    Don't know why it is not there.

When I just remove that line (set of line) from the xorg.conf file it works.

To simply solve the problem,
     X should ignore the sections where it can't find the files or section for and not error out into text mode.
     Maybe a warning could be generated to show the man behind the machine that something is not working as set.

Marc

dopple (graham-macleod) wrote :

I get this using Gutsy 7.10 on a Toshiba a100 laptop. Have tried almost everything but to no avail.
using
sudo apt-get install ubuntu-desktop
just returns that ubuntu-desktop is already the most up to date version

Namain (namain) wrote :

I confirm this bug on an Acer Aspire 1694 WLMi.

My fix:
edit /etc/usplash.conf to use my laptop's true resolution. It was detected as 1280x1024, but my laptop's native resolution is 1280x800.
then I ran the following commands
$ sudo swapoff /dev/sda2
to turn off my swap partition
$ sudo mkswap /dev/sda2
to rebuild my swap partition
$ sudo update-initramfs -u
to rebuild my initial boot image to use my new, rebuilt swap partition

Benjamin Roch (phibre) wrote :

Thanks to NAMAIN - this solved the problem.
Changing the resolution for the usplash is imo only for seeing the startup screen - it is not directly related to the init problem. The swap thing solved this problem.

Thanks for the help - btw I think that this problem is only caused by sata disks?

benjamin

Namain (namain) wrote :

Nope, this problem was happening on my Acer Aspire 1694, which has an older 2.5 inch ATA disk.

ThorbjørnTux (martsummsw) wrote :

Having the same problem sometimes.
I logon in commandline - runs startx and shutdown.

Afterwards I can normally boot into kdm (kubuntu 7.10 - fully upgraded) - but sometimes the problem comes back.
Have tried many of the above things without permanent succes.

I do NOT have a SATA-disk ! - but still it might have something to do with the hardware.
ASUS K8U-X with AMD Turion S754 1.6 Ghz.

Graeme Hewson (ghewson) wrote :

I encountered the problem with 7.10. The system has been fine since I upgraded from Feisty, but after changing the screensaver and monitor power saving timeouts, I hit recurring a problem where the mouse and keyboard were frozen, though the system was otherwise up. The last time, I found the keyboard was in fact available, so I pressed ctrl-alt-del and selected "Resume" from the KDM screen. After that, I hit the problem described here.

I didn't see any changed config files, and I figured this was only a temporary problem, so I didn't want to make any changes to my config files if I could avoid it. Norbert BRONDEAU mentioned the initramfs-tools man page, with the quote: "The boot variable noresume overrides it" [the RESUME variable].

So I rebooted, and used the grub "e" command to edit the "kernel" line and append "noresume". The system then booted OK... relief! I did a normal shutdown and rebooted to check the system was back to normal, and it was. YMMV, of course.

W. Kyle White (kyle-white) wrote :

I've had this happen twice now and noticed it was when I was trying to use hibernation or standby. Does anyone know anything about this or any way to avoid it in the future if it's related to hibernation? I've fixed it twice now on two different computers. One time I used the grub console I think, but this time it was much easier in that all I did was type

# sudo dpkg-reconfigure -phigh xserver-xorg

I'm definitely going to try this first if I ever run into this problem again.

Eric Entin (whoknew) wrote :

I had this issue when I installed the kde4 package and set kdm to be my default desktop manager, decided I didn't like it, and uninstalled the kde4 package. The next time I booted, I got this error message. I was able to get into gdm by typing startx at the console, and from there I was able to install the kde4 package again, use the prompt it gives you on install to set my default DM to be GDM, and then uninstalled kde4 again. Admittedly, there was probably a more direct way to set my default DM to be gdm, but that was the only way I could figure out how to do it. That fixed the problem. This was on Hardy.

Kobus Prinsloo (kprinsloo) wrote :

I tried the suggestion of W.Kyle White

# sudo dpkg-reconfigure -phigh xserver-xorg

Unfortunately it made absolutely no difference for me. I keep getting the No Resume Image message. I am running Ubuntu 8.04
(Linux laptop 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux)

IKT (ikt) wrote :

I am running ubuntu 8.04 server edition, and have this issue. However it generally doesn't hold the machine up, it just continues to boot as normal.

SMADdie86 (driess94) wrote :

I am using Xubuntu 8.04 and I have the same problem for the second time.

The first time I didnt really try much, I tought I messed something up after wanting to
install the music notation program thats included in the software list.
So I deleted the linux partitions and reinstalled xubuntu within an hour or so.

Now the second time I got the problem after that Xubuntu got the last updates
availible. I didnt really looked at what the update included so sorry.

The main pain is that I dont get back in the GUI, im stuck in the kernel.

Checking the UUID in the /etc/initramfs-tools/conf.d/resume file
witch is correct folowed by
sudo update-initramfs -u
didn't work

sudo apt-get install ubuntu-dektop
didn't work

when I type startx in ny possible way (lowercase and uppercase first letter uppercase etc)
I get an error like program not found (sorry currently working under windows)

I wonder if the xconf file would be the solution with me but I dont think so,
because evrything was working perfect on 1280 x 768 for the last few days.

I have a Fujitsu Siemens Esprimo V5535 laptop
with dual boot Vista / Xubuntu.

If anyone can give me any other idea's to try?
And if possible with some explaination of what I should type.
Im kinda of a linux noob, but Im able and willing to learn he he,
Xubuntu works better then Vista he he.

Or else in case that nothing works does anyone know
where Opera saves his bookmarks under Xubuntu?
Then I will mount my ntfs partition to backup some links.

\Many thanks in advance from the dutch guy.

I just had the same problem while running intrepid alpha 5 on amd64. As far as I know the only things changed since the last normal boot were that I removed virtualbox and an old kernel image. I didn't use suspend or sleep. Now it happens on every boot.

sudo update-initramfs -u did fix the problem, but that shouldn't be necessary.

jaktar (superdragonpoop) wrote :

I received this on Kubuntu 32 8.04.1.

I attempted "startx" after logging in. X failed to start with an error of "no screens detected".
I simply went to /etc/X11/ and did "sudo cp xorg.conf.failsafe xorg.conf" and then did another "startx".

abuhijleh (ala-a) wrote :

I did the following and it worked just perfect:

# sudo apt-get install ubuntu-desktop

boclozz (boclozz) wrote :

thanks guys specially bardo .......

i use # sudo apt-get install ubuntu-desktop

and it works fine
...

Bryce Nesbitt (bryce2) wrote :

Confirming. I installed a second HDD for a few minutes, partitioned it, removed it, and my main system fails with the kinit problem. Ugbuntu!

No matter how I mess with my swap partition, I get stuck at this step:

# sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-2.6.24-26-server
cryptsetup: WARNING: found more than one resume device candidate:
/dev/sda5
UUID=XXXXXXXX-XXXXX-XXXXX

https://bugs.launchpad.net/ubuntu/+source/uswsusp/+bug/108230
https://bugs.launchpad.net/ubuntu/+source/uswsusp/+bug/146894

papukaija (papukaija) on 2011-06-29
tags: removed: candidate release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments