macbook volume control doesn't work

Bug #102818 reported by Dan Bishop on 2007-04-04
74
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned

Bug Description

Using the volume control keys on the macbook doesn't control the volume. It seems to adjust treble/bass...

ProblemType: Bug
Architecture: i386
Date: Wed Apr 4 12:03:25 2007
DistroRelease: Ubuntu 7.04
Uname: Linux apple 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Dan Bishop (danbishop) wrote :

Running alssmixer whilst adjusting the volume shows that the master volume bar is the one adjusted, however, it i definitely not the volume that is being adjusted. Low volume levels and mute sound very bassy and higher volumes sound like the treble setting has been increased a lot...

From alsmixer (might be useful?):
│ Card: HDA Intel │
│ Chip: SigmaTel STAC9221 A1 │
│ View: [Playback] Capture All │
│ Item: Master [dB gain=-22.50, -22.50]

Dan Bishop (danbishop) wrote :

alsamixer*

Indeed. Master channel adjusts treble, while Front channel adjusts bass. BTW, when headphones are plugged in, Master has no effect, while Front simply adjusts the volume.

Dan Bishop (danbishop) wrote :

Any chance of a fix? We're scarily close to release...

infodesk06 (nickycommerce) wrote :

Confirmed (again) on a MacBook CoreDuo 2.0Ghz, Feisty Fawn clean instal.
I am a total *nix newbie, but I suspect that the sound device is behaving as if it were a multi-speaker system, and not a set of stereo speakers. That is, I suspect that the device is advertising the third or center speaker to the driver as a third speaker (rather than acting nice and just summing the stereo signal), and the driver is then getting confused and not reporting the speakers accurately to alsamixer. Has this problem been addressed elsewhere? It's well past release time now...

Ali Sabil (asabil) wrote :

I also experience the same problem, any chance to get a fix?

infodesk06 (nickycommerce) wrote :

Since I've only been on *nix for about a month, I can't put the ideas into practice, but I think the fix will involve changing the config file for alsamixer, and telling it to regard the computer as a surround sound system. If anyone can point me to a manual, i'll try to do it myself. Thanks.

I don't know if it's so easy, but I didn't find any documentation about alsa config file;
so I contacted alsa developpers; One of them simply answered that the current version of alsa in Ubuntu is far too old; There are tons of bugfixes for Intel HD audio in last versions of Alsa...

infodesk06 (nickycommerce) wrote :

If it can be confirmed that the latest version of alsa does not have this behavior with macbook hardware this bug can be dropped. Anyone to confirm?

I can confirm the same odd mixer behavior in the newest upstream stable version of alsa, 1.0.14, compiled for feisty on a MacBook 2.0 Core Duo first generation.

Dan Bishop (danbishop) wrote :

I can also confirm this is still the same in gutsy...

Daniel T Chen (crimsun) wrote :

None of you have attached relevant /proc/asound/card0/codec* contents, thus making this bug report useless.

 Thanks, Daniel, for your comment. This bug is 3 months old, and nobody asked about supplementary informations.
Actually, I'm unable to provide the output you asked; I switched back to another system...

Ubuntu is a fabulous distro: 10 years old 3com network cards supported in Linux 2.2 kernels doesn't work anymore with ubuntu kernels; don't know why...

Ali Sabil (asabil) wrote :

please find attached the output of /proc/asound/card0/codec#0

Dan Bishop (danbishop) wrote :

This is still broken in gutsy. Is there anything we can provide/do to help fix this?

This happens with the remote control the macbook has.

What log/files you may need to debug this?

thanks

Dan Bishop (danbishop) wrote :

This bug is still present in gutsy, what can we provide to help fix this? It's pretty much rendering ubuntu on macbooks unusable :(

PieterIserbyt (pieter-iserbyt) wrote :

My computer is a macbook second gen dual core.
I just upgraded to new kernel in Ubuntu Feisty: 2.6.20-16-generic #2 SMP Fri Aug 31 00:55:27 UTC 2007 i686 GNU/Linux

Before sound controls worked ok, only sound recording from built-in mic would not work.
After upgrading to this new kernel i get similar problems as described above:

I control the sound output via gnome-volume-control

- master controls treble
- front controls bass
(both put to zero mutes the sound)

- recording from front mic works!!
- recording from microphone jacked into mic outlet stopped working

- headphones no longer give sound output
  -> unless:
    - selecting "line in as output" in the switches tab
    - using surround to control the output volume
    - jacking the headphones in the mic outlet
    - putting master and front to mute to mute the sound on the speakers

attached my codec#0

maybe this helps you along. if you need more output, i'm happy to help...

Ali Sabil (asabil) wrote :

to me it seems like when there is a fix that fixes the 1st gen macbooks, it breaks the 2nd gen macbooks, and vice versa.

Dan Bishop (danbishop) wrote :

There doesn't seem to have been any devs active on this bug for a long time. Is there anything we can do to encourage you? :)

muller (listening) wrote :

This seems like it should be at least a medium priority for the project. Anyone?

Dan Bishop (danbishop) wrote :

Unfortunately the bug is already set to medium priority but no one seems to be able to do anything about it :(

nnutter (nnutter) wrote :

I was playing with alsamixer and at least for my computer PCM seems to control actual volume so I just went into System > Preferences > Sound and selected PCM to control via keyboard. Also, I can confirm that on my first gen MacBook Master does control treble.

I'm on Gutsy, I don't know if this is available in Feisty.

worked here. Huge thanks!

PieterIserbyt (pieter-iserbyt) wrote :

Recently seems something has changed in the volume control on my 2nd gen macbook (see https://bugs.launchpad.net/ubuntu/+bug/102818/comments/18).

The headphones seem to work again:
- headphones on headphone jack worl
- sound volume is controlled by the "surround" volume
- headphones are correctly detected and mutes sound

unfortunately, don't know exactly when or why it started working/improved.

nnutter - Thanks.

Using your suggestion of controlling PCM using keyboard fixed my issue.

I can confirm on a Dell XPS M170 that the Master controls the treble and the Master Mono controls the bass.

>>nnutter - Thanks.

>>Using your suggestion of controlling PCM using keyboard fixed my issue.

>>I can confirm on a Dell XPS M170 that the Master controls the treble and the Master Mono controls the bass.

I was mistaken. :) I actually bound the Master and Master Mono to the keyboard. So now when I use my volume feature keys it controls them both at simultaneously.

Johann Prieur (jprieur) wrote :

Same problem on macbook 2nd generation

Dan Bishop (danbishop) wrote :

Original report is for 2nd generation MacBook, sorry, probably should've mentioned that before.

David Balažic (xerces8) wrote :

I have the "mute does not work on Master" problem on this system,
using ubuntu 7.10 final o386 CD :

root@ubuntu:~# dmidecode -s system-manufacturer
Hewlett-Packard
root@ubuntu:~# dmidecode -s system-product-name
HP Compaq nw8440 (RH415EA#ABB)
root@ubuntu:~# dmidecode -s system-version
F.0F

the audio hardware (judging by mixer window) is :
HDA Intel (Alsa mixer)

the loaded kernel module is snd_hda_intel

Voluma change works fine.

David Balažic (xerces8) wrote :

Here is my /proc/asound/card0/codec#0 file begin :

Codec: Analog Devices AD1981
Address: 0
Vendor Id: 0x11d41981
Subsystem Id: 0x103c30a3
Revision Id: 0x100200

(not posting as attachment as Firefox has some issues with it ???)

Ali Sabil (asabil) wrote :

I installed the linux-backports-modules and this fixed the issue.

Can anyone confirm it's fixed in linux-backport-modules ?

Marco Nolden (marco-n) wrote :

Can't confirm it's fixed by linux-backport-modules (MacBook 2nd gen). Behaviour changed though: Master is completely ignored, "Front" is the already described high-pass center, "Surround" is mapped to the low-pass speakers.

David Balažic (xerces8) wrote :

8.04 alpha 4 works fine on my HP nw8440
except the delayed mute problem, reported as bug 188322

Slick (slick666) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu development version, this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect <bug #>, and any other logs that are relevant for this particular issue.

I've confirmed that this is not a problem on a MacBook 1,1 using the kernel Linux Macintel 2.6.31-20-generic

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers