Package cedarview-graphics-drivers

Reported by Jani Monoses on 2012-07-17
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Intel Cedarview based platforms need closed source binary drivers for accelerated graphics support.
There are 3 packages to be added to 12.04 to support laptops using such hardware.

Description: Intel binary Xorg driver for GMA3600 (Cedarview) GPUs.
 This package contains the proprietary firmware and drivers
 needed to run hardware accelerated Open GLES 2.0 under X11
 on Intel Cedarview based hardware.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1025716/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Steve Langasek (vorlon) wrote :

Hi Jani,

Minor nit with the packaging:

override_dh_auto_configure:
        echo "/usr/lib/intel-cdv" > usr/lib/ld.so.conf

This is never cleaned up; so if you try to build the binary package and then build the source package from the same directory, the source build will fail with this error:

dpkg-source: info: local changes detected, the modified files are:
 cedarview-graphics-drivers-20120608/usr/lib/ld.so.conf

Could you add usr/lib/ld.so.conf to debian/clean in a subsequent upload to quantal?

There's a bigger bug with the dh_shlibdeps override, though:

E: cedarview-graphics-drivers: missing-dependency-on-libc needed by usr/lib/i386-linux-gnu/dri/pvr_dri.so and 21 others

I think the dh_shlibdeps invocation you want in debian/rules is this:

override_dh_shlibdeps:
        dh_shlibdeps -l$(CURDIR)/debian/cedarview-graphics-drivers/usr/lib/intel-cdv/ -- --warnings=6

+ a couple extra build-dependencies on the runtime libs.

(btw, the original file had buggy whitespace, so dh_shlibdeps wasn't being called at all...)

however, even with this, dpkg-shlibdeps is returning errors:
dpkg-shlibdeps: error: couldn't find library libGL.so.1 needed by debian/cedarview-graphics-drivers/usr/lib/intel-cdv/dri/pvr_dri.so (ELF format: 'elf32-i386'; RPATH: '').
[...]
dpkg-shlibdeps: error: couldn't find library libGL.so.1 needed by debian/cedarview-graphics-drivers/usr/lib/i386-linux-gnu/dri/pvr_dri.so (ELF format: 'elf32-i386'; RPATH: '').

(which also points to a duplicated file within the package)

This seems very strange that a package providing GLES should be linked to a libGL.so that it doesn't provide. Do you know if this is correct? If it is, what package should the build-dependency be against?

If I -X the pvr_dri.so, I get the following set of shlibdeps:

libc6 (>= 2.15), libdrm2 (>= 2.4.16), libgcc1 (>= 1:4.1.1), libpciaccess0, libpixman-1-0, libstdc++6 (>= 4.1.1), libudev0 (>= 147), libwsbm1, libx11-6, libxext6, libxfixes3,

That's a non-trivial list, so I think the package should really be fixed to call dh_shlibdeps correctly.

Attached is a prospective fix for this. Can you look this over and see if this makes sense to apply to the package? If so, please reupload with these changes included.

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Steve Langasek (vorlon) wrote :

I've had verbal confirmation from James Leddy that he's tested with the full set of packages in precise-proposed and the install test worked through jockey; the packages have been copied to precise-updates, so considering this resolved.

Changed in ubuntu:
status: Confirmed → Fix Released
tags: added: verification-done
foutdroule (foutdroule) wrote :

atom

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers