Cannot set WEP key for Edimax EW-7318USg

Bug #102521 reported by Roman Polach on 2007-04-03
2
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I want to connect a notebook edgy box to a net by a USB Wifi adapter Edimax EW-7318USg,
using System->Administration->Networking I have set IP,mask,gw,
ESSID and WEP key and I check /etc/network/interfaces that all is
correctly set, but "iwconfig wlan0" shows that "Access Point: Not-Associated"
and "Encryption key:off" ! Itried manualy tweak /etc/network/interfaces to use
"restricted mode" but it did not help.
I also tried manually set it again by "iwconfig wlan0 key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX"
or "iwconfig wlan0 key restricted XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX" but neither
of them works... (still see "Access Point: Not-Associated" and "Encryption key:off")

Note: AP has set to use WEP, "shared mode" and MAC-address whitelist (that I filled correctly)
and I am able to connect it from another box (edgy, XI-626 PCI wifi) with the same settings
(with "restricted" tweak of /etc/network/interfaces or "iwconfig wlan0 key restricted ...")
successfuly.

Roman Polach (rpolach) wrote :

This is also problem in Feisty beta...

----

but I found some information on http://swik.net/GNOME/Planet+GNOME/Murray+Cumming:+Linux-compatible+wireless+USB+adaptor:+Results/x1t3 :

Edimax 7318USg

    * Ubuntu 6.06 “Dapper”: Not recognized in any UI, and not even by iwconfig on the command-line.
    * Ubuntu 6.10 “Edgy”: wlan0 and wmaster0 show up in the Networking control panel but can not make connections. Shows up as “Unknown USB Vendor Specific Interface” in the Network Manager applet, without a list of access points.
    * Ubuntu Feisty (herd 3): Recognized by Network Manager applet, but could not connect to any of the listed access points, which are also listed as having zero strength. Listed as wlan0 and wmaster in the Networking control panel, but trying to configure either crashes the control panel.

Note that this worked on all vesions of Ubuntu with the supplied driver, though you’ll need to use the command-line to connect, and you’ll need to rebuild the driver every few months when your Linux kernel is automatically updated.

-----

as I understand it needs a driver from supplier... and I found debian-targeted one on their supplied CD at last

so this bug should be probably changed to "include Edimax EW-7318USg driver in Ubuntu"...

what I do not know:
1) if is that supplied driver open-source
2) if it helps that I would upload the driver here..

Roman Polach (rpolach) wrote :

In Feisty beta the problem is a little bit different:

WEP key can be set thru commandline iwconfig,
but essid and associated access point is still not shown..
this could be also set thru iwconfig, but not in the same command as setting wep key.
After that, it shows all of: wep key, essid, access point,
and when I run "ifconfig wlan0 up" it shows interface is up,
but it does not work anyway, giving "Network unreachable"
e.g. for "route add default ..."

Roman Polach (rpolach) wrote :

in feisty (beta) is also strange, that after adapter is plugged onto usb,
both modules rt2500usb and rt73usb are loaded..

Roman Polach (rpolach) wrote :

...blacklisting rt2500usb did not help

Roman Polach (rpolach) wrote :

Another note in my monologue:
The problem is still present in Feisty final.

Roman Polach (rpolach) wrote :

Did anybody notice this report please?

Roman Polach (rpolach) wrote :

Is this bug related to https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/110590 ?
It seems to be wpasupplicant related and this bug is about WPA connection but maybe it is a common problem with rt* driver...

Roman Polach (rpolach) wrote :

I have solved this problem by installing rt73 driver from nightly builds http://rt2x00.serialmonkey.com/wiki/index.php/Downloads
by steps described here http://ubuntuforums.org/showthread.php?t=400236 and changing restricted mode to open...
So this bug should be probably marked as dupe of https://bugs.launchpad.net/ubuntu/+bug/115994

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers