Comment 2 for bug 1021684

Ubuntu 9.04 is no longer supported. The currently supported versions are 10.04 (server), 11.04, 11.10 and the latest 12.04 LTS. I would recommend using any flavour of ubuntu 12.04. The later the version, the most recent the kernel is and the better hardware support gets.